aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/flowdesigner/Makefile1
-rw-r--r--games/ggz-kde-client/Makefile10
-rw-r--r--lang/q/Makefile1
-rw-r--r--science/gerris/Makefile1
4 files changed, 5 insertions, 8 deletions
diff --git a/devel/flowdesigner/Makefile b/devel/flowdesigner/Makefile
index 4e62b0b78716..67aefe591697 100644
--- a/devel/flowdesigner/Makefile
+++ b/devel/flowdesigner/Makefile
@@ -39,6 +39,7 @@ CFLAGS+= -O0
post-patch:
@${REINPLACE_CMD} -e 's|tools examples|tools|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|src pixmaps|src|g' ${WRKSRC}/vflow/Makefile.in
+ @${FIND} ${WRKSRC} -name configure | ${XARGS} ${REINPLACE_CMD} -e 's|echo aout|echo elf|'
post-install:
.if !defined(NOPORTDOCS)
diff --git a/games/ggz-kde-client/Makefile b/games/ggz-kde-client/Makefile
index 5e2ff9c3645a..9fff9ab919bd 100644
--- a/games/ggz-kde-client/Makefile
+++ b/games/ggz-kde-client/Makefile
@@ -27,12 +27,6 @@ MAN6= compcal.6 ggzap.6 keepalivecontrol.6 \
kggz.6 kgrubby.6 shadowbridge.6
post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}| ; s|echo aout|echo elf|' ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= depends on libggz which does not build on 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/q/Makefile b/lang/q/Makefile
index 61f80e866b03..a5ffa5930e85 100644
--- a/lang/q/Makefile
+++ b/lang/q/Makefile
@@ -91,6 +91,7 @@ post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${GREP} -l "^examplesdir" | ${XARGS} ${REINPLACE_CMD} -e \
"s;[(]pkgdatadir[)]/examples;(datadir)/examples/@PACKAGE@;"
+ @${FIND} ${WRKSRC} -name configure | ${XARGS} ${REINPLACE_CMD} -e 's|echo aout|echo elf|'
@${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} \
${GREP} -l "<malloc\.h>" | ${XARGS} ${REINPLACE_CMD} \
-e "s,<malloc\.h>,<stdlib.h>,"
diff --git a/science/gerris/Makefile b/science/gerris/Makefile
index d97a4bb01567..7c4a25b560c0 100644
--- a/science/gerris/Makefile
+++ b/science/gerris/Makefile
@@ -42,6 +42,7 @@ USE_GETOPT_LONG= yes
CONFIGURE_ARGS+= --disable-mpi
post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
${WRKSRC}/src/Makefile.in