aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/mozart/Makefile13
-rw-r--r--lang/mozart/distinfo6
-rw-r--r--lang/mozart/files/patch-aclocal.m412
3 files changed, 23 insertions, 8 deletions
diff --git a/lang/mozart/Makefile b/lang/mozart/Makefile
index 26b5ce1d5a8f..c00d8f0cd019 100644
--- a/lang/mozart/Makefile
+++ b/lang/mozart/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mozart
-PORTVERSION= 1.2.1.20010816
+PORTVERSION= 1.2.3.20011201
CATEGORIES= lang tk83
MASTER_SITES= ftp://ftp.mozart-oz.org/pub/mozart/${PORTVERSION}/tar/ \
ftp://ftp.sics.se/pub/mozart/${PORTVERSION}/tar/
@@ -17,9 +17,7 @@ DISTFILES+= ${MOZART_DOCS}
MAINTAINER= mathiasp@virtual-earth.de
-BROKEN= "Does not detect bison correctly"
-
-BUILD_DEPENDS= emacs:${PORTSDIR}/editors/emacs20
+BUILD_DEPENDS= emacs:${PORTSDIR}/editors/emacs21
LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm \
tk83.1:${PORTSDIR}/x11-toolkits/tk83
@@ -36,7 +34,7 @@ USE_XLIB= yes
# mozart's configure will not find the right install
# when configuring as root.
CONFIGURE_ENV= INSTALL=${CHMOD}
-CONFIGURE_ARGS= --prefix=${PREFIX}/lib/oz --disable-doc \
+CONFIGURE_ARGS= --prefix=${PREFIX}/lib/oz --disable-doc \
--with-inc-dir=${LOCALBASE}/include/tcl8.3,${LOCALBASE}/include/tk8.3 \
--with-lib-dir=${LOCALBASE}/lib --with-tcl-lib=${LOCALBASE}/lib \
--with-tk-lib=${LOCALBASE}/lib \
@@ -53,6 +51,11 @@ pre-extract:
@${ECHO} ----------------------------------------------------
@${ECHO}
+post-patch:
+ cd ${WRKSRC}/contrib/gtk && autoconf213 -l ${WRKSRC}
+ cd ${WRKSRC}/platform/emulator && autoconf213 -l ${WRKSRC}
+ cd ${WRKSRC}/platform/tools/gump/ozflex && autoconf213 -l ${WRKSRC}
+
post-install:
.if !defined(NOPORTDOCS)
@${TAR} --unlink -xzpf ${DISTDIR}/${MOZART_DOCS} \
diff --git a/lang/mozart/distinfo b/lang/mozart/distinfo
index 777a5ef6b650..6815239696fc 100644
--- a/lang/mozart/distinfo
+++ b/lang/mozart/distinfo
@@ -1,3 +1,3 @@
-MD5 (mozart-1.2.1.20010816-src.tar.gz) = e066f1312214ed8b71c96f6981d600c3
-MD5 (mozart-1.2.1.20010816-doc.tar.gz) = acce77d8abaafe3caef0d047fde1cb26
-MD5 (mozart-1.2.1.20010816-doc.tar.gz) = acce77d8abaafe3caef0d047fde1cb26
+MD5 (mozart-1.2.3.20011201-src.tar.gz) = 4650e0367b3e36b6de81adf659b3bfd5
+MD5 (mozart-1.2.3.20011201-doc.tar.gz) = 90a03c7dba8ade9e80761a904c9b5636
+MD5 (mozart-1.2.3.20011201-doc.tar.gz) = 90a03c7dba8ade9e80761a904c9b5636
diff --git a/lang/mozart/files/patch-aclocal.m4 b/lang/mozart/files/patch-aclocal.m4
new file mode 100644
index 000000000000..90059fb770d8
--- /dev/null
+++ b/lang/mozart/files/patch-aclocal.m4
@@ -0,0 +1,12 @@
+--- aclocal.m4.orig Sat Mar 23 15:44:56 2002
++++ aclocal.m4 Sat Mar 23 15:44:17 2002
+@@ -572,7 +572,8 @@
+ oz_tmp_ok=no
+ AC_MSG_WARN([$YACC is not GNU bison])
+ else
+- OZ_PROG_VERSION_CHECK(oz_tmp_ok,$YACC,OZ_VERSION_BISON)
++ # OZ_PROG_VERSION_CHECK(oz_tmp_ok,$YACC,OZ_VERSION_BISON)
++ oz_tmp_ok=yes
+ fi
+ if test "$oz_tmp_ok" = yes; then
+ oz_cv_YACC=$YACC