aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/phpua-bf/Makefile21
-rw-r--r--games/phpua-bf/pkg-plist5
2 files changed, 16 insertions, 10 deletions
diff --git a/games/phpua-bf/Makefile b/games/phpua-bf/Makefile
index 517b3093ec81..ab10fd1e4a94 100644
--- a/games/phpua-bf/Makefile
+++ b/games/phpua-bf/Makefile
@@ -7,21 +7,19 @@
PORTNAME= phpua-plugin_bf
PORTVERSION= 1.1.0b
+PORTREVISION= 1
CATEGORIES= games www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= phpua
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= babak@farrokhi.net
COMMENT= A Battlefield 1942 plugin for phpUA
-RUN_DEPENDS= ${LOCALBASE}/${PHPUA}/index.php:${PORTSDIR}/games/phpua-engine
-
-BROKEN= does not install due to dependency problem in games/phpua-engine
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2006-09-03
+BUILD_DEPENDS= ${LOCALBASE}/${PHPUA}/index.php:${PORTSDIR}/games/phpua-engine
+RUN_DEPENDS= ${BUILD_DEPENDS}
# Some variables you can change
-PHPUA?= www/data/phpua
+PHPUA?= www/phpua
PHPUA_USER?= ${WWWOWN}
PHPUA_GROUP?= ${WWWGRP}
@@ -44,10 +42,13 @@ pre-everything::
${ECHO_MSG} '-------------------------------------------------------------------------')
.endif
+do-extract:
+ @ ${MKDIR} ${WRKSRC}
+ @ cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${EXTRACT_AFTER_ARGS}
+
do-install:
- @ ${CP} -R ${WRKDIR}/plugins ${PREFIX}/${PHPUA}/
- @ ${CP} -R ${WRKDIR}/templates ${PREFIX}/${PHPUA}/
- @ ${CHOWN} -R ${PHPUA_USER}:${PHPUA_GROUP} ${PREFIX}/${PHPUA}
+ @ ${CHOWN} -R ${PHPUA_USER}:${PHPUA_GROUP} ${WRKSRC}
+ @ ${CP} -R ${WRKSRC}/ ${PREFIX}/${PHPUA}/
@ ${ECHO_MSG} ""
@ ${ECHO_MSG} "* Files have been installed in"
@ ${ECHO_MSG} "* ${PREFIX}/${PHPUA}"
diff --git a/games/phpua-bf/pkg-plist b/games/phpua-bf/pkg-plist
index 80b6c837798a..8f9d1fde0071 100644
--- a/games/phpua-bf/pkg-plist
+++ b/games/phpua-bf/pkg-plist
@@ -11,6 +11,11 @@
%%PHPUA%%/templates/wap/plugin_bf/info.tpl
@exec chown -R %%PHPUA_USER%%:%%PHPUA_GROUP%% %D/%%PHPUA%%
@dirrm %%PHPUA%%/templates/wap/plugin_bf
+@dirrmtry %%PHPUA%%/templates/wap
@dirrm %%PHPUA%%/templates/javascript/plugin_bf
+@dirrmtry %%PHPUA%%/templates/javascript
@dirrm %%PHPUA%%/templates/default/plugin_bf
+@dirrmtry %%PHPUA%%/templates/default
+@dirrmtry %%PHPUA%%/templates
@dirrm %%PHPUA%%/plugins/plugin_bf
+@dirrmtry %%PHPUA%%/plugins