aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/mpich/Makefile14
-rw-r--r--net/mpich2/Makefile14
2 files changed, 20 insertions, 8 deletions
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index 1c65b3c88cb9..ccf88df7c6d5 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -20,14 +20,20 @@ DIST_SUBDIR= mpich
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -cflags="${CFLAGS}" -prefix=${PREFIX}/mpich
+.include <bsd.port.pre.mk>
+
# Include support for ssh client
USE_SSH?= YES
# Use ssh instead of rsh
-.if defined(USE_SSH) && ${USE_SSH} == YES || \
- exists(${PREFIX}/bin/ssh) && \
+.if ${OSVERSION} >= 400016 && \
+ exists(/usr/bin/ssh) && \
+ (!defined(USE_SSH) || ${USE_SSH} != NO)
+CONFIGURE_ARGS+= -rsh="/usr/bin/ssh"
+.elif defined(USE_SSH) && ${USE_SSH} == YES || \
+ exists(${LOCALBASE}/bin/ssh) && \
(!defined(USE_SSH) || ${USE_SSH} != NO)
RUN_DEPENDS+= ssh:${PORTSDIR}/security/ssh
-CONFIGURE_ARGS+= -rsh="${PREFIX}/bin/ssh"
+CONFIGURE_ARGS+= -rsh="${LOCALBASE}/bin/ssh"
.endif
ALL_TARGET=
@@ -178,4 +184,4 @@ MAN4= CLOG_Finalize.4 CLOG_Init.4 CLOG_Output.4 CLOG_commtype.4 \
MPE_TagsEnd.4 MPE_Update.4
INSTALL_TARGET= install
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index 1c65b3c88cb9..ccf88df7c6d5 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -20,14 +20,20 @@ DIST_SUBDIR= mpich
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -cflags="${CFLAGS}" -prefix=${PREFIX}/mpich
+.include <bsd.port.pre.mk>
+
# Include support for ssh client
USE_SSH?= YES
# Use ssh instead of rsh
-.if defined(USE_SSH) && ${USE_SSH} == YES || \
- exists(${PREFIX}/bin/ssh) && \
+.if ${OSVERSION} >= 400016 && \
+ exists(/usr/bin/ssh) && \
+ (!defined(USE_SSH) || ${USE_SSH} != NO)
+CONFIGURE_ARGS+= -rsh="/usr/bin/ssh"
+.elif defined(USE_SSH) && ${USE_SSH} == YES || \
+ exists(${LOCALBASE}/bin/ssh) && \
(!defined(USE_SSH) || ${USE_SSH} != NO)
RUN_DEPENDS+= ssh:${PORTSDIR}/security/ssh
-CONFIGURE_ARGS+= -rsh="${PREFIX}/bin/ssh"
+CONFIGURE_ARGS+= -rsh="${LOCALBASE}/bin/ssh"
.endif
ALL_TARGET=
@@ -178,4 +184,4 @@ MAN4= CLOG_Finalize.4 CLOG_Init.4 CLOG_Output.4 CLOG_commtype.4 \
MPE_TagsEnd.4 MPE_Update.4
INSTALL_TARGET= install
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>