aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/squeeze/Makefile9
-rw-r--r--archivers/squeeze/pkg-plist2
-rw-r--r--archivers/thunar-archive-plugin/Makefile4
-rw-r--r--audio/thunar-media-tags-plugin/Makefile8
-rw-r--r--devel/thunar-vcs-plugin/Makefile9
5 files changed, 12 insertions, 20 deletions
diff --git a/archivers/squeeze/Makefile b/archivers/squeeze/Makefile
index dd430cfc5997..b6d0ee770439 100644
--- a/archivers/squeeze/Makefile
+++ b/archivers/squeeze/Makefile
@@ -3,7 +3,7 @@
PORTNAME= squeeze
PORTVERSION= 0.2.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= archivers xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}
@@ -19,10 +19,10 @@ LIB_DEPENDS= thunar-vfs-1:${PORTSDIR}/x11-fm/thunar-vfs
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USES= pkgconfig gettext
+USES= pkgconfig gettext pathfix desktop-file-utils
USE_XFCE= configenv libutil thunar
USE_XORG= x11
-USE_GNOME= gnomehack gtk20 glib20 intltool intlhack desktopfileutils
+USE_GNOME= gtk20 glib20 intltool intlhack
USE_BZIP2= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
@@ -44,7 +44,4 @@ post-patch:
@${REINPLACE_CMD} -e "s|docs||g" ${WRKSRC}/Makefile.in
.endif
-post-install:
- @-update-desktop-database
-
.include <bsd.port.mk>
diff --git a/archivers/squeeze/pkg-plist b/archivers/squeeze/pkg-plist
index defd766df8b9..c1304c03c929 100644
--- a/archivers/squeeze/pkg-plist
+++ b/archivers/squeeze/pkg-plist
@@ -55,5 +55,3 @@ share/applications/squeeze.desktop
@dirrmtry libexec/thunar-archive-plugin
@dirrmtry include/libsqueeze-0.2/libsqueeze
@dirrmtry include/libsqueeze-0.2
-@exec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || /usr/bin/true
diff --git a/archivers/thunar-archive-plugin/Makefile b/archivers/thunar-archive-plugin/Makefile
index 80b7df2734be..6839ccdb7467 100644
--- a/archivers/thunar-archive-plugin/Makefile
+++ b/archivers/thunar-archive-plugin/Makefile
@@ -4,7 +4,7 @@
PORTNAME= thunar-archive-plugin
PORTVERSION= 0.3.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= archivers xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=src/thunar-plugins/${PORTNAME}/${PORTVERSION:R}
@@ -18,7 +18,7 @@ GNU_CONFIGURE= yes
USE_XFCE= configenv libexo thunar
USES= gettext
INSTALLS_ICONS= yes
-USE_GNOME= desktopfileutils intltool
+USE_GNOME= intltool
USE_GMAKE= yes
.include <bsd.port.mk>
diff --git a/audio/thunar-media-tags-plugin/Makefile b/audio/thunar-media-tags-plugin/Makefile
index f1da972d8ae7..e09283668cc8 100644
--- a/audio/thunar-media-tags-plugin/Makefile
+++ b/audio/thunar-media-tags-plugin/Makefile
@@ -3,22 +3,22 @@
PORTNAME= thunar-media-tags-plugin
PORTVERSION= 0.2.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=src/thunar-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
-COMMENT= A Media Tags Plugin
+COMMENT= Media Tags Plugin
LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib
-USES= pkgconfig gettext
+USES= pkgconfig gettext pathfix
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack gtk20 intltool intlhack
+USE_GNOME= gtk20 intltool intlhack
USE_XFCE= configenv libexo thunar
USE_AUTOTOOLS= libtool
diff --git a/devel/thunar-vcs-plugin/Makefile b/devel/thunar-vcs-plugin/Makefile
index 1eda5677b427..45dafc98be8a 100644
--- a/devel/thunar-vcs-plugin/Makefile
+++ b/devel/thunar-vcs-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= thunar-vcs-plugin
PORTVERSION= 0.1.4
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= devel xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/thunar-plugins/${PORTNAME}/${PORTVERSION:R}
@@ -16,10 +16,10 @@ USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GNOME= desktopfileutils gnomehack gtk20 glib20 intltool intlhack
+USE_GNOME= gtk20 glib20 intltool intlhack
USE_XFCE= configenv libexo libutil thunar
INSTALLS_ICONS= yes
-USES= pkgconfig
+USES= pkgconfig pathfix
LDFLAGS+= -L${LOCALBASE}/lib
@@ -56,7 +56,4 @@ CONFIGURE_ARGS+=--disable-subversion
PLIST_SUB+= SVN="@comment "
.endif
-post-install:
- @-update-desktop-database
-
.include <bsd.port.mk>