aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/p5-Image-Imlib2/Makefile8
-rw-r--r--palm/pose/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/graphics/p5-Image-Imlib2/Makefile b/graphics/p5-Image-Imlib2/Makefile
index 8c8b3f18370c..368a2b3ff16d 100644
--- a/graphics/p5-Image-Imlib2/Makefile
+++ b/graphics/p5-Image-Imlib2/Makefile
@@ -22,4 +22,10 @@ PERL_CONFIGURE= yes
MAN3= Image::Imlib2.3
.include "../../devel/p5-Module-Build/inc.build.mk"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= 'Does not compile'
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/palm/pose/Makefile b/palm/pose/Makefile
index fe7c723d15a8..8be41e1ec0e0 100644
--- a/palm/pose/Makefile
+++ b/palm/pose/Makefile
@@ -30,10 +30,16 @@ CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
CFLAGS=-DBROKEN_VIRTUAL_DEFAULT_ARGUMENTS=1 \
LIBS="${PTHREAD_LIBS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Does not compile"
+.endif
+
post-install:
${MKDIR} ${PREFIX}/share/pose
${INSTALL_DATA} "${WRKSRC}/../ROMTransfer/Source/ROM_Transfer.prc" ${PREFIX}/share/pose
@${SED} -e 's#/usr/local#${PREFIX}#g' ${PKGMESSAGE}
${CP} -Rp ${WRKDIR}/Skins_v1.9 ${PREFIX}/share/pose/skins
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>