aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/ruby-rbprof/Makefile6
-rw-r--r--devel/ruby-rbprof/pkg-plist2
2 files changed, 5 insertions, 3 deletions
diff --git a/devel/ruby-rbprof/Makefile b/devel/ruby-rbprof/Makefile
index ebf6156273cb..8dbe376b3fbc 100644
--- a/devel/ruby-rbprof/Makefile
+++ b/devel/ruby-rbprof/Makefile
@@ -21,12 +21,14 @@ COMMENT= A flexible Ruby profiler
USE_RUBY= yes
-NO_BUILD= yes
+NO_BUILD= yes
do-install:
- ${MKDIR} ${PORTDOCS}${RUBY_DOCDIR}/rbprof
+.ifndef NOPORTDOCS
+ @${MKDIR} ${PORTDOCS}${RUBY_DOCDIR}/rbprof
${INSTALL_DATA} ${WRKSRC}/README ${PORTDOCS}${RUBY_DOCDIR}/rbprof/
${INSTALL_DATA} ${WRKSRC}/TODO ${PORTDOCS}${RUBY_DOCDIR}/rbprof/
+.endif
${RUBY} -p -i -e 'gsub(/\r\n/, "\n")' ${WRKSRC}/aspects/profiler/lib/rbprof.rb
${RUBY} -p -i -e 'gsub(/\r\n/, "\n")' ${WRKSRC}/aspects/profiler/lib/trap_method_definitions.rb
${INSTALL_DATA} ${WRKSRC}/aspects/profiler/lib/rbprof.rb ${RUBY_SITELIBDIR}/
diff --git a/devel/ruby-rbprof/pkg-plist b/devel/ruby-rbprof/pkg-plist
index eb3da2ed792c..28a5361eb315 100644
--- a/devel/ruby-rbprof/pkg-plist
+++ b/devel/ruby-rbprof/pkg-plist
@@ -2,5 +2,5 @@
%%PORTDOCS%%%%RUBY_DOCDIR%%/rbprof/TODO
%%RUBY_SITELIBDIR%%/rbprof.rb
%%RUBY_SITELIBDIR%%/rbprof/trap_method_definitions.rb
-@dirrm %%PORTDOCS%%%%RUBY_DOCDIR%%/rbprof
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/rbprof
@dirrm %%RUBY_SITELIBDIR%%/rbprof