aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.gecko.mk1
-rw-r--r--deskutils/lightning-thunderbird/Makefile4
-rw-r--r--deskutils/lightning/Makefile4
-rw-r--r--www/kompozer/Makefile7
-rw-r--r--www/libxul/Makefile4
-rw-r--r--www/seamonkey2/Makefile5
6 files changed, 5 insertions, 20 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index a3edf49c07b7..5c700383ae5a 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -530,7 +530,6 @@ GENERIC_MOZCONFIG?= ${.CURDIR}/../../www/seamonkey/files/mozconfig-generic.in
PORT_MOZCONFIG?= ${FILESDIR}/mozconfig.in
MOZCONFIG?= ${WRKSRC}/.mozconfig
MOZILLA_PLIST_DIRS?= bin include lib share/idl
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 pthread: | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
PKGINSTALL?= ${WRKDIR}/pkg-install
PKGDEINSTALL?= ${WRKDIR}/pkg-deinstall
MASTER_MOZDIR?= ${PORTSDIR}/www/seamonkey
diff --git a/deskutils/lightning-thunderbird/Makefile b/deskutils/lightning-thunderbird/Makefile
index 9a82418d78e1..d6c275e41786 100644
--- a/deskutils/lightning-thunderbird/Makefile
+++ b/deskutils/lightning-thunderbird/Makefile
@@ -61,8 +61,6 @@ EXTRA_PATCHES= ${FILESDIR}/releng6_pulseaudio
EXTRA_PATCHES= ${FILESDIR}/liboggplay_oss
.endif
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-
.if defined(WITHOUT_DBUS)
MOZ_OPTIONS+= --disable-dbus --disable-libnotify
.else
@@ -71,7 +69,7 @@ LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:C/-pthread/${GECKO_PTHREAD_LIBS}/}|' \
+ ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
${MOZSRC}/storage/build/Makefile.in \
${MOZSRC}/db/sqlite3/src/Makefile.in
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
diff --git a/deskutils/lightning/Makefile b/deskutils/lightning/Makefile
index c40081afd4c9..aeb3180d7eb7 100644
--- a/deskutils/lightning/Makefile
+++ b/deskutils/lightning/Makefile
@@ -61,8 +61,6 @@ EXTRA_PATCHES= ${FILESDIR}/releng6_pulseaudio
EXTRA_PATCHES= ${FILESDIR}/liboggplay_oss
.endif
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-
.if defined(WITHOUT_DBUS)
MOZ_OPTIONS+= --disable-dbus
.else
@@ -70,7 +68,7 @@ LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:C/-pthread/${GECKO_PTHREAD_LIBS}/}|' \
+ ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
${MOZSRC}/storage/build/Makefile.in \
${MOZSRC}/db/sqlite3/src/Makefile.in
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
diff --git a/www/kompozer/Makefile b/www/kompozer/Makefile
index 538164039a98..7ef879537395 100644
--- a/www/kompozer/Makefile
+++ b/www/kompozer/Makefile
@@ -39,13 +39,8 @@ NOT_FOR_ARCHS_REASON_ia64= does not build
.include <bsd.port.pre.mk>
-.if ${ARCH}=="powerpc"
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED
-} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-.endif
-
post-patch:
- ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:C/-pthread/${GECKO_PTHREAD_LIBS}/}|' \
+ ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
${WRKSRC}/storage/build/Makefile.in
@${RM} -f ${WRKSRC}/config.status ${WRKSRC}/config.cache
@${ECHO_CMD} "LDFLAGS += -L${LOCALBASE}/lib" >> ${WRKSRC}/toolkit/components/Makefile.in
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index f7c936d1e79d..19851191afc5 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -51,8 +51,6 @@ OPTIONS= DBUS "Enable D-BUS support" on
.include <bsd.port.pre.mk>
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-
.if ${OSVERSION} < 700000
LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
EXTRA_PATCHES= ${FILESDIR}/releng6_pulseaudio
@@ -77,7 +75,7 @@ LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:C/-pthread/${GECKO_PTHREAD_LIBS}/}|' \
+ ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
${WRKSRC}/storage/build/Makefile.in \
${WRKSRC}/db/sqlite3/src/Makefile.in
${REINPLACE_CMD} -e 's|/usr/local/include|${LOCALBASE}/include|' \
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index be95e7724b2c..e6f8672117f4 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -74,9 +74,6 @@ CFLAGS+= -mminimal-toc
MOZSRC:= ${WRKDIR}/comm-1.9.1/mozilla
WRKSRC= ${WRKDIR}/comm-1.9.1
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED
-} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-
.if ${HAVE_GNOME:Mlibgnomeui}!=""
USE_GNOME+= libgnomeui
MOZ_OPTIONS+= --enable-gnomeui
@@ -125,7 +122,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/mozilla/security/manager/ssl/src/Makefile.in \
${WRKSRC}/mozilla/js/src/config/mkdepend/Makefile.in
- ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:C/-pthread/${GECKO_PTHREAD_LIBS}/}|' \
+ ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
${WRKSRC}/mozilla/storage/build/Makefile.in
@${REINPLACE_CMD} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
${WRKSRC}/mozilla/modules/libpref/src/init/all.js