aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/pear-Mail_mimeDecode/Makefile25
-rw-r--r--mail/pear-Mail_mimeDecode/distinfo3
-rw-r--r--mail/pear-Mail_mimeDecode/pkg-descr4
4 files changed, 33 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 902003aaef44..1297464b6fc7 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -409,6 +409,7 @@
SUBDIR += pear-Mail_Mbox
SUBDIR += pear-Mail_Mime
SUBDIR += pear-Mail_Queue
+ SUBDIR += pear-Mail_mimeDecode
SUBDIR += pear-Net_Cyrus
SUBDIR += pear-Net_IMAP
SUBDIR += pear-Net_LMTP
diff --git a/mail/pear-Mail_mimeDecode/Makefile b/mail/pear-Mail_mimeDecode/Makefile
new file mode 100644
index 000000000000..0611ed43ad34
--- /dev/null
+++ b/mail/pear-Mail_mimeDecode/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: pear-Mail_mimeDecode
+# Date created: 21 June 2007
+# Whom: Zhen REN <bg1tpt@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail_mimeDecode
+PORTVERSION= 1.5.0
+CATEGORIES= mail www pear
+DISTNAME= Mail_mimeDecode-${PORTVERSION}
+
+MAINTAINER= bg1tpt@gmail.com
+COMMENT= Provides a class to decode mime messages
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Mail
+FILES= mimeDecode.php
+TESTS= parse_header_value.phpt semicolon_content_type_bug1724.phpt
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/mail/pear-Mail_mimeDecode/distinfo b/mail/pear-Mail_mimeDecode/distinfo
new file mode 100644
index 000000000000..9262340772e9
--- /dev/null
+++ b/mail/pear-Mail_mimeDecode/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Mail_mimeDecode-1.5.0.tgz) = e81f99c951eb5f199caa9dcd9c16f97f
+SHA256 (PEAR/Mail_mimeDecode-1.5.0.tgz) = c971e5fcdc0b3c588a738f81bf01452b3c4c60ef892667ad77a031214631433f
+SIZE (PEAR/Mail_mimeDecode-1.5.0.tgz) = 9281
diff --git a/mail/pear-Mail_mimeDecode/pkg-descr b/mail/pear-Mail_mimeDecode/pkg-descr
new file mode 100644
index 000000000000..9696c5a449b6
--- /dev/null
+++ b/mail/pear-Mail_mimeDecode/pkg-descr
@@ -0,0 +1,4 @@
+Provides a class to deal with the decoding and interpreting of mime messages.
+This package used to be part of the Mail_Mime package, but has been split off.
+
+WWW: http://pear.php.net/package/Mail_mimeDecode