aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/zbgset/Makefile42
-rw-r--r--deskutils/zbgset/distinfo3
-rw-r--r--deskutils/zbgset/pkg-descr16
4 files changed, 62 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 162b19fd9ac4..4ed1550a238e 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -228,6 +228,7 @@
SUBDIR += xpostitPlus
SUBDIR += xrolo
SUBDIR += xwrits
+ SUBDIR += zbgset
SUBDIR += zorro
.include <bsd.port.subdir.mk>
diff --git a/deskutils/zbgset/Makefile b/deskutils/zbgset/Makefile
new file mode 100644
index 000000000000..89f5ee206f27
--- /dev/null
+++ b/deskutils/zbgset/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: zbgset
+# Date created: 24 June 2008
+# Whom: Zane C. Bowers
+#
+# $FreeBSD$
+#
+
+PORTNAME= zbgset
+PORTVERSION= 3.0.0
+CATEGORIES= deskutils x11
+MASTER_SITES= http://cpan.org/authors/id/V/VV/VVELOX/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.pl
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= A perl program for managing the background
+
+RUN_DEPENDS= ${SITE_PERL}/Image/Size/FillFullSelect.pm:${PORTSDIR}/graphics/p5-Image-Size-FillFullSelect \
+ ${SITE_PERL}/ZConf.pm:${PORTSDIR}/devel/p5-ZConf \
+ ${LOCALBASE}/bin/hsetroot:${PORTSDIR}/graphics/hsetroot
+
+USE_PERL5= yes
+
+NO_WRKSUBDIR= yes
+
+MAN1= ${PORTNAME}.1
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-extract:
+ @${CP} -v ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+do-build:
+ @${EXEC} pod2man --section=1 --release=${PORTVERSION} --name=${PORTNAME} --center=${PORTNAME}" user guide" ${WRKSRC}/${DISTNAME} ${WRKSRC}/${PORTNAME}.1
+
+do-install:
+ @${CP} -v ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/${PORTNAME}
+ @${CP} -v ${WRKSRC}/${PORTNAME}.1 ${PREFIX}/man/man1/${PORTNAME}.1
+ @${CHMOD} +x ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/deskutils/zbgset/distinfo b/deskutils/zbgset/distinfo
new file mode 100644
index 000000000000..a2499c1356f4
--- /dev/null
+++ b/deskutils/zbgset/distinfo
@@ -0,0 +1,3 @@
+MD5 (zbgset-3.0.0.pl) = 300867f23f46d2e3a86ff2bb07e4c700
+SHA256 (zbgset-3.0.0.pl) = ed586fd8d7abd72af0921e2f01f45c72ac6cc90ab9145f757d06f070a11a7c92
+SIZE (zbgset-3.0.0.pl) = 14398
diff --git a/deskutils/zbgset/pkg-descr b/deskutils/zbgset/pkg-descr
new file mode 100644
index 000000000000..48f8ccd86a8d
--- /dev/null
+++ b/deskutils/zbgset/pkg-descr
@@ -0,0 +1,16 @@
+NAME
+ zbgset - A perl program for managing the background.
+
+SYNOPSIS
+ zbgset (-f <file>|-r|-l) [-F <fill type>] [-s <ZConf set>]
+
+USAGE
+ Either -f, -r, or -l need used.
+
+ This does not actually set the background, but calls another program to
+ do it, but what makes it useful is it allows for random images to be
+ used as well as the last image to be called. This makes it useful for
+ setting the image upon login or changing it regullarly through cron.
+
+ When it is ran for the first time it creates a ZConf config named
+ "zbgset" used store the settings.