aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/balsa/Makefile2
-rw-r--r--mail/balsa/distinfo2
-rw-r--r--mail/balsa/files/patch-configure135
-rw-r--r--mail/balsa/files/patch-libmutt::configure18
-rw-r--r--mail/balsa/pkg-plist3
5 files changed, 72 insertions, 88 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index 9e14d13fe556..545fc740e294 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= balsa
-PORTVERSION= 1.4.2
+PORTVERSION= 1.4.3
CATEGORIES= mail gnome
MASTER_SITES= http://balsa.gnome.org/ \
http://www.theochem.kth.se/~pawsa/balsa/ \
diff --git a/mail/balsa/distinfo b/mail/balsa/distinfo
index 27b9768f3437..7f61dabe1b1d 100644
--- a/mail/balsa/distinfo
+++ b/mail/balsa/distinfo
@@ -1 +1 @@
-MD5 (balsa-1.4.2.tar.bz2) = bc1e785acae7d70ab65f22558cb85cd0
+MD5 (balsa-1.4.3.tar.bz2) = 26ac08c059d2aaa73bd76d21150a6d24
diff --git a/mail/balsa/files/patch-configure b/mail/balsa/files/patch-configure
index 71ad1e7df72b..271b95f4f99b 100644
--- a/mail/balsa/files/patch-configure
+++ b/mail/balsa/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Mon Aug 19 14:05:07 2002
-+++ configure Tue Sep 3 13:17:10 2002
-@@ -5951,6 +5951,7 @@
+--- configure.orig Mon Mar 24 16:14:15 2003
++++ configure Wed Mar 26 12:17:03 2003
+@@ -8031,6 +8031,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -8,97 +8,76 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -6881,24 +6882,24 @@
-
+@@ -9281,13 +9282,13 @@
--echo $ac_n "checking for new_pspell_manager in -lpspell""... $ac_c" 1>&6
--echo "configure:6886: checking for new_pspell_manager in -lpspell" >&5
--ac_lib_var=`echo pspell'_'new_pspell_manager | sed 'y%./+-%__p_%'`
-+echo $ac_n "checking for new_aspell_speller in -lpspell""... $ac_c" 1>&6
-+echo "configure:6886: checking for new_aspell_speller in -lpspell" >&5
-+ac_lib_var=`echo pspell'_'new_aspell_speller | sed 'y%./+-%__p_%'`
- if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
+
+-echo "$as_me:$LINENO: checking for new_pspell_manager in -lpspell" >&5
+-echo $ECHO_N "checking for new_pspell_manager in -lpspell... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for new_aspell_speller in -lpspell" >&5
++echo $ECHO_N "checking for new_aspell_speller in -lpspell... $ECHO_C" >&6
+ if test "${ac_cv_lib_pspell_new_pspell_manager+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
else
- ac_save_LIBS="$LIBS"
+ ac_check_lib_save_LIBS=$LIBS
-LIBS="-lpspell -lstdc++ -lpspell-modules $LIBS"
+LIBS="-lpspell -lstdc++ $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 6894 "configure"
- #include "confdefs.h"
- /* Override any gcc2 internal prototype to avoid an error. */
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ /* confdefs.h. */
+@@ -9302,11 +9303,11 @@
+ #endif
/* We use char because int might match the return type of a gcc2
- builtin and then its argument prototype would still apply. */
--char new_pspell_manager();
-+char new_aspell_speller();
-
- int main() {
--new_pspell_manager()
-+new_aspell_speller()
- ; return 0; }
- EOF
- if { (eval echo configure:6905: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-@@ -8920,7 +8921,7 @@
- extern int *_nl_domain_bindings;
- int main() {
- bindtextdomain ("", "");
--return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings
-+return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings
- ; return 0; }
- EOF
- if { (eval echo configure:8927: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-@@ -9306,7 +9307,7 @@
- #include "confdefs.h"
- #include <libintl.h>
- extern int _nl_msg_cat_cntr;
--extern int *_nl_domain_bindings;
-+extern int *libintl_nl_domain_bindings;
- extern
- #ifdef __cplusplus
- "C"
-@@ -9314,7 +9315,7 @@
- const char *_nl_expand_alias ();
- int main() {
- bindtextdomain ("", "");
--return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)
-+return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings + *_nl_expand_alias (0)
- ; return 0; }
- EOF
- if { (eval echo configure:9321: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-@@ -9334,7 +9335,7 @@
- #include "confdefs.h"
+ builtin and then its argument prototype would still apply. */
+-char new_pspell_manager ();
++char new_aspell_speller ();
+ int
+ main ()
+ {
+-new_pspell_manager ();
++new_aspell_speller ();
+ ;
+ return 0;
+ }
+@@ -12726,12 +12727,12 @@
+ /* end confdefs.h. */
#include <libintl.h>
extern int _nl_msg_cat_cntr;
-extern int *_nl_domain_bindings;
+extern int *libintl_nl_domain_bindings;
- extern
- #ifdef __cplusplus
- "C"
-@@ -9342,7 +9343,7 @@
- const char *_nl_expand_alias ();
- int main() {
+ int
+ main ()
+ {
bindtextdomain ("", "");
--return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)
-+return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings + *_nl_expand_alias (0)
- ; return 0; }
- EOF
- if { (eval echo configure:9349: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-@@ -9847,7 +9848,7 @@
- echo $ac_n "(cached) $ac_c" 1>&6
+-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings
++return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings
+ ;
+ return 0;
+ }
+@@ -13806,7 +13807,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
else
- ac_save_LIBS="$LIBS"
+ ac_check_lib_save_LIBS=$LIBS
-LIBS="-lldap -llber -lresolv $LIBS"
+LIBS="-lldap -llber $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 9853 "configure"
- #include "confdefs.h"
-@@ -9879,7 +9880,7 @@
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ /* confdefs.h. */
+@@ -13860,7 +13861,7 @@
#define ENABLE_LDAP 1
- EOF
+ _ACEOF
- LIBS="-lldap -llber -lresolv $LIBS"
+ LIBS="-lldap -llber $LIBS"
else
- echo "$ac_t""no" 1>&6
- { echo "configure: error: *** You enabled LDAP but ldap library is not found." 1>&2; exit 1; }
+ { { echo "$as_me:$LINENO: error: *** You enabled LDAP but ldap library is not found." >&5
+ echo "$as_me: error: *** You enabled LDAP but ldap library is not found." >&2;}
+@@ -14479,7 +14480,7 @@
+ echo $ECHO_N "checking whether to build SSL support... $ECHO_C" >&6
+ if test "x$with_ssl" != xno ; then
+ # openssl >=0.9.7 is pkg-config compatible.
+- if pkg-config openssl >&/dev/null; then
++ if pkg-config openssl >/dev/null 2>&1; then
+ LIBS="$LIBS `pkg-config --libs openssl`"
+ CPPFLAGS="`pkg-config --cflags-only-I openssl` $CPPFLAGS"
+ echo "$as_me:$LINENO: result: yes" >&5
diff --git a/mail/balsa/files/patch-libmutt::configure b/mail/balsa/files/patch-libmutt::configure
index be36a18bb276..8ffb7dd5137a 100644
--- a/mail/balsa/files/patch-libmutt::configure
+++ b/mail/balsa/files/patch-libmutt::configure
@@ -1,9 +1,6 @@
-
-$FreeBSD$
-
---- libmutt/configure 2002/07/18 16:53:06 1.1
-+++ libmutt/configure 2002/07/18 16:53:15
-@@ -5192,6 +5192,7 @@
+--- libmutt/configure.orig Mon Mar 24 16:18:17 2003
++++ libmutt/configure Wed Mar 26 12:22:07 2003
+@@ -7627,6 +7627,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -11,3 +8,12 @@ $FreeBSD$
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -10514,7 +10515,7 @@
+ echo "$as_me: error: SSL support is only for IMAP, but IMAP is not enabled" >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+- if pkg-config openssl >& /dev/null; then
++ if pkg-config openssl >/dev/null 2>&1; then
+ echo here
+ LDFLAGS="$LIBS `pkg-config --libs openssl`"
+ CPPFLAGS="`pkg-config --cflags-only-I openssl` $CPPFLAGS"
diff --git a/mail/balsa/pkg-plist b/mail/balsa/pkg-plist
index 869052cf67cb..e49fec85a5ed 100644
--- a/mail/balsa/pkg-plist
+++ b/mail/balsa/pkg-plist
@@ -1,7 +1,7 @@
bin/balsa
etc/sound/events/balsa.soundlist
etc/sound/events/email.soundlist
-share/gnome/apps/Internet/balsa.desktop
+share/gnome/applications/balsa.desktop
share/gnome/help/balsa/C/images/address-book-ldap.png
share/gnome/help/balsa/C/images/address-book-modify.png
share/gnome/help/balsa/C/images/address-book-start.png
@@ -62,7 +62,6 @@ share/locale/it/LC_MESSAGES/balsa.mo
share/locale/ja/LC_MESSAGES/balsa.mo
share/locale/ko/LC_MESSAGES/balsa.mo
share/locale/lt/LC_MESSAGES/balsa.mo
-share/locale/lv/LC_MESSAGES/balsa.mo
share/locale/ms/LC_MESSAGES/balsa.mo
share/locale/nl/LC_MESSAGES/balsa.mo
share/locale/nn/LC_MESSAGES/balsa.mo