aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.gecko.mk16
-rw-r--r--www/linux-seamonkey/Makefile2
-rw-r--r--www/linux-seamonkey/distinfo4
-rw-r--r--www/linux-seamonkey/pkg-plist3
-rw-r--r--www/seamonkey-i18n/Makefile4
-rw-r--r--www/seamonkey-i18n/distinfo88
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--www/seamonkey/distinfo4
-rw-r--r--www/seamonkey/files/patch-configure.in33
-rw-r--r--www/seamonkey/files/patch-ipc-chromium-src-base-file_util.h13
-rw-r--r--www/seamonkey/files/patch-mozilla-ipc-chromium-src-base-dir_reader_linux.h45
11 files changed, 120 insertions, 94 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 39a63b778066..1fdc30c2334b 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -192,9 +192,9 @@ Gecko_Pre_Include= bsd.gecko.mk
# version is given by the maintainer via the port
# or by the user via defined variable try to find
# the highest stable installed version.
-# Available values: yes 25+ 25
+# Available values: yes 26+ 26
# NOTE:
-# default value 25 is used in case of USE_SEAMONKEY=yes
+# default value 26 is used in case of USE_SEAMONKEY=yes
#
# USE_SEAMONKEY_BUILD Add buildtime dependency on SeaMonkey.
# Available values: see USE_SEAMONKEY
@@ -295,12 +295,12 @@ USE_SEAMONKEY:= ${USE_SEAMONKEY_BUILD}
_SEAMONKEY_BUILD_DEPENDS= yes
.endif
-_SEAMONKEY_DEFAULT_VERSION= 25
-_SEAMONKEY_VERSIONS= 25
-_SEAMONKEY_RANGE_VERSIONS= 25+
+_SEAMONKEY_DEFAULT_VERSION= 26
+_SEAMONKEY_VERSIONS= 26
+_SEAMONKEY_RANGE_VERSIONS= 26+
-# For specifying [25, 20, ..]+
-_SEAMONKEY_25P= 25
+# For specifying [26, 20, ..]+
+_SEAMONKEY_26P= 26
# Set the default SeaMonkey version and check if USE_SEAMONKEY=yes was given
.if ${USE_SEAMONKEY} == "yes"
@@ -342,7 +342,7 @@ IGNORE= cannot install: unknown SeaMonkey version: seamonkey-${USE_SEAMONKEY:C
.endif
# Dependence lines for different SeaMonkey versions
-25_DEPENDS= ${LOCALBASE}/lib/seamonkey/seamonkey:${PORTSDIR}/www/seamonkey
+26_DEPENDS= ${LOCALBASE}/lib/seamonkey/seamonkey:${PORTSDIR}/www/seamonkey
# Add dependencies
.if defined(USE_SEAMONKEY)
diff --git a/www/linux-seamonkey/Makefile b/www/linux-seamonkey/Makefile
index 867980a44698..88b0662c7a09 100644
--- a/www/linux-seamonkey/Makefile
+++ b/www/linux-seamonkey/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= seamonkey
-PORTVERSION= 2.5
+PORTVERSION= 2.6
CATEGORIES= www
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}/linux-i686/en-US
diff --git a/www/linux-seamonkey/distinfo b/www/linux-seamonkey/distinfo
index 4427d5571447..5822f639a736 100644
--- a/www/linux-seamonkey/distinfo
+++ b/www/linux-seamonkey/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seamonkey-2.5.tar.bz2) = ee3bad929dee2b2b4696894a299d1bb1c9d90a92f3f15610a6db64f5f05f7c55
-SIZE (seamonkey-2.5.tar.bz2) = 20729056
+SHA256 (seamonkey-2.6.tar.bz2) = 2c904471d0a0a760f5ed6ca40262ad374e5f7079f831021e55687354e476eaf2
+SIZE (seamonkey-2.6.tar.bz2) = 21045347
diff --git a/www/linux-seamonkey/pkg-plist b/www/linux-seamonkey/pkg-plist
index feee1f962963..3f2d0a36a202 100644
--- a/www/linux-seamonkey/pkg-plist
+++ b/www/linux-seamonkey/pkg-plist
@@ -92,8 +92,10 @@ lib/%%APP_NAME%%/hyphenation/hyph_fr.dic
lib/%%APP_NAME%%/hyphenation/hyph_gl.dic
lib/%%APP_NAME%%/hyphenation/hyph_hr.dic
lib/%%APP_NAME%%/hyphenation/hyph_hsb.dic
+lib/%%APP_NAME%%/hyphenation/hyph_hu.dic
lib/%%APP_NAME%%/hyphenation/hyph_ia.dic
lib/%%APP_NAME%%/hyphenation/hyph_is.dic
+lib/%%APP_NAME%%/hyphenation/hyph_it.dic
lib/%%APP_NAME%%/hyphenation/hyph_kmr.dic
lib/%%APP_NAME%%/hyphenation/hyph_la.dic
lib/%%APP_NAME%%/hyphenation/hyph_lt.dic
@@ -106,6 +108,7 @@ lib/%%APP_NAME%%/hyphenation/hyph_ru.dic
lib/%%APP_NAME%%/hyphenation/hyph_sh.dic
lib/%%APP_NAME%%/hyphenation/hyph_sl.dic
lib/%%APP_NAME%%/hyphenation/hyph_sv.dic
+lib/%%APP_NAME%%/hyphenation/hyph_tr.dic
lib/%%APP_NAME%%/hyphenation/hyph_uk.dic
lib/%%APP_NAME%%/icons/updater.png
lib/%%APP_NAME%%/isp/SpamAssassin.sfd
diff --git a/www/seamonkey-i18n/Makefile b/www/seamonkey-i18n/Makefile
index 2e20ae719575..3eaa452e70eb 100644
--- a/www/seamonkey-i18n/Makefile
+++ b/www/seamonkey-i18n/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= seamonkey-i18n
-PORTVERSION= 2.5
+PORTVERSION= 2.6
CATEGORIES= www
MASTER_SITE_SUBDIR= seamonkey/releases/${PORTVERSION}/langpack
PKGNAMEPREFIX=
@@ -18,7 +18,7 @@ COMMENT= Localized interface for SeaMonkey 2.4
EXTRACT_DEPENDS= zip:${PORTSDIR}/archivers/zip
-USE_SEAMONKEY= 25
+USE_SEAMONKEY= 26
USE_XPI= seamonkey linux-seamonkey
USE_SUBMAKE= yes
diff --git a/www/seamonkey-i18n/distinfo b/www/seamonkey-i18n/distinfo
index 1af082a590e7..7dc2c3724f2d 100644
--- a/www/seamonkey-i18n/distinfo
+++ b/www/seamonkey-i18n/distinfo
@@ -1,44 +1,44 @@
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.ca.langpack.xpi) = fe39d637442301e828e1253f27ae050b995c673e5d20adf132e06dbc614964e1
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.ca.langpack.xpi) = 813814
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.cs.langpack.xpi) = 2e06b46543fcddbf9a3bf82bb7180a99561906c278598b26e1c8e7461b37d520
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.cs.langpack.xpi) = 819090
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.de.langpack.xpi) = df1ef68cc68f8c562a8ad058268b2d735d48b75bd013a82d56805e33408a4fac
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.de.langpack.xpi) = 859869
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.en-GB.langpack.xpi) = 3acfc054459aaae43f29234c8e0bca01b91e3950d3f7de72632069c24d74d018
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.en-GB.langpack.xpi) = 789630
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.en-US.langpack.xpi) = f4fad47edbae648c7107b6d688a1bafdf2a579675aa08d8fa70dc5b96ad41e24
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.en-US.langpack.xpi) = 789287
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.es-AR.langpack.xpi) = 72fdb673ba148441272b65253cce14e8bd4b22c2a7a872008481645032d9596d
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.es-AR.langpack.xpi) = 859119
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.es-ES.langpack.xpi) = 7b01567cf2fb4a31bd5d3308fbb606764874b0f2a5621031e76db9c636b57df8
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.es-ES.langpack.xpi) = 787408
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.fi.langpack.xpi) = ab7e605fb04f5ec7b919992707e262c5e34626f9c5923f9560d5557078cdfdee
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.fi.langpack.xpi) = 809364
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.fr.langpack.xpi) = c7aa9b739bf898120993ebff197bc047ed796abe3ceb9fbb079ccec8f79d8baf
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.fr.langpack.xpi) = 814852
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.hu.langpack.xpi) = bc934aec9c0e0fd0ab395077fd76189b128a7b3ba921d9c43a5143d6eb58d26b
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.hu.langpack.xpi) = 830898
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.it.langpack.xpi) = a36770857aeefff0f1192bce600ce480386242847f49c5420e47eb622ea24ede
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.it.langpack.xpi) = 737810
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.ja-JP-mac.langpack.xpi) = e871bf8ba79b083406903ab31e877a61117146bb0fb3f586ddb496c1d3e22001
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.ja-JP-mac.langpack.xpi) = 888741
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.ja.langpack.xpi) = 24bd7381868030f15e167d1d417a59e4c0b67a920b875f2c32f4b5ff55499074
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.ja.langpack.xpi) = 864233
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.lt.langpack.xpi) = a0a6686284b17e52ad1267901e90989dd8c7dac9febab1d5de1076df392d20fe
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.lt.langpack.xpi) = 961779
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.nb-NO.langpack.xpi) = 209b8a8a97896fda24e9c65ddad826869ba64cbea2176e50d8bfe7f9a92140b0
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.nb-NO.langpack.xpi) = 807765
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.nl.langpack.xpi) = 3b16ec27733dbbd4491c4cfe13b25f2bd706a4686ac3d8d0a3472456ba233edf
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.nl.langpack.xpi) = 806319
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.pl.langpack.xpi) = 08c4209e7e39f7eda287143122f074bebf18f95cb800f90a8aa1f9753c25303f
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.pl.langpack.xpi) = 828798
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.pt-PT.langpack.xpi) = e7e537c874bec1c269f120346f3ea282243d30c018ffc3a642f3f5536a03f636
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.pt-PT.langpack.xpi) = 844864
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.ru.langpack.xpi) = 70fa704c3966ce0d86489997eccca55d22e6eca2fc2a44de65742a167d14058f
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.ru.langpack.xpi) = 891481
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.sk.langpack.xpi) = 06e396153b822921fb61f4c0a56d066e0eae3b12bf46cd58dea0deccd639d84c
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.sk.langpack.xpi) = 842552
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.sv-SE.langpack.xpi) = db3a8e939f4beea10af6cd7c82e5d3e976145a9ac196a79a0ccfee3f1e1747ea
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.sv-SE.langpack.xpi) = 871535
-SHA256 (xpi/seamonkey-i18n-2.5/seamonkey-2.5.tr.langpack.xpi) = 13ea5f3e8523af74b838ce3271509f07d61981ccebbcf1acb38bf90adcf444a6
-SIZE (xpi/seamonkey-i18n-2.5/seamonkey-2.5.tr.langpack.xpi) = 807205
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.ca.langpack.xpi) = 09c0372201980d8cc6ad9716caa8604fa616b7280c741859a63d9232c62f8c38
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.ca.langpack.xpi) = 814466
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.cs.langpack.xpi) = a0f40b1050be0fb5c30cbdc3c488f4927e24e6e88727636c7d454339bedd9728
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.cs.langpack.xpi) = 819661
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.de.langpack.xpi) = 2e7f2a5e3141404550ab4c14e8ac74096301573d43d51a6c02f57e8a667cb53e
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.de.langpack.xpi) = 860449
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.en-GB.langpack.xpi) = f810216697af2fbd9d83498eee70979bf7147742df22449de75f0a446e25550e
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.en-GB.langpack.xpi) = 790667
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.en-US.langpack.xpi) = ba7bed020b033acf897f3d501c4eacb4f8255a21c871b4c8f762412efb669581
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.en-US.langpack.xpi) = 789695
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.es-AR.langpack.xpi) = e263296917c9a6904d40c3d249738861eee5d0a55b569a1c64e928fe4af89df1
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.es-AR.langpack.xpi) = 860257
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.es-ES.langpack.xpi) = 986e59b866139baaa59ed1ae65e778c2084271ff37edafbf7a89832fc51a97b5
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.es-ES.langpack.xpi) = 788484
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.fi.langpack.xpi) = 62862888fc71b1051fa4c6f7486b78dbb9fd83cfc3658d002b9b5a61b7d3fd68
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.fi.langpack.xpi) = 809900
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.fr.langpack.xpi) = c165bdc212be7faf5e645393bcf26ce1f4b57a2c7667c9e0cb2487cf63c0e049
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.fr.langpack.xpi) = 815678
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.hu.langpack.xpi) = c5fde5ac1d802099f62d51e9ef5f81c83dde7a754bdba42ae6de9e4f2e1fc0e7
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.hu.langpack.xpi) = 832650
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.it.langpack.xpi) = 7fc51ee05a1d415e0ad8cfa2b15c8b58842c30b01f6a9280e63832dc980836c0
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.it.langpack.xpi) = 738878
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.ja-JP-mac.langpack.xpi) = 018783c2c8d26f237661f1fb45c86f7144bd3d1e87916172569fbe3887784a35
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.ja-JP-mac.langpack.xpi) = 889484
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.ja.langpack.xpi) = 054981b6bc5f756046abfccff7e42bbbf539dd42574b54005e71c6ecee0a0e7e
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.ja.langpack.xpi) = 864873
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.lt.langpack.xpi) = f4f5ea5e57c2a32f8acec1601ae005bfb329dc3277d9699ed61b349ba656a5aa
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.lt.langpack.xpi) = 962667
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.nb-NO.langpack.xpi) = 6fc02079a327a9bfae1595860a471d7842532e7d5b7f2cecce85765455efe5d7
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.nb-NO.langpack.xpi) = 808226
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.nl.langpack.xpi) = bfc50cab29e92d1e239f9c9fa6d3e31e5cc23a564e7f26060efa1eb42e279770
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.nl.langpack.xpi) = 806819
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.pl.langpack.xpi) = 5c35271a2dbd07814d6d8239d2d0bdb2efb4d0a7c7d0e7fa8b2a1cc24c2bae53
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.pl.langpack.xpi) = 829357
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.pt-PT.langpack.xpi) = c7f2c5b43f85a39027f3a79b8d0b157e73e3ab69cada3b4e28550054205ef2ea
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.pt-PT.langpack.xpi) = 845392
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.ru.langpack.xpi) = 51122d366eaf4c6c93047afad0d9dbf79ad0d18e5f30611cc5eceb0e8f71102a
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.ru.langpack.xpi) = 892794
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.sk.langpack.xpi) = 29f5b60dc88a338c3b738acf4157b34a7c1c041225466d5c0481748e0ca6b683
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.sk.langpack.xpi) = 843098
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.sv-SE.langpack.xpi) = 076467687999872018ba71af05e8af21ee01adc95156b42682a0fe22430ab8f0
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.sv-SE.langpack.xpi) = 872017
+SHA256 (xpi/seamonkey-i18n-2.6/seamonkey-2.6.tr.langpack.xpi) = fd7763e96181014eca8f9620e8d9e3fd5fea124ad46c8e93658ffdab08a7bfb3
+SIZE (xpi/seamonkey-i18n-2.6/seamonkey-2.6.tr.langpack.xpi) = 809260
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index dcc36f532f3b..6af38b1cd315 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= seamonkey
-DISTVERSION= 2.5
+DISTVERSION= 2.6
CATEGORIES?= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= seamonkey/releases/${DISTVERSION}/source
diff --git a/www/seamonkey/distinfo b/www/seamonkey/distinfo
index b72564bc8cb8..62774a342568 100644
--- a/www/seamonkey/distinfo
+++ b/www/seamonkey/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seamonkey-2.5.source.tar.bz2) = 50d6146f20d3221fac0366f6647956e142749891dbd411f85e745d75cc32c8d0
-SIZE (seamonkey-2.5.source.tar.bz2) = 89448141
+SHA256 (seamonkey-2.6.source.tar.bz2) = ebac80074583bb8a79e58aa59595b57266de092c846d51c005222decba5d9cb2
+SIZE (seamonkey-2.6.source.tar.bz2) = 96733312
diff --git a/www/seamonkey/files/patch-configure.in b/www/seamonkey/files/patch-configure.in
index 56c07e868572..393b67a0341c 100644
--- a/www/seamonkey/files/patch-configure.in
+++ b/www/seamonkey/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig 2011-07-15 07:42:33.000000000 +0200
-+++ configure.in 2011-07-22 13:43:44.000000000 +0200
-@@ -1438,7 +1438,7 @@
+--- configure.in.orig 2011-12-17 18:35:47.000000000 +0100
++++ configure.in 2011-12-19 15:57:09.000000000 +0100
+@@ -1410,7 +1410,7 @@
CPU_ARCH=sparc
;;
@@ -9,7 +9,7 @@
CPU_ARCH="$OS_TEST"
;;
-@@ -1458,7 +1458,7 @@
+@@ -1430,7 +1430,7 @@
dnl ===============================================================
INTEL_ARCHITECTURE=
case "$OS_TEST" in
@@ -18,7 +18,7 @@
INTEL_ARCHITECTURE=1
esac
-@@ -1781,7 +1781,7 @@
+@@ -1753,7 +1753,7 @@
esac
case "${host_cpu}" in
@@ -27,7 +27,7 @@
HOST_CFLAGS="$HOST_CFLAGS -D_AMD64_"
;;
esac
-@@ -2437,6 +2437,9 @@
+@@ -2415,6 +2415,9 @@
x86_64-*)
AC_DEFINE(_AMD64_)
;;
@@ -37,7 +37,7 @@
*)
AC_DEFINE(_CPU_ARCH_NOT_DEFINED)
;;
-@@ -2508,7 +2511,7 @@
+@@ -2486,7 +2489,7 @@
else
DLL_SUFFIX=".so.1.0"
fi
@@ -46,7 +46,7 @@
DSO_CFLAGS=''
DSO_PIC_CFLAGS='-fPIC'
DSO_LDOPTS='-shared -fPIC'
-@@ -3326,11 +3329,11 @@
+@@ -3304,11 +3307,11 @@
;;
*)
MOZ_CHECK_PTHREADS(pthreads,
@@ -61,7 +61,7 @@
MOZ_CHECK_PTHREADS(c,
USE_PTHREADS=1
)
-@@ -3405,18 +3408,18 @@
+@@ -3383,18 +3386,18 @@
*-*-freebsd*)
AC_DEFINE(_REENTRANT)
AC_DEFINE(_THREAD_SAFE)
@@ -83,7 +83,7 @@
if test "$ac_cv_have_dash_pthread" = "yes"; then
_PTHREAD_LDFLAGS="-pthread"
fi
-@@ -3591,7 +3594,7 @@
+@@ -3569,7 +3572,7 @@
ac_cv_func_iconv,
[AC_TRY_LINK([
#include <stdlib.h>
@@ -92,7 +92,7 @@
],
[
iconv_t h = iconv_open("", "");
-@@ -3612,7 +3615,7 @@
+@@ -3590,7 +3593,7 @@
ac_cv_func_const_iconv,
[AC_TRY_COMPILE([
#include <stdlib.h>
@@ -101,7 +101,7 @@
],
[
const char *input = "testing";
-@@ -4409,7 +4412,7 @@
+@@ -4383,7 +4386,7 @@
LDFLAGS=$_SAVE_LDFLAGS
LIBS=$_SAVE_LIBS
@@ -110,12 +110,3 @@
ZLIB_CFLAGS="-I${ZLIB_DIR}/include"
ZLIB_LIBS="-L${ZLIB_DIR}/lib ${ZLIB_LIBS}"
fi
-@@ -5966,7 +5969,7 @@
- i*86)
- MOZ_CRT_CPU_ARCH=intel
- ;;
-- x86_64)
-+ amd64 | x86_64)
- MOZ_CRT_CPU_ARCH=amd64
- ;;
- *)
diff --git a/www/seamonkey/files/patch-ipc-chromium-src-base-file_util.h b/www/seamonkey/files/patch-ipc-chromium-src-base-file_util.h
deleted file mode 100644
index 81a4693140a8..000000000000
--- a/www/seamonkey/files/patch-ipc-chromium-src-base-file_util.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- mozilla/ipc/chromium/src/base/file_util.h~
-+++ mozilla/ipc/chromium/src/base/file_util.h
-@@ -15,8 +15,9 @@
- #elif defined(ANDROID)
- #include <sys/stat.h>
- #elif defined(OS_POSIX)
-+#include <sys/types.h>
-+#include <sys/stat.h>
- #include <fts.h>
--#include <sys/stat.h>
- #endif
-
- #include <stdio.h>
diff --git a/www/seamonkey/files/patch-mozilla-ipc-chromium-src-base-dir_reader_linux.h b/www/seamonkey/files/patch-mozilla-ipc-chromium-src-base-dir_reader_linux.h
new file mode 100644
index 000000000000..5c4e5b79f3d1
--- /dev/null
+++ b/www/seamonkey/files/patch-mozilla-ipc-chromium-src-base-dir_reader_linux.h
@@ -0,0 +1,45 @@
+--- mozilla/ipc/chromium/src/base/dir_reader_linux.h.orig 2011-12-16 21:29:22.000000000 +0100
++++ mozilla/ipc/chromium/src/base/dir_reader_linux.h 2011-12-19 21:00:27.000000000 +0100
+@@ -9,6 +9,7 @@
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <stdint.h>
++#include <sys/dirent.h>
+ #include <sys/syscall.h>
+ #include <unistd.h>
+
+@@ -19,6 +20,8 @@
+
+ namespace base {
+
++#define linux_dirent struct dirent
++#if 0
+ struct linux_dirent {
+ uint64_t d_ino;
+ int64_t d_off;
+@@ -26,11 +29,16 @@
+ unsigned char d_type;
+ char d_name[0];
+ };
++#endif
+
+ class DirReaderLinux {
+ public:
+ explicit DirReaderLinux(const char* directory_path)
++#ifdef O_DIRECTORY
+ : fd_(open(directory_path, O_RDONLY | O_DIRECTORY)),
++#else
++ : fd_(open(directory_path, O_RDONLY)),
++#endif
+ offset_(0),
+ size_(0) {
+ memset(buf_, 0, sizeof(buf_));
+@@ -57,7 +65,7 @@
+ if (offset_ != size_)
+ return true;
+
+- const int r = syscall(__NR_getdents64, fd_, buf_, sizeof(buf_));
++ const int r = syscall(SYS_getdents, fd_, buf_, sizeof(buf_));
+ if (r == 0)
+ return false;
+ if (r == -1) {