aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sub-Signatures/Makefile21
-rw-r--r--devel/p5-Sub-Signatures/distinfo2
-rw-r--r--devel/p5-Sub-Signatures/pkg-descr8
-rw-r--r--devel/p5-Sub-Signatures/pkg-plist5
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fe5886d86c22..8058eac0c350 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2175,6 +2175,7 @@
SUBDIR += p5-Sub-Multi
SUBDIR += p5-Sub-Name
SUBDIR += p5-Sub-Override
+ SUBDIR += p5-Sub-Signatures
SUBDIR += p5-Sub-Uplevel
SUBDIR += p5-Sub-WrapPackages
SUBDIR += p5-Sys-Cpu
diff --git a/devel/p5-Sub-Signatures/Makefile b/devel/p5-Sub-Signatures/Makefile
new file mode 100644
index 000000000000..377f0fc272b2
--- /dev/null
+++ b/devel/p5-Sub-Signatures/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Sub-Signatures
+# Date created: 21 Nov 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sub-Signatures
+PORTVERSION= 0.21
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= magik@roorback.net
+COMMENT= Use proper signatures for subroutines, including dispatching
+
+PERL_CONFIGURE= yes
+
+MAN3= Sub::Signatures.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Sub-Signatures/distinfo b/devel/p5-Sub-Signatures/distinfo
new file mode 100644
index 000000000000..dabaf2b4ba4f
--- /dev/null
+++ b/devel/p5-Sub-Signatures/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Sub-Signatures-0.21.tar.gz) = 52b9d803946b711d31ad32a9cdaf46194975b1996964228a81d37cf60614f220
+SIZE (Sub-Signatures-0.21.tar.gz) = 11254
diff --git a/devel/p5-Sub-Signatures/pkg-descr b/devel/p5-Sub-Signatures/pkg-descr
new file mode 100644
index 000000000000..1c63b770d591
--- /dev/null
+++ b/devel/p5-Sub-Signatures/pkg-descr
@@ -0,0 +1,8 @@
+One of the strongest complaints about Perl is its poor argument handling.
+Simply passing everything in the @_ array is a serious limitation. This
+module aims to rectify that.
+
+With this module, we an specify subroutine signatures and automatically
+dispatch on the number of arguments.
+
+WWW: http://search.cpan.org/dist/Sub-Signatures/
diff --git a/devel/p5-Sub-Signatures/pkg-plist b/devel/p5-Sub-Signatures/pkg-plist
new file mode 100644
index 000000000000..436eaacc1317
--- /dev/null
+++ b/devel/p5-Sub-Signatures/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Signatures/.packlist
+%%SITE_PERL%%/Sub/Signatures.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Signatures
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub
+@dirrmtry %%SITE_PERL%%/Sub