aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/samesame/Makefile37
-rw-r--r--sysutils/samesame/distinfo6
-rw-r--r--sysutils/samesame/files/patch-matchmatrix.cpp10
-rw-r--r--sysutils/samesame/pkg-message4
4 files changed, 24 insertions, 33 deletions
diff --git a/sysutils/samesame/Makefile b/sysutils/samesame/Makefile
index 805eb62003f1..3008623b99f6 100644
--- a/sysutils/samesame/Makefile
+++ b/sysutils/samesame/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= samesame
-PORTVERSION= 1.2
-PORTREVISION= 1
+PORTVERSION= 1.3
CATEGORIES= sysutils
MASTER_SITES= http://samesame.kruijff.org/ \
${MASTER_SITE_LOCAL}
@@ -18,55 +17,53 @@ COMMENT= Find identical files and optionally link them together
CONFLICTS= samefile-[0-9]*
MAN1= samearchive.1 samearchive-lite.1 samefile.1 samelink.1
-MANCOMPRESSED= yes
+MANCOMPRESSED= no
+
PLIST_FILES= bin/samearchive bin/samefile \
bin/samearchive-lite bin/samelink \
etc/rc.d/samesame.sh
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir="${MANPREFIX}/man" --prefix="${PREFIX}" \
+ --includedir="${LOCALBASE}/include" --libdir="${LOCALBASE}/lib"
USE_BZIP2= yes
OPTIONS= DEBUG "Enables debugging support" Off \
- DISK_STORAGE "Allow temporarily storage paths on disk" On \
+ DISK_STORAGE "Allows temporarily storage paths on disk" On \
LOGIC "Determine results by using logic when posible" On \
TEST "Run quality assurance test" Off
.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG)
-CFLAGS+= -DDEBUG
+CONFIGURE_ARGS+= --enable-debug
.endif
.if defined(WITH_DISK_STORAGE)
-CFLAGS+= -DWITH_DISK_STORAGE
+CONFIGURE_ARGS+= --enable-disk-storage
.endif
.if defined(WITHOUT_LOGIC)
-CFLAGS+= -DWITHOUT_LOGIC
+CONFIGURE_ARGS+= --disable-logic
.endif
-CFLAGS+= -DWITH_MMAP
-CFLAGS+= -D'TEMP_STORAGE_DIR=\"/tmp\"'
-CFLAGS+= -DPATH_INIT=256
-CFLAGS+= -DSTATIC_CACHE_CAPACITY=8192
-
-post-patch:
- @${REINPLACE_CMD} -e 's|@||g' ${WRKSRC}/Makefile
-
-post-build:
-.if defined(WITH_TEST)
- cd ${WRKSRC}; ${MAKE} test
-.endif
+test: build
+ @cd ${WRKSRC}; ${MAKE} check
pre-install:
.if defined(WITH_TEST)
- cd ${WRKSRC}; ${MAKE} test
+ @cd ${WRKSRC}; ${MAKE} check
.endif
post-install:
+.if defined(WITHOUT_DEBUG)
${STRIP_CMD} ${PREFIX}/bin/samefile
${STRIP_CMD} ${PREFIX}/bin/samelink
${STRIP_CMD} ${PREFIX}/bin/samearchive
${STRIP_CMD} ${PREFIX}/bin/samearchive-lite
+.endif
+
${INSTALL_SCRIPT} ${FILESDIR}/samesame.sh ${PREFIX}/etc/rc.d/
+ @${CAT} pkg-message
.include <bsd.port.post.mk>
diff --git a/sysutils/samesame/distinfo b/sysutils/samesame/distinfo
index ec53d466b366..740dd78432d0 100644
--- a/sysutils/samesame/distinfo
+++ b/sysutils/samesame/distinfo
@@ -1,3 +1,3 @@
-MD5 (samesame-1.2.tar.bz2) = 828eb35bdb1c8dc9a4cd37e38a3de61e
-SHA256 (samesame-1.2.tar.bz2) = 82f30cc8295dace42e3c6a847217b1b023cd55c754a409c3388614f45a0a6c3b
-SIZE (samesame-1.2.tar.bz2) = 42642
+MD5 (samesame-1.3.tar.bz2) = e64863157690dfcc161c92f079a1dee7
+SHA256 (samesame-1.3.tar.bz2) = 057f5e754cdcceae1d78d4878d501c589fbe214ce63022feebe9c9b7d11d3483
+SIZE (samesame-1.3.tar.bz2) = 100841
diff --git a/sysutils/samesame/files/patch-matchmatrix.cpp b/sysutils/samesame/files/patch-matchmatrix.cpp
deleted file mode 100644
index 3e6360546637..000000000000
--- a/sysutils/samesame/files/patch-matchmatrix.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- matchmatrix.cpp.orig 2009-05-22 12:45:27.000000000 +0200
-+++ matchmatrix.cpp 2009-06-30 22:24:35.000000000 +0200
-@@ -35,6 +35,7 @@
- arr[0] = ((signed char *)tmp) + n * sizeof(char **);
- for (size_t i = 1; i < n; ++i)
- arr[i] = arr[i - 1] + n - i + 1;
-+ memset(arr[0], 0, (n + 1) * n / 2);
- #ifdef DEBUG
- if (tmp + n * sizeof(char **) + (n + 1) * n / 2 <= arr[n - 1])
- {
diff --git a/sysutils/samesame/pkg-message b/sysutils/samesame/pkg-message
new file mode 100644
index 000000000000..b7b51b8753b2
--- /dev/null
+++ b/sysutils/samesame/pkg-message
@@ -0,0 +1,4 @@
+---------------------------------------------------
+A 2 clause BSD licence applies to this application:
+http://samesame.kruijff.org/license.html
+---------------------------------------------------
d> * Mark as broken on powerpc: does not compile.linimon2011-11-111-0/+4 * Mark broken on powerpc as well as sparc64. (In fact, on all the tier-2s.)linimon2011-11-101-2/+2 * - Remove WITH_FBSD10_FIX, is no longer neededmiwi2011-11-095-5/+0 * - Mark BROKEN: does not compile with new fltkpav2011-11-051-0/+2 * - Update to 0.7.2wen2011-11-033-116/+196 * Remove ports@ ports that have been DEPRECATED for at least 1 monthdougb2011-11-026-144/+0 * - Update to 1.5.3sunpoet2011-11-012-4/+4 * - Mark BROKEN: does not compilepav2011-11-011-0/+2 * Add patch from upstream to fix build on i386makc2011-10-311-0/+11 * - Fix build on FreeBSD 10miwi2011-10-291-0/+1 * - Fix build on FreeBSD 10miwi2011-10-292-0/+2 * - Fix build with FreeBSD 10miwi2011-10-291-0/+1 * - Fix build on FreeBSD 10miwi2011-10-291-0/+1 * - Update to 0.9.8wen2011-10-262-4/+4 * The vast majority of pkg-descr files had the following format when theydougb2011-10-247-6/+7 * Remove more tags from pkg-descr files fo the form:dougb2011-10-244-12/+1 * Update to 2.0.4makc2011-10-205-106/+61 * - add run time dependency on py-scipyeadler2011-10-201-1/+2 * Build fix for recent update of USE_FORTRAN tomaho2011-10-183-6/+7 * - update fftw3* to 3.3 [1], and adjust dependent portsbf2011-10-174-9/+10 * The KDE/FreeBSD team is pleased to announce KDE Software Compilationavilla2011-10-179-0/+651 * update math/R to 2.13.2, and adjust dependent portsbf2011-10-115-2/+5 * Update ImageMagick to 6.7.2-10 (shlib bumped to .5)mm2011-10-111-2/+2 * Remove ports maintainted by ports@ which have passed their EXPIRATION_DATEdougb2011-10-0915-667/+0 * Remove optional dependency on graphics/giftrans, which is about to be removeddougb2011-10-091-6/+1 * fix distinfo, the distfile was rerolled. Nothing major, mostly spelling fixes.flo2011-10-021-2/+2 * eco is a publicly available R package that implements the Bayesianwen2011-09-284-0/+29 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-2427-48/+45 * - Reassign to the heaptabthorpe2011-09-221-1/+1 * - update to 4.5.5flo2011-09-203-9/+15 * Remove a special configuration for versions of FreeBSD before 7.0gerald2011-09-191-4/+0 * - Add a new port: science/R-cran-DClustertota2011-09-184-0/+32 * - Add a new port: science/R-cran-Epitota2011-09-174-0/+30 * - Update to 2.1.24sunpoet2011-09-172-3/+3 * Change maintainer address to my FreeBSD addresscs2011-09-152-2/+2 * I forgot to remove unncessary patch..maho2011-09-131-64/+0 * - Mark broken on some versions of FreeBSD (libtool error).stephen2011-09-071-0/+6 * Update to 1.4.0 and unbreak for 8-exp gcc46 run.maho2011-09-074-9/+26 * - Fix paths in installed CMake modules.avilla2011-09-071-3/+2 * - Update to 3.1.0dhn2011-09-072-3/+4 * - Move preprocessor options back to CPPFLAGSsunpoet2011-09-011-2/+3 * Mark as broken on recent i386-9: does not compile.linimon2011-08-291-0/+2 * - Update to 1.5.2sunpoet2011-08-292-4/+4 * Remove the dependency on multimedia/avifile which has been brokengerald2011-08-281-5/+0 * Fix for experimental gcc 4.6 build, and many small fixesmaho2011-08-261-13/+20 * - Updated to 1.12cglarkin2011-08-262-4/+5 * - Update to 0.97wen2011-08-252-4/+3 * Use libdata/pkgconfig instead of lib/pkgconfig,maho2011-08-252-4/+3 * adjust pkg-plistmaho2011-08-251-1/+1 * Use libdata/pkgconfig instead of lib/pkgconfig.maho2011-08-252-2/+4 * - Updated to 3.9.0glarkin2011-08-252-3/+3 * - Drop maintainership for this port -- I don't use it any morecrees2011-08-251-2/+2 * fix the clang buildbf2011-08-202-2/+38 * Update to 3.10.1zi2011-08-174-54/+946 * adoptbf2011-08-121-1/+1 * Remove USE_GNOME=gnometarget from ports. It has been a empty keyword sincekwm2011-08-126-6/+4 * - update to 3.3.0beech2011-08-114-166/+449 * - update MASTER_SITESdinoex2011-08-072-4/+4 * - Update to 0.99.22wen2011-08-044-18/+22 * Remove WWW entries from unmaintained ports that return 404 or where the domainehaupt2011-08-031-2/+0 * Deprecate some ports where I can't find distfiles and upstreambapt2011-08-032-0/+6 * Mark BROKEN: Does not fetchbapt2011-08-031-0/+2 * Fix master_sitebapt2011-08-032-2/+2 * Remove some expired portsbapt2011-08-025-74/+0 * - Update to 0.008sunpoet2011-08-012-4/+8 * - Chase guile shared lib bumpjlaffaye2011-07-314-6/+8 * Build fixes with glib 2.28. gtk 2.24, gtkmm 2.24 and vala 0.12.kwm2011-07-302-0/+16 * remove science/bblimage; attach science/pyvox to build;bf2011-07-288-216/+1 * update R to 2.13.1 [1], and adjust dependent ports (thisbf2011-07-282-2/+2 * Update to 1.12makc2011-07-213-31/+49 * Now that the Java 1.3 and Java 1.4 ports are deprecated and will expire soon,linimon2011-07-214-4/+4 * - Update to 1.5.1sunpoet2011-07-164-39/+41 * - Bump PORTREVISION for science/hdf5-18 shlib changesunpoet2011-07-158-11/+16 * - Update to 1.8.7sunpoet2011-07-15