aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/megapov/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/megapov/Makefile b/graphics/megapov/Makefile
index bbc43534a12b..51011bb8e722 100644
--- a/graphics/megapov/Makefile
+++ b/graphics/megapov/Makefile
@@ -37,6 +37,12 @@ CXXFLAGS+= -mcpu=i686 -march=i686 -mfancy-math-387
.endif # i386
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502103
+BROKEN= "Install fails on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%X11BASE%%|${X11BASE}|g ; \
@@ -66,4 +72,4 @@ do-install:
@${FIND} ${EXAMPLESDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>