aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/zita-convolver/Makefile6
-rw-r--r--audio/zita-convolver/files/patch-Makefile9
-rw-r--r--biology/phyml/Makefile9
-rw-r--r--games/trigger-rally/Makefile8
-rw-r--r--games/trigger-rally/files/patch-GNUmakefile9
5 files changed, 31 insertions, 10 deletions
diff --git a/audio/zita-convolver/Makefile b/audio/zita-convolver/Makefile
index 16beee125d40..fd1f79361bd6 100644
--- a/audio/zita-convolver/Makefile
+++ b/audio/zita-convolver/Makefile
@@ -16,9 +16,9 @@ LICENSE_FILE= ${WRKSRC}/../COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3
LIB_DEPENDS= libfftw3f.so:math/fftw3-float
-BROKEN_aarch64= fails to compile: c++: the clang compiler does not support '-march=native'
-BROKEN_armv6= fails to compile: c++: the clang compiler does not support '-march=native'
-BROKEN_armv7= fails to compile: c++: the clang compiler does not support '-march=native'
+#BROKEN_aarch64= fails to compile: c++: the clang compiler does not support '-march=native'
+#BROKEN_armv6= fails to compile: c++: the clang compiler does not support '-march=native'
+#BROKEN_armv7= fails to compile: c++: the clang compiler does not support '-march=native'
USES= compiler:c++11-lib gmake localbase:ldflags tar:bz2
USE_LDCONFIG= yes
diff --git a/audio/zita-convolver/files/patch-Makefile b/audio/zita-convolver/files/patch-Makefile
index cfab1e421c38..64c50cefb43a 100644
--- a/audio/zita-convolver/files/patch-Makefile
+++ b/audio/zita-convolver/files/patch-Makefile
@@ -11,6 +11,15 @@
MAJVERS = 3
+@@ -33,7 +33,7 @@ VERSION = $(MAJVERS).$(MINVERS)
+ CPPFLAGS += -I. -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -DENABLE_VECTOR_MODE
+ CXXFLAGS += -fPIC -Wall
+ CXXFLAGS += -ffast-math -funroll-loops -O3
+-CXXFLAGS += -march=native
++#CXXFLAGS += -march=native
+ LDLFAGS +=
+ LDLIBS +=
+
@@ -45,9 +45,10 @@ ZITA-CONVOLVER_DEP = -lfftw3f -lpthread
ZITA-CONVOLVER_O = zita-convolver.o
ZITA-CONVOLVER_H = zita-convolver.h
diff --git a/biology/phyml/Makefile b/biology/phyml/Makefile
index 652db021400e..53c8ca69ab72 100644
--- a/biology/phyml/Makefile
+++ b/biology/phyml/Makefile
@@ -13,9 +13,9 @@ COMMENT= Simple, fast, and accurate algorithm to estimate large phylogenies
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_aarch64= fails to compile: c++: the clang compiler does not support '-march=native'
-BROKEN_armv6= fails to compile: c++: the clang compiler does not support '-march=native'
-BROKEN_armv7= fails to compile: c++: the clang compiler does not support '-march=native'
+#BROKEN_aarch64= fails to compile: c++: the clang compiler does not support '-march=native'
+#BROKEN_armv6= fails to compile: c++: the clang compiler does not support '-march=native'
+#BROKEN_armv7= fails to compile: c++: the clang compiler does not support '-march=native'
USE_GITHUB= yes
GH_ACCOUNT= stephaneguindon
@@ -50,6 +50,9 @@ BIN_SUFFIX= # none
post-patch:
@${REINPLACE_CMD} -e \
's|-O2 .* $${ARCH_flag}|$${CFLAGS}|' ${WRKSRC}/configure.ac
+.if ${ARCH} != amd64 && ${ARCH} != i386
+ @${REINPLACE_CMD} -e 's|VECTOR_FLAG=-march=native|dnl &|' ${WRKSRC}/configure.ac
+.endif
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/utilities.h
post-install-DOCS-on:
diff --git a/games/trigger-rally/Makefile b/games/trigger-rally/Makefile
index b1e5179894c2..edd650bb94e2 100644
--- a/games/trigger-rally/Makefile
+++ b/games/trigger-rally/Makefile
@@ -15,10 +15,10 @@ LICENSE= GPLv2
LIB_DEPENDS= libphysfs.so:devel/physfs
LIB_DEPENDS+= libalut.so:audio/freealut
-BROKEN_aarch64= fails to compile: error: the clang compiler does not support -march=native
-BROKEN_armv6= fails to compile: error: the clang compiler does not support -march=native
-BROKEN_armv7= fails to compile: error: the clang compiler does not support -march=native
-BROKEN_powerpc64= fails to compile: error: the clang compiler does not support -march=native
+#BROKEN_aarch64= fails to compile: error: the clang compiler does not support -march=native
+#BROKEN_armv6= fails to compile: error: the clang compiler does not support -march=native
+#BROKEN_armv7= fails to compile: error: the clang compiler does not support -march=native
+#BROKEN_powerpc64= fails to compile: error: the clang compiler does not support -march=native
WRKSRC_SUBDIR= src
USES= gmake openal:al,alut
diff --git a/games/trigger-rally/files/patch-GNUmakefile b/games/trigger-rally/files/patch-GNUmakefile
index db931b65efca..2d94210c4e44 100644
--- a/games/trigger-rally/files/patch-GNUmakefile
+++ b/games/trigger-rally/files/patch-GNUmakefile
@@ -1,5 +1,14 @@
--- GNUmakefile.orig 2016-11-05 17:27:10 UTC
+++ GNUmakefile
+@@ -21,7 +21,7 @@ SRCFILES := $(shell find $(PROJDI
+ OBJFILES := $(patsubst %.cpp, %.o, $(SRCFILES))
+ DEPFILES := $(patsubst %.cpp, %.d, $(SRCFILES))
+ WARNINGS ?= -Wall -Wextra -pedantic
+-OPTIMS ?= -march=native -mtune=native -Ofast
++OPTIMS ?= -mtune=native -Ofast
+ DMACROS := -DNDEBUG -DUNIX -DPACKAGE_VERSION=\"$(DISTVER)\"
+ INCDIRS := -I'./include'
+ CXXFLAGS += -std=c++11 $(WARNINGS) $(OPTIMS)
@@ -125,7 +125,7 @@ $(TR_EXEFILE): $(OBJFILES)
printf "\t%s\n" $$file; \
done;