aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/shutter/Makefile2
-rw-r--r--deskutils/shutter/files/patch-CVE-2015-08542
2 files changed, 2 insertions, 2 deletions
diff --git a/deskutils/shutter/Makefile b/deskutils/shutter/Makefile
index 82bf7c5f1932..f9d5628e646f 100644
--- a/deskutils/shutter/Makefile
+++ b/deskutils/shutter/Makefile
@@ -3,7 +3,7 @@
PORTNAME= shutter
PORTVERSION= 0.93.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils
MASTER_SITES= http://shutter-project.org/wp-content/uploads/releases/tars/
diff --git a/deskutils/shutter/files/patch-CVE-2015-0854 b/deskutils/shutter/files/patch-CVE-2015-0854
index 58e82b0a88ff..fed4e103a473 100644
--- a/deskutils/shutter/files/patch-CVE-2015-0854
+++ b/deskutils/shutter/files/patch-CVE-2015-0854
@@ -5,7 +5,7 @@
sub xdg_open {
my ( $self, $dialog, $link, $user_data ) = @_;
- system("xdg-open $link");
-+ @args = ("xdg-open", "$link");
++ my @args = ("xdg-open", "$link");
+ system(@args);
if($?){
my $response = $self->{_dialogs}->dlg_error_message(