aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/cppcheck/files/patch-CMakeLists.txt4
-rw-r--r--devel/cppcheck/files/patch-gui_CMakeLists.txt6
-rw-r--r--devel/p5-Config-Auto/files/patch-Makefile.PL16
-rw-r--r--graphics/ImageMagick/files/patch-config_policy.xml16
-rw-r--r--graphics/ImageMagick7/files/patch-config_policy.xml16
-rw-r--r--japanese/esecanna/files/patch-README.jp9
-rw-r--r--lang/tcl84/files/patch-warnings16
-rw-r--r--www/py-gunicorn/files/patch-requirements__test.txt4
-rw-r--r--x11/rxvt-unicode/files/patch-src_gencompose10
-rw-r--r--x11/rxvt-unicode/files/patch-src_genlinedraw10
10 files changed, 55 insertions, 52 deletions
diff --git a/devel/cppcheck/files/patch-CMakeLists.txt b/devel/cppcheck/files/patch-CMakeLists.txt
index a51c9ac7b367..61e1bc259341 100644
--- a/devel/cppcheck/files/patch-CMakeLists.txt
+++ b/devel/cppcheck/files/patch-CMakeLists.txt
@@ -1,8 +1,8 @@
---- CMakeLists.txt.orig 2017-05-13 09:27:11 UTC
+--- CMakeLists.txt.orig 2017-10-07 21:11:39 UTC
+++ CMakeLists.txt
@@ -1,4 +1,4 @@
-project(CppCheck)
+project(cppcheck)
- cmake_minimum_required(VERSION 2.8)
+ cmake_minimum_required(VERSION 2.8.4)
include(GNUInstallDirs)
diff --git a/devel/cppcheck/files/patch-gui_CMakeLists.txt b/devel/cppcheck/files/patch-gui_CMakeLists.txt
index aff4c31501b0..045a0c7646ad 100644
--- a/devel/cppcheck/files/patch-gui_CMakeLists.txt
+++ b/devel/cppcheck/files/patch-gui_CMakeLists.txt
@@ -1,7 +1,7 @@
---- gui/CMakeLists.txt.orig 2017-05-13 09:27:11 UTC
+--- gui/CMakeLists.txt.orig 2017-10-07 21:11:39 UTC
+++ gui/CMakeLists.txt
-@@ -29,7 +29,7 @@ if (BUILD_GUI)
-
+@@ -27,7 +27,7 @@ if (BUILD_GUI)
+ qt5_use_modules(cppcheck-gui ${GUI_QT_COMPONENTS})
install(TARGETS cppcheck-gui RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
- install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
diff --git a/devel/p5-Config-Auto/files/patch-Makefile.PL b/devel/p5-Config-Auto/files/patch-Makefile.PL
index 1f2bac930ac3..62f90e9bc736 100644
--- a/devel/p5-Config-Auto/files/patch-Makefile.PL
+++ b/devel/p5-Config-Auto/files/patch-Makefile.PL
@@ -1,12 +1,14 @@
---- Makefile.PL.orig Sun Sep 28 13:41:23 2003
-+++ Makefile.PL Sun Sep 28 13:42:32 2003
-@@ -29,4 +29,9 @@
- AUTHOR => 'Jos I. Boumans <kane@cpan.org>')
- : ()
- ),
+--- Makefile.PL.orig 2013-05-12 15:18:54 UTC
++++ Makefile.PL
+@@ -29,6 +29,11 @@ WriteMakefile1(
+ LICENSE => 'perl',
+ META_MERGE => {
+ resources => {
+
+ 'MAN3PODS' => {
+ 'lib/Config/Auto.pm' => '$(INST_MAN3DIR)/Config::Auto.$(MAN3EXT)',
+ },
+
- );
+ repository => 'https://github.com/jib/config-auto',
+ },
+ },
diff --git a/graphics/ImageMagick/files/patch-config_policy.xml b/graphics/ImageMagick/files/patch-config_policy.xml
index 2a285225c948..f7af1e22efcb 100644
--- a/graphics/ImageMagick/files/patch-config_policy.xml
+++ b/graphics/ImageMagick/files/patch-config_policy.xml
@@ -1,12 +1,14 @@
---- config/policy.xml.orig 2016-05-09 19:28:58.000000000 +0200
-+++ config/policy.xml 2016-05-10 17:44:26.720503000 +0200
-@@ -64,4 +64,9 @@
- <!-- <policy domain="coder" rights="none" pattern="HTTPS" /> -->
- <!-- <policy domain="path" rights="none" pattern="@*" /> -->
- <policy domain="cache" name="shared-secret" value="passphrase"/>
+--- config/policy.xml.orig 2017-09-23 12:22:04 UTC
++++ config/policy.xml
+@@ -64,6 +64,11 @@
+ <!-- <policy domain="resource" name="map" value="4GiB"/> -->
+ <!-- <policy domain="resource" name="width" value="10KP"/> -->
+ <!-- <policy domain="resource" name="height" value="10KP"/> -->
+ <policy domain="coder" rights="none" pattern="EPHEMERAL" />
+ <policy domain="coder" rights="none" pattern="URL" />
+ <policy domain="coder" rights="none" pattern="HTTPS" />
+ <policy domain="coder" rights="none" pattern="MVG" />
+ <policy domain="coder" rights="none" pattern="MSL" />
- </policymap>
+ <!-- <policy domain="resource" name="area" value="100MP"/> -->
+ <!-- <policy domain="resource" name="disk" value="16EiB"/> -->
+ <!-- <policy domain="resource" name="file" value="768"/> -->
diff --git a/graphics/ImageMagick7/files/patch-config_policy.xml b/graphics/ImageMagick7/files/patch-config_policy.xml
index 2a285225c948..f2c914df229d 100644
--- a/graphics/ImageMagick7/files/patch-config_policy.xml
+++ b/graphics/ImageMagick7/files/patch-config_policy.xml
@@ -1,12 +1,14 @@
---- config/policy.xml.orig 2016-05-09 19:28:58.000000000 +0200
-+++ config/policy.xml 2016-05-10 17:44:26.720503000 +0200
-@@ -64,4 +64,9 @@
- <!-- <policy domain="coder" rights="none" pattern="HTTPS" /> -->
- <!-- <policy domain="path" rights="none" pattern="@*" /> -->
- <policy domain="cache" name="shared-secret" value="passphrase"/>
+--- config/policy.xml.orig 2017-09-23 12:22:07 UTC
++++ config/policy.xml
+@@ -64,6 +64,11 @@
+ <!-- <policy domain="resource" name="map" value="4GiB"/> -->
+ <!-- <policy domain="resource" name="width" value="10KP"/> -->
+ <!-- <policy domain="resource" name="height" value="10KP"/> -->
+ <policy domain="coder" rights="none" pattern="EPHEMERAL" />
+ <policy domain="coder" rights="none" pattern="URL" />
+ <policy domain="coder" rights="none" pattern="HTTPS" />
+ <policy domain="coder" rights="none" pattern="MVG" />
+ <policy domain="coder" rights="none" pattern="MSL" />
- </policymap>
+ <!-- <policy domain="resource" name="area" value="100MP"/> -->
+ <!-- <policy domain="resource" name="disk" value="16EiB"/> -->
+ <!-- <policy domain="resource" name="file" value="768"/> -->
diff --git a/japanese/esecanna/files/patch-README.jp b/japanese/esecanna/files/patch-README.jp
index cc3b33db295e..3daab7d4b686 100644
--- a/japanese/esecanna/files/patch-README.jp
+++ b/japanese/esecanna/files/patch-README.jp
@@ -1,5 +1,5 @@
---- README.jp.orig Fri Feb 25 02:22:33 2000
-+++ README.jp Fri Feb 25 23:58:43 2000
+--- README.jp.orig 2000-09-09 03:38:39 UTC
++++ README.jp
@@ -5,7 +5,7 @@
1) えせかんなの設定
@@ -45,8 +45,3 @@
えせかんなは /var/log/esecanna.log にログを吐きます。このログを見て、何が起き
てるのか、手がかりを得ることが出来ます。
-@@ -58,4 +55,4 @@
- 大阪大学医学部医学科 学2 |
- Debian JP Project | take@debian.or.jp
- LILO, NetFort | take@netfort.gr.jp
-==========================================================
diff --git a/lang/tcl84/files/patch-warnings b/lang/tcl84/files/patch-warnings
index ee2cab063834..609cf4749782 100644
--- a/lang/tcl84/files/patch-warnings
+++ b/lang/tcl84/files/patch-warnings
@@ -1,12 +1,14 @@
Quiet the noisy "already defined" warning triggered, when building with TCL_THREADS.
---- ../unix/tclUnixPort.h Tue Dec 6 04:01:07 2005
-+++ ../unix/tclUnixPort.h Tue Jun 27 15:16:21 2006
-@@ -607,4 +607,7 @@
- #endif
- EXTERN char * TclpInetNtoa(struct in_addr);
+--- ../unix/tclUnixPort.h.orig 2012-11-19 16:27:16 UTC
++++ ../unix/tclUnixPort.h
+@@ -606,6 +606,9 @@ extern double strtod();
+ # undef HAVE_LANGINFO
+ # endif
+ # endif /* MAC_OS_X_VERSION_MAX_ALLOWED */
+#ifdef inet_ntoa
+# undef inet_ntoa
+#endif
- #define inet_ntoa(x) TclpInetNtoa(x)
- #else
+ # if defined(HAVE_COREFOUNDATION) && defined(__LP64__) && \
+ defined(HAVE_WEAK_IMPORT) && MAC_OS_X_VERSION_MIN_REQUIRED < 1050
+ # warning "Weak import of 64-bit CoreFoundation is not supported, will not run on Mac OS X < 10.5."
diff --git a/www/py-gunicorn/files/patch-requirements__test.txt b/www/py-gunicorn/files/patch-requirements__test.txt
index 72a691b5c27e..869a095c1975 100644
--- a/www/py-gunicorn/files/patch-requirements__test.txt
+++ b/www/py-gunicorn/files/patch-requirements__test.txt
@@ -1,6 +1,6 @@
---- requirements_test.txt.orig 2015-02-04 13:43:57 UTC
+--- requirements_test.txt.orig 2016-01-05 00:10:38 UTC
+++ requirements_test.txt
@@ -1,2 +1 @@
--pytest==2.6.3
+-pytest==2.8.3
-pytest-cov==1.7.0
+pytest>=2.6.3
diff --git a/x11/rxvt-unicode/files/patch-src_gencompose b/x11/rxvt-unicode/files/patch-src_gencompose
index 6ab69da246f6..6e66001b4661 100644
--- a/x11/rxvt-unicode/files/patch-src_gencompose
+++ b/x11/rxvt-unicode/files/patch-src_gencompose
@@ -1,8 +1,8 @@
---- ./src/gencompose.orig Wed Aug 4 04:59:09 2004
-+++ ./src/gencompose Tue Aug 10 00:03:21 2004
+--- src/gencompose.orig 2014-05-22 18:53:16 UTC
++++ src/gencompose
@@ -1,4 +1,4 @@
--#!/opt/bin/perl
+-#!/usr/bin/perl
+#!/usr/bin/env perl
- # the generated tables mostly have NOT been checked so far!
-
+ open UNIDATA, "<", "www.unicode.org/Public/UNIDATA/UnicodeData.txt"
+ or die "www.unicode.org/Public/UNIDATA/UnicodeData.txt: $!";
diff --git a/x11/rxvt-unicode/files/patch-src_genlinedraw b/x11/rxvt-unicode/files/patch-src_genlinedraw
index ccd2058fdd73..9161abbbabfe 100644
--- a/x11/rxvt-unicode/files/patch-src_genlinedraw
+++ b/x11/rxvt-unicode/files/patch-src_genlinedraw
@@ -1,8 +1,8 @@
---- ./src/genlinedraw.orig Wed Aug 4 04:59:09 2004
-+++ ./src/genlinedraw Tue Aug 10 00:03:21 2004
+--- src/genlinedraw.orig 2014-05-22 18:53:16 UTC
++++ src/genlinedraw
@@ -1,4 +1,4 @@
--#!/opt/bin/perl
+-#!/usr/bin/perl
+#!/usr/bin/env perl
- # the generated tables mostly have NOT been checked so far!
-
+ open TABLE, ">", "table/linedraw.h";
+ select TABLE;