aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/Makefile1
-rw-r--r--dns/drool/Makefile24
-rw-r--r--dns/drool/distinfo3
-rw-r--r--dns/drool/pkg-descr8
-rw-r--r--dns/drool/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 52bf9b5ca30d..1c53944caea4 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -58,6 +58,7 @@
SUBDIR += dnswall
SUBDIR += doc
SUBDIR += dq
+ SUBDIR += drool
SUBDIR += dualserver
SUBDIR += erlang-idna
SUBDIR += ez-ipupdate
diff --git a/dns/drool/Makefile b/dns/drool/Makefile
new file mode 100644
index 000000000000..694188d47aaa
--- /dev/null
+++ b/dns/drool/Makefile
@@ -0,0 +1,24 @@
+# Created by: Jaap Akkerhuis <jaap@NLnetLabs.nl>
+# $FreeBSD$
+
+PORTNAME= drool
+DISTVERSION= 1.0.0
+DISTVERSIONSUFFIX= -beta.3
+CATEGORIES= dns
+MASTER_SITES= https://www.dns-oarc.net/files/drool/
+
+MAINTAINER= jaap@NLnetLabs.nl
+COMMENT= Replay DNS traffic from packet capture files
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libev.so:devel/libev
+
+USES= pkgconfig
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CPPFLAGS+= $$(pkg-config libev --cflags-only-I)
+LDFLAGS+= $$(pkg-config libev --libs-only-L)
+
+.include <bsd.port.mk>
diff --git a/dns/drool/distinfo b/dns/drool/distinfo
new file mode 100644
index 000000000000..c2285c7810fa
--- /dev/null
+++ b/dns/drool/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492021886
+SHA256 (drool-1.0.0-beta.3.tar.gz) = cbff7cdb25a9a994eea11074b1263e42703c6a556db9e012fe77bb4191cf2be9
+SIZE (drool-1.0.0-beta.3.tar.gz) = 403883
diff --git a/dns/drool/pkg-descr b/dns/drool/pkg-descr
new file mode 100644
index 000000000000..5c0b7e81afff
--- /dev/null
+++ b/dns/drool/pkg-descr
@@ -0,0 +1,8 @@
+DNS Replay Tool (drool) can replay DNS traffic from packet capture
+(PCAP) files and send it to a specified server, with options such
+as to manipulate the timing between packets, as well as loop packets
+infinitely or for a set number of iterations. This tool's goal is
+to be able to produce a high amount of UDP packets per second and
+TCP sessions per second on common hardware.
+
+WWW: https://www.dns-oarc.net/tools/drool
diff --git a/dns/drool/pkg-plist b/dns/drool/pkg-plist
new file mode 100644
index 000000000000..367a9c9ff0ea
--- /dev/null
+++ b/dns/drool/pkg-plist
@@ -0,0 +1,6 @@
+bin/drool
+man/man1/drool.1.gz
+man/man5/drool.conf.5.gz
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README.md