aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/node/Makefile14
-rw-r--r--www/node/distinfo6
-rw-r--r--www/node/files/patch-common.gypi12
-rw-r--r--www/node/files/patch-deps_v8_src_base_cpu.cc8
-rw-r--r--www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc12
-rw-r--r--www/node/pkg-plist1
6 files changed, 15 insertions, 38 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 91a50c492a4c..388d5a21a92c 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 8.2.1
+PORTVERSION= 8.3.0
DISTVERSIONPREFIX= v
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
@@ -84,18 +84,6 @@ CONFIGURE_ARGS+=--openssl-no-asm
CXXFLAGS+= -D_GLIBCXX_USE_C99
.endif
-.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 40
-# Conditinal work around for a bug in libc++ included with clang 3.x:
-# https://bugs.llvm.org/show_bug.cgi?id=18249
-# https://bugs.llvm.org/show_bug.cgi?id=18350
-# https://bugs.llvm.org/show_bug.cgi?id=18853
-#
-# Upstream Node.js adds the define to all FreeBSD builds. This breaks
-# the build with clang 4.0, so we patch it out (files/patch-common.gypi)
-# and add it here instead.
-CXXFLAGS+= -D_LIBCPP_TRIVIAL_PAIR_COPY_CTOR
-.endif
-
.if ${PORT_OPTIONS:MDTRACE}
CONFIGURE_ARGS+= --with-dtrace
.endif
diff --git a/www/node/distinfo b/www/node/distinfo
index 3c56ab2648e2..0cf5e3946696 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500933063
-SHA256 (node-v8.2.1.tar.gz) = 66fe1379bc7daf9a16c6b5c45ab695bf1cdcfae9738d2989e940104d6b31973f
-SIZE (node-v8.2.1.tar.gz) = 30334692
+TIMESTAMP = 1502344455
+SHA256 (node-v8.3.0.tar.gz) = 33fa7a02f265636c240be9ebd0f93942f77856a9c2c751592da1a0962b6ed010
+SIZE (node-v8.3.0.tar.gz) = 30588563
diff --git a/www/node/files/patch-common.gypi b/www/node/files/patch-common.gypi
deleted file mode 100644
index 820e6cc2c4ee..000000000000
--- a/www/node/files/patch-common.gypi
+++ /dev/null
@@ -1,12 +0,0 @@
---- common.gypi.orig 2017-06-28 05:52:55 UTC
-+++ common.gypi
-@@ -407,9 +407,6 @@
- 'libraries': [ '-lelf' ],
- }],
- ['OS=="freebsd"', {
-- # Use this flag because on FreeBSD std::pairs copy constructor is non-trivial
-- # https://lists.freebsd.org/pipermail/freebsd-toolchain/2016-March/002094.html
-- 'cflags': [ '-D_LIBCPP_TRIVIAL_PAIR_COPY_CTOR=1' ],
- 'ldflags': [
- '-Wl,--export-dynamic',
- ],
diff --git a/www/node/files/patch-deps_v8_src_base_cpu.cc b/www/node/files/patch-deps_v8_src_base_cpu.cc
index 8a155cb0109f..b8bed3b277b2 100644
--- a/www/node/files/patch-deps_v8_src_base_cpu.cc
+++ b/www/node/files/patch-deps_v8_src_base_cpu.cc
@@ -1,6 +1,6 @@
---- deps/v8/src/base/cpu.cc.orig 2017-06-19 14:24:53.928317000 +0000
-+++ deps/v8/src/base/cpu.cc 2017-06-19 14:24:57.294664000 +0000
-@@ -601,6 +601,7 @@
+--- deps/v8/src/base/cpu.cc.orig 2017-08-09 18:48:10 UTC
++++ deps/v8/src/base/cpu.cc
+@@ -607,6 +607,7 @@ CPU::CPU()
#elif V8_HOST_ARCH_ARM64
@@ -8,7 +8,7 @@
CPUInfo cpu_info;
// Extract implementor from the "CPU implementer" field.
-@@ -634,6 +635,8 @@
+@@ -640,6 +641,8 @@ CPU::CPU()
}
delete[] part;
}
diff --git a/www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc b/www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc
index 0844d5dee608..921c53da2cbe 100644
--- a/www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc
+++ b/www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc
@@ -1,8 +1,8 @@
---- deps/v8/src/base/platform/platform-freebsd.cc.orig 2017-06-15 11:55:21 UTC
+--- deps/v8/src/base/platform/platform-freebsd.cc.orig 2017-08-09 18:48:10 UTC
+++ deps/v8/src/base/platform/platform-freebsd.cc
-@@ -35,6 +35,48 @@
- namespace v8 {
- namespace base {
+@@ -48,6 +48,48 @@ void* OS::Allocate(const size_t requested, size_t* all
+ return mbase;
+ }
+#ifdef __arm__
+
@@ -47,5 +47,5 @@
+#endif // def __arm__
+
- const char* OS::LocalTimezone(double time, TimezoneCache* cache) {
- if (std::isnan(time)) return "";
+ static unsigned StringToLong(char* buffer) {
+ return static_cast<unsigned>(strtol(buffer, NULL, 16)); // NOLINT
diff --git a/www/node/pkg-plist b/www/node/pkg-plist
index e63c91105cd1..ee414daa71d5 100644
--- a/www/node/pkg-plist
+++ b/www/node/pkg-plist
@@ -111,6 +111,7 @@ include/node/v8-platform.h
include/node/v8-profiler.h
include/node/v8-testing.h
include/node/v8-util.h
+include/node/v8-value-serializer-version.h
include/node/v8-version.h
include/node/v8-version-string.h
include/node/v8.h