aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--polish/ekg2/Makefile60
1 files changed, 24 insertions, 36 deletions
diff --git a/polish/ekg2/Makefile b/polish/ekg2/Makefile
index 105c225c6707..26389196ec0e 100644
--- a/polish/ekg2/Makefile
+++ b/polish/ekg2/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libgadu.so:${PORTSDIR}/polish/libgadu \
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USES= gmake iconv pathfix pkgconfig libtool
+USES= gmake iconv libtool pathfix pkgconfig readline
CONFIGURE_ARGS+= --enable-shared \
--disable-static \
@@ -38,65 +38,53 @@ OPTIONS_DEFINE= ASPELL GPG GSM GTK2 NLS PERL PYTHON SQLITE UNICODE XOSD
OPTIONS_DEFAULT=ASPELL
OPTIONS_SUB= yes
-ASPELL_DESC= Enable spell checking support
-GPG_DESC= Enable gpg plugin
-GSM_DESC= Enable gsm audio plugin
-GTK2_DESC= Enable gtk plugin
-PERL_DESC= Enable perl plugin
-PYTHON_DESC= Enable python plugin
-SQLITE_DESC= Enable sqlite plugin
-UNICODE_DESC= Enable unicode (experimental)
-XOSD_DESC= Enable xosd plugin
-
-ASPELL_CONFIGURE_ON= --with-aspell
-ASPELL_CONFIGURE_OFF= --without-aspell
+GPG_DESC= GPG plugin
+GSM_DESC= GSM audio plugin
+GTK2_DESC= GTK+ 2 plugin
+PERL_DESC= Perl plugin
+PYTHON_DESC= Python plugin
+SQLITE_DESC= SQLite plugin
+UNICODE_DESC= Unicode support (experimental)
+XOSD_DESC= Xosd plugin
+
+ASPELL_CONFIGURE_WITH= aspell
ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
ASPELL_RUN_DEPENDS= ${LOCALBASE}/share/aspell/pl.rws:${PORTSDIR}/polish/aspell
-GPG_CONFIGURE_ON= --with-gpg
-GPG_CONFIGURE_OFF= --without-gpg
+GPG_CONFIGURE_WITH= gpg
GPG_LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme \
libgpg-error.so:${PORTSDIR}/security/libgpg-error
GPG_RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
-GSM_CONFIGURE_ON= --with-libgsm
-GSM_CONFIGURE_OFF= --without-libgsm
+GSM_CONFIGURE_WITH= libgsm
GSM_LIB_DEPENDS= libgsm.so:${PORTSDIR}/audio/gsm
-GTK2_CONFIGURE_ON= --with-gtk
-GTK2_CONFIGURE_OFF= --without-gtk
+GTK2_CONFIGURE_WITH= gtk
+GTK2_USE= GNOME=gtk2
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
-PERL_CONFIGURE_ON= --with-perl
-PERL_CONFIGURE_OFF= --without-perl
+PERL_CONFIGURE_WITH= perl
PERL_USES= perl5
-PYTHON_CONFIGURE_ON= --with-python
-PYTHON_CONFIGURE_OFF= --without-python
+PYTHON_CONFIGURE_WITH= python
+PYTHON_USE= PYTHON=yes
-SQLITE_CONFIGURE_ON= --with-sqlite3
-SQLITE_CONFIGURE_OFF= --without-sqlite3
+SQLITE_CONFIGURE_WITH= sqlite3
SQLITE_LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
-UNICODE_CONFIGURE_ON= --enable-unicode
+UNICODE_CONFIGURE_ENABLE= unicode
-XOSD_CONFIGURE_ON= --with-libxosd
-XOSD_CONFIGURE_OFF= --without-libxosd
+XOSD_CONFIGURE_WITH= libxosd
XOSD_LIB_DEPENDS= libxosd.so:${PORTSDIR}/misc/xosd
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MGTK2}
-USE_GNOME+= gtk20
-.endif
-
-.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
-.endif
-
post-patch:
+# needs newer headers for O_NOFOLLOW flag
+ @${REINPLACE_CMD} '/_XOPEN_SOURCE/ s|600|700|' \
+ ${WRKSRC}/plugins/xmsg/xmsg.c
.if ${PORT_OPTIONS:MPYTHON}
@${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|' \
${WRKSRC}/contrib/python/notify-bubble.py