aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/libdsp/Makefile17
-rw-r--r--devel/libdsp/distinfo2
-rw-r--r--devel/libdsp/files/patch-Makefile13
-rw-r--r--devel/libdsp/files/patch-Makefile_FreeBSD17
-rw-r--r--devel/libdsp/pkg-plist9
5 files changed, 27 insertions, 31 deletions
diff --git a/devel/libdsp/Makefile b/devel/libdsp/Makefile
index dc527be4f342..dd1901225ac6 100644
--- a/devel/libdsp/Makefile
+++ b/devel/libdsp/Makefile
@@ -7,30 +7,23 @@
#
PORTNAME= libdsp
-PORTVERSION= 3.3.8
+PORTVERSION= 4.0.0
CATEGORIES= devel audio
-MASTER_SITES= http://www.pp.clinet.fi/~visitor/dlbins/
-DISTNAME= libdsp-src
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= libdsp-src-${PORTVERSION}
MAINTAINER= ijliao@FreeBSD.org
# dont use "USE_LIBTOOL=yes" because there's no configure script
BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
-INSTALLS_SHLIB= yes
-
WRKSRC= ${WRKDIR}/libdsp-src/${PORTNAME:S/dsp/DSP/}-${PORTVERSION}
-MAKEFILE= Makefile.FreeBSD
-INLINE_VER= 1.2.1
-
+INLINE_VER= 1.2.2
USE_GMAKE= yes
-
INSTALLS_SHLIB= yes
post-patch:
@${PERL} -pi -e "s|%%INLINE_VER%%|${INLINE_VER}|g" ${WRKSRC}/${MAKEFILE}
-post-install:
- @${RM} ${PREFIX}/lib/libdsp.la
-
.include <bsd.port.mk>
diff --git a/devel/libdsp/distinfo b/devel/libdsp/distinfo
index e6bb9a6558ce..58e8751967da 100644
--- a/devel/libdsp/distinfo
+++ b/devel/libdsp/distinfo
@@ -1 +1 @@
-MD5 (libdsp-src.tar.gz) = 7b28eb912cc932f7c95f8ab152d6c27d
+MD5 (libdsp-src-4.0.0.tar.gz) = 73845c912233675823a2a699cddf99ef
diff --git a/devel/libdsp/files/patch-Makefile b/devel/libdsp/files/patch-Makefile
new file mode 100644
index 000000000000..5f217e3c964f
--- /dev/null
+++ b/devel/libdsp/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Mon Jul 9 09:56:51 2001
++++ Makefile Mon Jul 9 09:57:37 2001
+@@ -20,4 +20,4 @@
+-CXX = g++
+-CXXFLAGS = -mcpu=k6 -march=k6 -O6 -fomit-frame-pointer -ffast-math -funroll-loops -malign-loops=5 -malign-jumps=5 -malign-functions=5 -mpreferred-stack-boundary=5 -mfancy-math-387 -Wall -Werror
+-DEFS = -D_REENTRANT -D_THREAD_SAFE -D_ISOC9X_SOURCE -DX86 -DUSE_MEMMOVE
+-INCS = -I.
++CXX ?= g++
++CXXFLAGS += -O6 -fomit-frame-pointer -ffast-math -funroll-loops -malign-loops=5 -malign-jumps=5 -malign-functions=5 -mpreferred-stack-boundary=5 -mfancy-math-387 -Wall -Werror
++DEFS = -D_REENTRANT -D_THREAD_SAFE -DBSDSYS -DX86 -DUSE_MEMMOVE
++INCS = -I. -I../Inlines-%%INLINE_VER%%
+@@ -26 +25,0 @@
+-PREFIX = /usr/local
diff --git a/devel/libdsp/files/patch-Makefile_FreeBSD b/devel/libdsp/files/patch-Makefile_FreeBSD
deleted file mode 100644
index 2f9f62cec164..000000000000
--- a/devel/libdsp/files/patch-Makefile_FreeBSD
+++ /dev/null
@@ -1,17 +0,0 @@
---- Makefile.FreeBSD.orig Mon Apr 2 21:09:48 2001
-+++ Makefile.FreeBSD Mon Apr 2 21:10:41 2001
-@@ -17,13 +17,10 @@
- # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- #
-
--CXX = g++
--CXXFLAGS = -mcpu=k6 -march=k6 -O6 -fomit-frame-pointer -ffast-math -funroll-loops -malign-loops=3 -malign-jumps=3 -malign-functions=3 -mpreferred-stack-boundary=3 -mfancy-math-387 -Wall
- DEFS = -D_REENTRANT -D_THREAD_SAFE -DBSDSYS
--INCS = -I.
-+INCS = -I. -I../Inlines-%%INLINE_VER%%
- LIBS = -lm #-ldrfftw -ldfftw
- LIBTOOL = libtool
--PREFIX = /usr/local
-
- VERSION = 0:7:0
-
diff --git a/devel/libdsp/pkg-plist b/devel/libdsp/pkg-plist
index 4a3f343bbede..81d56a250da8 100644
--- a/devel/libdsp/pkg-plist
+++ b/devel/libdsp/pkg-plist
@@ -1,12 +1,19 @@
include/dsp/DSPConfig.hh
include/dsp/DSPOp.hh
include/dsp/Decimator.hh
+include/dsp/FFTDecimator.hh
include/dsp/Filter.hh
+include/dsp/Filter2.hh
+include/dsp/FIRDecimator.hh
include/dsp/Hankel.hh
+include/dsp/ReBuffer.hh
+include/dsp/ReBuffer2.hh
+include/dsp/RecDecimator.hh
include/dsp/Transform4.hh
include/dsp/Transform8.hh
include/dsp/TransformS.hh
@dirrm include/dsp
lib/libdsp.a
+lib/libdsp.la
lib/libdsp.so
-lib/libdsp.so.0
+lib/libdsp.so.1