aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-p2p/libtorrent/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-p2p/libtorrent/Makefile b/net-p2p/libtorrent/Makefile
index 56bd480d8f11..f4bb874c9b79 100644
--- a/net-p2p/libtorrent/Makefile
+++ b/net-p2p/libtorrent/Makefile
@@ -46,13 +46,13 @@ CONFIGURE_ARGS+=--disable-instrumentation
.endif
# Workaround to build on >= 10.x
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
+.if ${OPSYS} == FreeBSD
USE_CXXSTD= c++11
EXTRA_PATCHES+= ${FILESDIR}/extra-clang
.endif
post-patch:
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
+.if ${OPSYS} == FreeBSD
@${FIND} ${WRKSRC} \( -name '*.h' -o -name '*.cc' \) -type f \
-exec ${REINPLACE_CMD} -e 's/tr1::/std::/g' {} \; \
-exec ${REINPLACE_CMD} -e 's/std::std::/std::/g' {} \; \