aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/beatslash-lv2/Makefile2
-rw-r--r--audio/eq10q-lv2/Makefile2
-rw-r--r--audio/midi-matrix-lv2/Makefile4
-rw-r--r--audio/oaml/Makefile2
-rw-r--r--biology/bedtools/Makefile2
-rw-r--r--databases/lua-xapian/Makefile2
-rw-r--r--databases/mysql-connector-c++/Makefile4
-rw-r--r--databases/p5-Xapian/Makefile2
-rw-r--r--databases/postgis23/Makefile3
-rw-r--r--databases/postgis24/Makefile3
-rw-r--r--databases/py-xapian/Makefile2
-rw-r--r--databases/ruby-xapian/Makefile2
-rw-r--r--deskutils/xpad/Makefile2
-rw-r--r--devel/universalindentgui/Makefile2
-rw-r--r--devel/yaml-cpp/Makefile2
-rw-r--r--games/blobby/Makefile3
-rw-r--r--games/frogatto/Makefile2
-rw-r--r--games/trigger-rally/Makefile2
-rw-r--r--games/violetland/Makefile5
-rw-r--r--graphics/graphviz/Makefile5
-rw-r--r--lang/sdcc/Makefile8
-rw-r--r--math/cbc/Makefile2
-rw-r--r--math/cgl/Makefile2
-rw-r--r--math/clp/Makefile4
-rw-r--r--math/clrng/Makefile9
-rw-r--r--math/gnuplot/Makefile2
-rw-r--r--multimedia/libvdpau-va-gl/Makefile9
-rw-r--r--print/pdfcube/Makefile4
-rw-r--r--science/bddsolve/Makefile3
-rw-r--r--textproc/multimarkdown/Makefile4
-rw-r--r--textproc/regex2dfa/Makefile2
-rw-r--r--textproc/tinyxml2/Makefile2
-rw-r--r--www/logtools/Makefile6
-rw-r--r--www/xapian-omega/Makefile2
34 files changed, 49 insertions, 63 deletions
diff --git a/audio/beatslash-lv2/Makefile b/audio/beatslash-lv2/Makefile
index cc157719e132..1bbdeb566881 100644
--- a/audio/beatslash-lv2/Makefile
+++ b/audio/beatslash-lv2/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= lv2>0:audio/lv2 \
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= pkgconfig waf
+USES= compiler:c++11-lang pkgconfig waf
USE_GITHUB= yes
GH_ACCOUNT= blablack
GH_PROJECT= ${PORTNAME}-lv2
diff --git a/audio/eq10q-lv2/Makefile b/audio/eq10q-lv2/Makefile
index 50a22a25b367..4eaf5bedc664 100644
--- a/audio/eq10q-lv2/Makefile
+++ b/audio/eq10q-lv2/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libfftw3.so:math/fftw3 \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= cmake:outsource dos2unix localbase:ldflags pkgconfig
+USES= cmake:outsource compiler:c++11-lang dos2unix localbase:ldflags pkgconfig
USE_GNOME= glib20 gtk20 gtkmm24 gdkpixbuf2 atkmm cairo cairomm pangomm
DOS2UNIX_FILES= dsp/vu.h
diff --git a/audio/midi-matrix-lv2/Makefile b/audio/midi-matrix-lv2/Makefile
index 33b22836d08b..090acf842afa 100644
--- a/audio/midi-matrix-lv2/Makefile
+++ b/audio/midi-matrix-lv2/Makefile
@@ -13,11 +13,9 @@ COMMENT= LV2 'Midi Matrix' plugin bundle: 'Channel Filter'
LICENSE= ART20
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to build: cc1: unrecognized command line option -std=gnu11
-
BUILD_DEPENDS= lv2>0:audio/lv2
-USES= cmake pkgconfig
+USES= cmake compiler:c11 pkgconfig
USE_XORG= x11 xext
USE_GL= gl glu
diff --git a/audio/oaml/Makefile b/audio/oaml/Makefile
index 660086f42958..41c8e655ca97 100644
--- a/audio/oaml/Makefile
+++ b/audio/oaml/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libogg.so:audio/libogg \
USE_GITHUB= yes
GH_ACCOUNT= oamldev
-USES= cmake
+USES= cmake compiler:c++11-lang
CMAKE_ARGS= -DENABLE_UNITYPLUGIN:BOOL=OFF
PORTDOCS= *
diff --git a/biology/bedtools/Makefile b/biology/bedtools/Makefile
index a19c3ff723a6..3103c1deca8a 100644
--- a/biology/bedtools/Makefile
+++ b/biology/bedtools/Makefile
@@ -12,7 +12,7 @@ COMMENT= Toolset for genome set arithmetic such as intersect, union
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake python
+USES= compiler:c++11-lang gmake python
USE_GITHUB= yes
GH_ACCOUNT= arq5x
GH_PROJECT= bedtools2
diff --git a/databases/lua-xapian/Makefile b/databases/lua-xapian/Makefile
index 5f26cc8131f5..9fef8ce40a2c 100644
--- a/databases/lua-xapian/Makefile
+++ b/databases/lua-xapian/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR} \
CONFIGURE_ENV= LUA="${LUA_CMD}" LUA_INC="${LUA_INCDIR}" LUA_LIB="${LUA_MODLIBDIR}" LUA_SO=.so
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= libtool lua tar:xz
+USES= compiler:c++11-lang libtool lua tar:xz
PORTDOCS= *
diff --git a/databases/mysql-connector-c++/Makefile b/databases/mysql-connector-c++/Makefile
index e25c1f5fee02..9e1ca96aed17 100644
--- a/databases/mysql-connector-c++/Makefile
+++ b/databases/mysql-connector-c++/Makefile
@@ -15,9 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
-BROKEN_powerpc64= fails to configure: the compiler doesn't support C++11
-
-USES= cmake:outsource mysql ssl
+USES= cmake:outsource compiler:c++11-lang mysql ssl
USE_LDCONFIG= yes
CMAKE_ARGS= -DDOC_DESTINATION="${DOCSDIR}"
diff --git a/databases/p5-Xapian/Makefile b/databases/p5-Xapian/Makefile
index 572c78d03d03..660a991d17be 100644
--- a/databases/p5-Xapian/Makefile
+++ b/databases/p5-Xapian/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR} \
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
LDFLAGS+= -L${LOCALBASE}/lib/perl5/${PERL_VER}/mach/CORE -lperl
-USES= libtool perl5 tar:xz
+USES= compiler:c++11-lang libtool perl5 tar:xz
PORTDOCS= *
diff --git a/databases/postgis23/Makefile b/databases/postgis23/Makefile
index 23d80f4160ac..02f2d0b8d862 100644
--- a/databases/postgis23/Makefile
+++ b/databases/postgis23/Makefile
@@ -20,7 +20,8 @@ LIB_DEPENDS= libproj.so:graphics/proj \
CONFLICTS= postgis20 postgis21 postgis22 postgis24 postgis
-USES= gettext gmake iconv:wchar_t libtool:keepla perl5 pgsql pkgconfig shebangfix
+USES= compiler:c++11-lang gettext gmake iconv:wchar_t libtool:keepla \
+ perl5 pgsql pkgconfig shebangfix
LLD_UNSAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE}
diff --git a/databases/postgis24/Makefile b/databases/postgis24/Makefile
index 66dfb1cea5e3..2f4ab99e4f7b 100644
--- a/databases/postgis24/Makefile
+++ b/databases/postgis24/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= libproj.so:graphics/proj \
CONFLICTS_INSTALL= postgis20 postgis21 postgis22 postgis23 postgis
-USES= gettext gmake gnome iconv:wchar_t libtool:keepla perl5 pgsql pkgconfig shebangfix
+USES= compiler:c++11-lang gettext gmake iconv:wchar_t libtool:keepla \
+ perl5 pgsql pkgconfig shebangfix
LLD_UNSAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE}
diff --git a/databases/py-xapian/Makefile b/databases/py-xapian/Makefile
index 4ed76ad61c30..8c56d3aa9962 100644
--- a/databases/py-xapian/Makefile
+++ b/databases/py-xapian/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR} \
--without-php --without-ruby --without-tcl
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= libtool python tar:xz
+USES= compiler:c++11-lang libtool python tar:xz
USE_PYTHON= flavors
PORTDOCS= *
diff --git a/databases/ruby-xapian/Makefile b/databases/ruby-xapian/Makefile
index 70aa02fd1c8f..909ededf5cda 100644
--- a/databases/ruby-xapian/Makefile
+++ b/databases/ruby-xapian/Makefile
@@ -30,8 +30,8 @@ CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR} \
--without-php --without-python --without-python3 --without-tcl
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
+USES= compiler:c++11-lang libtool tar:xz
USE_RUBY= yes
-USES= libtool tar:xz
PORTDOCS= *
diff --git a/deskutils/xpad/Makefile b/deskutils/xpad/Makefile
index afb886cad401..ce9b519aad6f 100644
--- a/deskutils/xpad/Makefile
+++ b/deskutils/xpad/Makefile
@@ -17,7 +17,7 @@ OPTIONS_DEFINE= NLS DOCS
OPTIONS_SUB= yes
CONFLICTS_INSTALL= xpad3-[0-9]*
-USES= pkgconfig gmake tar:bzip2 autoreconf
+USES= autoreconf compiler:c++11-lang gmake pkgconfig tar:bzip2
USE_XORG= x11 sm ice
USE_GNOME= gtk30 intltool gtksourceview3 cairo
INSTALLS_ICONS= yes
diff --git a/devel/universalindentgui/Makefile b/devel/universalindentgui/Makefile
index 1bc7d7f4746d..9d67c633be35 100644
--- a/devel/universalindentgui/Makefile
+++ b/devel/universalindentgui/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.GPL
LIB_DEPENDS= libqscintilla2_qt4.so:devel/qscintilla2
-USES= dos2unix qmake python:run qt:4 shebangfix
+USES= compiler:c++11-lang dos2unix qmake python:run qt:4 shebangfix
SHEBANG_FILES= indenters/*.py indenters/*.rb
USE_QT= corelib moc_build uic_build rcc_build \
linguist_build network script gui
diff --git a/devel/yaml-cpp/Makefile b/devel/yaml-cpp/Makefile
index 462a6f302199..1a928a2cc05b 100644
--- a/devel/yaml-cpp/Makefile
+++ b/devel/yaml-cpp/Makefile
@@ -12,7 +12,7 @@ COMMENT= YAML parser and emitter in C++ matching the YAML 1.2 spec
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake
+USES= cmake compiler:c++11-lang
USE_LDCONFIG= yes
CMAKE_ARGS+= -DBUILD_SHARED_LIBS:BOOL=ON -DYAML_CPP_BUILD_TOOLS=0
diff --git a/games/blobby/Makefile b/games/blobby/Makefile
index 670d6c5c8e23..ceec14a5b164 100644
--- a/games/blobby/Makefile
+++ b/games/blobby/Makefile
@@ -15,7 +15,6 @@ COMMENT= Official continuation of the famous Blobby Volley 1.x game
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to build: cc1plus: unrecognized command line option "-std=c++11"
NOT_FOR_ARCHS= aarch64
NOT_FOR_ARCHS_REASON= fails to compile: I can't tell what endian-ness to use for your architecture
@@ -23,7 +22,7 @@ LIB_DEPENDS= libphysfs.so:devel/physfs
BUILD_DEPENDS= zip:archivers/zip \
${LOCALBASE}/include/boost/crc.hpp:devel/boost-libs
-USES= cmake dos2unix localbase:ldflags pkgconfig
+USES= cmake compiler:c++11-lang dos2unix localbase:ldflags pkgconfig
DOS2UNIX_REGEX= .*\.(c|h|cpp)
CMAKE_ARGS= -DDATADIR:PATH="${DATADIR}"
WRKSRC= ${WRKDIR}/blobby-${PORTVERSION}
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index ae26cb947278..baaa613b2bb1 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
USE_GITHUB= yes
GH_ACCOUNT= frogatto
-USES= gmake pkgconfig dos2unix
+USES= compiler:c++11-lang dos2unix gmake pkgconfig
ALL_TARGET= game server
USE_GL= glew glu
USE_SDL= sdl image mixer ttf
diff --git a/games/trigger-rally/Makefile b/games/trigger-rally/Makefile
index df4af0f81aff..aaad02d6231c 100644
--- a/games/trigger-rally/Makefile
+++ b/games/trigger-rally/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libphysfs.so:devel/physfs
LIB_DEPENDS+= libalut.so:audio/freealut
WRKSRC_SUBDIR= src
-USES= gmake openal:al,alut
+USES= compiler:c++11-lang gmake openal:al,alut
USE_SDL= sdl2 image2
USE_GL= glu gl glew
MAKEFILE= GNUmakefile
diff --git a/games/violetland/Makefile b/games/violetland/Makefile
index ee01b01a9a7b..40e5c8c60020 100644
--- a/games/violetland/Makefile
+++ b/games/violetland/Makefile
@@ -20,13 +20,14 @@ USE_GITHUB= yes
GH_ACCOUNT= ooxi
GH_TUPLE= jarro2783:CMake-Gettext:6ee6405:cmakegettext/lib/CMake-Gettext
-USES= cmake gettext
+USES= cmake compiler:c++11-lang gettext
USE_SDL= sdl mixer image ttf
USE_GL= gl glu
CMAKE_ARGS= -DDATA_INSTALL_DIR="${DATADIR}" \
-DLOCALE_INSTALL_DIR="${PREFIX}/share/locale"
-CXXFLAGS+= -Wno-c++11-narrowing
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
PORTDOCS= *
PORTDATA= *
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 9ca49faf677e..5f93069484ab 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -20,8 +20,9 @@ LIB_DEPENDS= libltdl.so:devel/libltdl \
libexpat.so:textproc/expat2 \
libgd.so:${GD_PORT}
-USES= cpe pathfix shebangfix gmake bison groff pkgconfig \
- libtool:keepla localbase:ldflags jpeg
+USES= bison compiler:c++11-lang cpe gmake groff \
+ jpeg libtool:keepla localbase:ldflags pathfix \
+ pkgconfig shebangfix
GNU_CONFIGURE= yes
# sincos is broken on armv6, see ports/220591
CFLAGS_armv6= -fno-builtin-sincos -fno-builtin-sin -fno-builtin-cos \
diff --git a/lang/sdcc/Makefile b/lang/sdcc/Makefile
index b6849da26914..d2db619a5c28 100644
--- a/lang/sdcc/Makefile
+++ b/lang/sdcc/Makefile
@@ -2,8 +2,8 @@
PORTNAME= sdcc
PORTVERSION= 3.7.0
-PORTREVISION= 1
DISTVERSIONPREFIX= src-
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= SF
@@ -12,11 +12,13 @@ COMMENT= Small Device C Compiler
LICENSE= GPLv3
+BROKEN_aarch64= Fails to configure: BFD does not support target aarch64-portbld-freebsd11.0
+
BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/adjacency_list.hpp:devel/boost-libs
CONFLICTS_INSTALL= sdcc-[0-9]* sdcc-devel-[0-9]*
GNU_CONFIGURE= yes
-USES= bison gmake readline:port python:2.7,run shebangfix tar:bzip2
+USES= bison compiler:c++11-lang gmake readline:port python:2.7,run shebangfix tar:bzip2
SHEBANG_FILES= support/scripts/as2gbmap.py
OPTIONS_DEFINE= DEVLIB DOCS UCSIM
@@ -51,8 +53,6 @@ Z80_CONFIGURE_OFF= --disable-gbz80-port --disable-r2k-port \
--disable-r3ka-port --disable-tlcs90-port \
--disable-z180-port --disable-z80-port
-BROKEN_aarch64= Fails to configure: BFD does not support target aarch64-portbld-freebsd11.0
-
.include <bsd.port.options.mk>
.if ${ARCH} == "amd64"
diff --git a/math/cbc/Makefile b/math/cbc/Makefile
index 380dd38d9a3c..3cf77db7fbfd 100644
--- a/math/cbc/Makefile
+++ b/math/cbc/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libblas.so:math/blas \
libClp.so:math/clp \
liblapack.so:math/lapack
-USES= fortran gmake libtool pkgconfig
+USES= compiler:c++11-lang fortran gmake libtool pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= coin-or
GH_PROJECT= Cbc
diff --git a/math/cgl/Makefile b/math/cgl/Makefile
index 2996ca932529..42ea8d1c7fb7 100644
--- a/math/cgl/Makefile
+++ b/math/cgl/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libblas.so:math/blas \
libClp.so:math/clp \
liblapack.so:math/lapack
-USES= gmake libtool pkgconfig
+USES= compiler:c++11-lang gmake libtool pkgconfig
GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= coin-or
diff --git a/math/clp/Makefile b/math/clp/Makefile
index 4c1a014d72b8..04a0bdc56a19 100644
--- a/math/clp/Makefile
+++ b/math/clp/Makefile
@@ -13,9 +13,7 @@ COMMENT= Linear Programming Solver
LICENSE= EPL
-BROKEN_powerpc64= fails to compile: CoinSignal.hpp: ISO C++ forbids declaration of '__decltype' with no type
-
-USES= blaslapack fortran libtool tar:tgz pathfix
+USES= blaslapack compiler:c++11-lang fortran libtool pathfix tar:tgz
CXXFLAGS+= -ffast-math
GNU_CONFIGURE= yes
diff --git a/math/clrng/Makefile b/math/clrng/Makefile
index fcfddc0d909b..04409fd4e18c 100644
--- a/math/clrng/Makefile
+++ b/math/clrng/Makefile
@@ -12,20 +12,19 @@ COMMENT= Library for uniform random number generation in OpenCL
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
+ONLY_FOR_ARCHS_REASON= this code has only been tested on x86 and powerpc platforms
+
BUILD_DEPENDS= opencl>=0:devel/opencl
LIB_DEPENDS= libOpenCL.so:devel/ocl-icd
RUN_DEPENDS= opencl>=0:devel/opencl
-ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
-ONLY_FOR_ARCHS_REASON= this code has only been tested on x86 and powerpc platforms
-BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option -std=c11
-
USE_GITHUB= yes
GH_ACCOUNT= clMathLibraries
GH_PROJECT= clRNG
+USES= cmake compiler:c++11-lang
USE_LDCONFIG= yes
-USES= cmake
CMAKE_ARGS+= -DBUILD_CLIENT=OFF \
-DBUILD_TEST=OFF \
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index fd20181d33b7..c2bfd1a968f5 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -15,7 +15,7 @@ LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
CONFLICTS_INSTALL?= gnuplot-lite-[0-9]*
-USES+= groff iconv pkgconfig readline
+USES+= compiler:c++11-lang groff iconv pkgconfig readline
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS+=--with-readline=gnu \
diff --git a/multimedia/libvdpau-va-gl/Makefile b/multimedia/libvdpau-va-gl/Makefile
index 0c8181a61276..d2a06b9299a2 100644
--- a/multimedia/libvdpau-va-gl/Makefile
+++ b/multimedia/libvdpau-va-gl/Makefile
@@ -2,8 +2,8 @@
PORTNAME= libvdpau-va-gl
PORTVERSION= 0.4.2
-PORTREVISION= 2
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= multimedia
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -15,15 +15,14 @@ COMMENT= VDPAU driver with OpenGL/VAAPI backend
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libva-x11.so:multimedia/libva
-
BROKEN_armv6= fails to configure: CMake Error: Check for working CXX compiler: /nxb-bin/usr/bin/c++ -- broken
-BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
+
+LIB_DEPENDS= libva-x11.so:multimedia/libva
USE_GITHUB= yes
GH_ACCOUNT= i-rinat
-USES= cmake pkgconfig
+USES= cmake compiler:c++11-lang pkgconfig
USE_XORG= x11
USE_GL= gl
LDFLAGS+= -Wl,--as-needed # Xext, ICE, SM
diff --git a/print/pdfcube/Makefile b/print/pdfcube/Makefile
index 2c5d385c0340..c30a13f99dc0 100644
--- a/print/pdfcube/Makefile
+++ b/print/pdfcube/Makefile
@@ -10,13 +10,11 @@ MASTER_SITES= http://code.100allora.it/releases/pdfcube/
MAINTAINER= lwhsu@FreeBSD.org
COMMENT= OpenGL presentation viewer on a spinning cube
-BROKEN_powerpc64= fails to configure: checking for exit in -lboost_program_options... no
-
LIB_DEPENDS= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
libpoppler-glib.so:graphics/poppler-glib \
libboost_program_options.so:devel/boost-libs
-USES= pkgconfig
+USES= compiler:c++11-lang pkgconfig
USE_GL= glut
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${LOCALBASE}/lib --includedir=${LOCALBASE}/include
diff --git a/science/bddsolve/Makefile b/science/bddsolve/Makefile
index 92f9b99ba8d0..441ca5cf3a77 100644
--- a/science/bddsolve/Makefile
+++ b/science/bddsolve/Makefile
@@ -12,12 +12,11 @@ MAINTAINER= ed@FreeBSD.org
COMMENT= BDD-based satisfiability and reachability solver
BROKEN_powerpc= fails to compile due to running out of virtual memory
-BROKEN_powerpc64= fails to build: undefined reference to boost::program_options::options_description::options_description
LIB_DEPENDS+= libbdd.so:science/buddy \
libboost_program_options.so:devel/boost-libs
-USES= zip
+USES= compiler:c++11-lang zip
NO_WRKSUBDIR= yes
CFLAGS+= -I${LOCALBASE}/include -I${WRKSRC}/include
LDFLAGS+= -L${LOCALBASE}/lib -lbdd -lboost_program_options
diff --git a/textproc/multimarkdown/Makefile b/textproc/multimarkdown/Makefile
index 1a25578d0291..d887ae47b1de 100644
--- a/textproc/multimarkdown/Makefile
+++ b/textproc/multimarkdown/Makefile
@@ -13,11 +13,9 @@ LICENSE= BSD3CLAUSE MIT GPLv2+ ZLIB
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BROKEN_powerpc64= fails to compile: Sources/libMultiMarkdown/file.h:116: redefinition of typedef 'DString'
-
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= cmake localbase:ldflags
+USES= cmake compiler:c11 localbase:ldflags
USE_GITHUB= yes
GH_ACCOUNT= fletcher
GH_PROJECT= MultiMarkdown-6
diff --git a/textproc/regex2dfa/Makefile b/textproc/regex2dfa/Makefile
index f1619e72c893..b9d823a24603 100644
--- a/textproc/regex2dfa/Makefile
+++ b/textproc/regex2dfa/Makefile
@@ -10,7 +10,7 @@ COMMENT= Command-line utility that converts regular expressions to DFA
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake libtool
+USES= compiler:c++11-lang gmake libtool
USE_GITHUB= yes
GH_ACCOUNT= kpdyer
diff --git a/textproc/tinyxml2/Makefile b/textproc/tinyxml2/Makefile
index 5db571630fe5..8f5896a204c3 100644
--- a/textproc/tinyxml2/Makefile
+++ b/textproc/tinyxml2/Makefile
@@ -15,8 +15,8 @@ OPTIONS_DEFINE= EXAMPLES
CMAKE_OFF= BUILD_TESTS
CMAKE_ON= BUILD_SHARED_LIBS BUILD_STATIC_LIBS
+USES= cmake compiler:c++11-lang dos2unix pathfix
USE_LDCONFIG= yes
-USES= cmake dos2unix pathfix
PLIST_SUB= PORTVERSION=${PORTVERSION}
PORTEXAMPLES= *
diff --git a/www/logtools/Makefile b/www/logtools/Makefile
index 1363fa19ba2a..6f44dcf044c1 100644
--- a/www/logtools/Makefile
+++ b/www/logtools/Makefile
@@ -11,11 +11,7 @@ COMMENT= Useful tools to deal with CLF files (Common Log File format)
LICENSE= GPLv2
-BROKEN_mips= fails to compile: clfmerge.cpp: error: unordered_map: No such file or directory
-BROKEN_mips64= fails to compile: clfmerge.cpp: error: unordered_map: No such file or directory
-BROKEN_powerpc64= fails to compile: clfmerge.cpp: error: unordered_map: No such file or directory
-
-USES= tar:tgz
+USES= compiler:c++11-lang tar:tgz
GNU_CONFIGURE= yes
post-patch:
diff --git a/www/xapian-omega/Makefile b/www/xapian-omega/Makefile
index 27dc75c2b251..03fc37d87c8a 100644
--- a/www/xapian-omega/Makefile
+++ b/www/xapian-omega/Makefile
@@ -29,8 +29,8 @@ CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR}
CONFIGURE_ENV= PCRE_CONFIG=${LOCALBASE}/bin/pcre-config \
XAPIAN_CONFIG=${LOCALBASE}/bin/xapian-config
GNU_CONFIGURE= yes
+USES= compiler:c++11-lang libtool localbase perl5 shebangfix tar:xz
USE_LDCONFIG= yes
-USES= libtool localbase perl5 shebangfix tar:xz
SHEBANG_FILES= dbi2omega htdig2omega mbox2omega