aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/snoopy/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/security/snoopy/Makefile b/security/snoopy/Makefile
index adec1e4b8044..12d7630c0e90 100644
--- a/security/snoopy/Makefile
+++ b/security/snoopy/Makefile
@@ -15,6 +15,11 @@ COMMENT= An execve() wrapper and logger
PLIST_FILES= lib/snoopy.so bin/detect
PORTDOCS= README
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/README
@@ -26,4 +31,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>