aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/relx/Makefile6
-rw-r--r--devel/relx/distinfo10
-rw-r--r--devel/relx/pkg-plist5
3 files changed, 13 insertions, 8 deletions
diff --git a/devel/relx/Makefile b/devel/relx/Makefile
index 5c68969f0bcc..a05b1940d51a 100644
--- a/devel/relx/Makefile
+++ b/devel/relx/Makefile
@@ -1,15 +1,15 @@
# $FreeBSD$
PORTNAME= relx
-PORTVERSION= 3.21.1
+PORTVERSION= 3.22.0
DISTVERSIONPREFIX= v
CATEGORIES= devel
MASTER_SITES+= LOCAL/olgeni:deps \
http://olgeni.olgeni.com/~olgeni/distfiles/:deps \
https://s3.amazonaws.com/s3.hex.pm/tarballs/:hex
-DISTFILES= relx-cache-12.tar.gz:deps
+DISTFILES= relx-cache-13${EXTRACT_SUFX}:deps
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX} \
- relx-cache-12.tar.gz
+ relx-cache-13${EXTRACT_SUFX}
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Sane, simple release creation for Erlang
diff --git a/devel/relx/distinfo b/devel/relx/distinfo
index 9f89e8f2e2aa..9c8bbad62bc6 100644
--- a/devel/relx/distinfo
+++ b/devel/relx/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1476474109
-SHA256 (relx-cache-12.tar.gz) = fcb88a0ac84c6175ebb0d2d725c22c74bcc59db5abf182c87d5382be7bfa90e9
-SIZE (relx-cache-12.tar.gz) = 876564
+TIMESTAMP = 1481373678
+SHA256 (relx-cache-13.tar.gz) = 82e76bd84fee5f53902185bc5f32ceaad0dec7f95fe59450a428602250d178a3
+SIZE (relx-cache-13.tar.gz) = 1381975
SHA256 (bbmustache-1.0.4.tar) = 03b0d47db66e86df993896dce7578d7e4aae5f84636809b45fa8a3e34ee59b12
SIZE (bbmustache-1.0.4.tar) = 20480
SHA256 (cf-0.2.1.tar) = baee9aa7ec2dfa3cb4486b67211177caa293f876780f0b313b45718edef6a0a5
@@ -11,5 +11,5 @@ SHA256 (getopt-0.8.2.tar) = 736e6db3679fbbad46373efb96b69509f8e420281635e9d92989
SIZE (getopt-0.8.2.tar) = 20480
SHA256 (providers-1.6.0.tar) = 0f6876529a613d34224de8c61d3660388eb981142360f2699486d8536050ce2f
SIZE (providers-1.6.0.tar) = 20480
-SHA256 (erlware-relx-v3.21.1_GH0.tar.gz) = f913bdcc1e8818f5cc43bbc8b28823d4e92e1590e72612fcce5c3816553b1941
-SIZE (erlware-relx-v3.21.1_GH0.tar.gz) = 97958
+SHA256 (erlware-relx-v3.22.0_GH0.tar.gz) = b789dcbb5bbb0d2a535874c45e81e24ced2ff5586a04873d5eb8368c7c6a177f
+SIZE (erlware-relx-v3.22.0_GH0.tar.gz) = 111605
diff --git a/devel/relx/pkg-plist b/devel/relx/pkg-plist
index dd2b3d90ada5..eb21958a5eb7 100644
--- a/devel/relx/pkg-plist
+++ b/devel/relx/pkg-plist
@@ -20,10 +20,14 @@ lib/erlang/lib/relx-%%VERSION%%/ebin/rlx_prv_relup.beam
lib/erlang/lib/relx-%%VERSION%%/ebin/rlx_rel_discovery.beam
lib/erlang/lib/relx-%%VERSION%%/ebin/rlx_release.beam
lib/erlang/lib/relx-%%VERSION%%/ebin/rlx_state.beam
+lib/erlang/lib/relx-%%VERSION%%/ebin/rlx_topo.beam
lib/erlang/lib/relx-%%VERSION%%/ebin/rlx_util.beam
lib/erlang/lib/relx-%%VERSION%%/include/relx.hrl
lib/erlang/lib/relx-%%VERSION%%/priv/templates/bin
lib/erlang/lib/relx-%%VERSION%%/priv/templates/bin_windows
+lib/erlang/lib/relx-%%VERSION%%/priv/templates/builtin_hook_pid
+lib/erlang/lib/relx-%%VERSION%%/priv/templates/builtin_hook_wait_for_process
+lib/erlang/lib/relx-%%VERSION%%/priv/templates/builtin_hook_wait_for_vm_start
lib/erlang/lib/relx-%%VERSION%%/priv/templates/erl_ini
lib/erlang/lib/relx-%%VERSION%%/priv/templates/erl_script
lib/erlang/lib/relx-%%VERSION%%/priv/templates/extended_bin
@@ -54,6 +58,7 @@ lib/erlang/lib/relx-%%VERSION%%/src/rlx_prv_relup.erl
lib/erlang/lib/relx-%%VERSION%%/src/rlx_rel_discovery.erl
lib/erlang/lib/relx-%%VERSION%%/src/rlx_release.erl
lib/erlang/lib/relx-%%VERSION%%/src/rlx_state.erl
+lib/erlang/lib/relx-%%VERSION%%/src/rlx_topo.erl
lib/erlang/lib/relx-%%VERSION%%/src/rlx_util.erl
%%PORTDOCS%%%%DOCSDIR%%/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/relx.config