aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/p5-Algorithm-Accounting/Makefile15
-rw-r--r--devel/p5-Algorithm-Accounting/distinfo4
-rw-r--r--devel/p5-Algorithm-Accounting/pkg-plist9
3 files changed, 20 insertions, 8 deletions
diff --git a/devel/p5-Algorithm-Accounting/Makefile b/devel/p5-Algorithm-Accounting/Makefile
index 50726f6dc9e6..7ec95b5de38d 100644
--- a/devel/p5-Algorithm-Accounting/Makefile
+++ b/devel/p5-Algorithm-Accounting/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= Algorithm-Accounting
-PORTVERSION= 0.05
+PORTVERSION= 0.08
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= ../../authors/id/G/GU/GOD
+MASTER_SITE_SUBDIR= ../../authors/id/G/GU/GUGOD
PKGNAMEPREFIX= p5-
MAINTAINER= ychsiao@ychsiao.org
@@ -21,13 +21,18 @@ BUILD_DEPENDS= ${SITE_PERL}/Spiffy.pm:${PORTSDIR}/devel/p5-Spiffy \
${SITE_PERL}/Array/Compare.pm:${PORTSDIR}/misc/p5-Array-Compare \
${SITE_PERL}/Array/Iterator/Reusable.pm:${PORTSDIR}/devel/p5-Array-Iterator \
${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone \
+ ${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
+ ${SITE_PERL}/Imager/Graph/Pie.pm:${PORTSDIR}/graphics/p5-Imager-Graph \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS= ${BUILD_DEPENDS}
-BROKEN= Unfetchable
-
PERL_CONFIGURE= yes
-MAN3= Algorithm::Accounting.3
+MAN3= Algorithm::Accounting.3 \
+ Algorithm::Accounting::Report.3 \
+ Algorithm::Accounting::Report::Imager.3 \
+ Algorithm::Accounting::Report::GDGraph.3 \
+ Algorithm::Accounting::Report::Text.3
.include <bsd.port.mk>
diff --git a/devel/p5-Algorithm-Accounting/distinfo b/devel/p5-Algorithm-Accounting/distinfo
index dba46583862e..1bbf016fa923 100644
--- a/devel/p5-Algorithm-Accounting/distinfo
+++ b/devel/p5-Algorithm-Accounting/distinfo
@@ -1,2 +1,2 @@
-MD5 (Algorithm-Accounting-0.05.tar.gz) = f33ab7b352fcfd491346befffe5b8556
-SIZE (Algorithm-Accounting-0.05.tar.gz) = 10576
+MD5 (Algorithm-Accounting-0.08.tar.gz) = 8e2f24e8ac41760c904c56bc6864c989
+SIZE (Algorithm-Accounting-0.08.tar.gz) = 11259
diff --git a/devel/p5-Algorithm-Accounting/pkg-plist b/devel/p5-Algorithm-Accounting/pkg-plist
index d9c6460ff8e3..940212338bf8 100644
--- a/devel/p5-Algorithm-Accounting/pkg-plist
+++ b/devel/p5-Algorithm-Accounting/pkg-plist
@@ -1,5 +1,12 @@
%%SITE_PERL%%/Algorithm/Accounting.pm
+%%SITE_PERL%%/Algorithm/Accounting/Report.pm
+%%SITE_PERL%%/Algorithm/Accounting/Report/Imager.pm
+%%SITE_PERL%%/Algorithm/Accounting/Report/Text.pm
+%%SITE_PERL%%/Algorithm/Accounting/Report/GDGraph.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Accounting/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Accounting
-@unexec rmdir %D/%%SITE_PERL%%/Algorithm/Accounting 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Accounting 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Algorithm/Accounting/Report
+@unexec rmdir %D/%%SITE_PERL%%/Algorithm/Accounting 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Algorithm 2>/dev/null || true