aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--converters/mule-ucs/Makefile2
-rw-r--r--editors/bitmap/Makefile8
2 files changed, 7 insertions, 3 deletions
diff --git a/converters/mule-ucs/Makefile b/converters/mule-ucs/Makefile
index 92ebe1ecbede..bd074c4f9545 100644
--- a/converters/mule-ucs/Makefile
+++ b/converters/mule-ucs/Makefile
@@ -25,7 +25,7 @@ PORTCLASS?= master
.if (${PORTCLASS} == "master")
USE_EMACS= yes
-EMACS_PORT_NAME= emacs21
+EMACS_PORT_NAME?= emacs21
.endif
MULEUCS_DESTDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/mule-ucs
diff --git a/editors/bitmap/Makefile b/editors/bitmap/Makefile
index d65acf2706cf..a39243142827 100644
--- a/editors/bitmap/Makefile
+++ b/editors/bitmap/Makefile
@@ -41,8 +41,8 @@ PORTCLASS?= master
# Setup EMACS_PORT_NAME variable.
.if (${PORTCLASS} == "master")
USE_EMACS= yes
-EMACS_PORT_NAME= emacs21
-DEPPORT_SUFFIX=
+EMACS_PORT_NAME?= emacs21
+DEPPORT_SUFFIX=
.else
DEPPORT_SUFFIX= -${EMACS_PORT_NAME}
.endif
@@ -67,6 +67,10 @@ MAKE_ARGS= PREFIX="${LOCALBASE}" \
# depends on apel
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel${DEPPORT_SUFFIX}
RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel${DEPPORT_SUFFIX}
+.if (${EMACS_PORT_NAME} == "emacs21") || (${EMACS_PORT_NAME} == "emacs22")
+DESCR= ${PKGDIR}/pkg-descr.emacs21
+PLIST= ${PKGDIR}/pkg-plist.emacs21
+.endif
.else
.BEGIN:
@${ECHO} "Error: Bad port."