aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/swftools/Makefile28
-rw-r--r--graphics/swftools/distinfo4
-rw-r--r--graphics/swftools/files/patch-Makefile.in17
-rw-r--r--graphics/swftools/files/patch-configure97
-rw-r--r--graphics/swftools/files/patch-lib::modules::swffont.c12
-rw-r--r--graphics/swftools/files/patch-lib:modules:swffont.c11
-rw-r--r--graphics/swftools/pkg-plist1
7 files changed, 115 insertions, 55 deletions
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index 9babea487368..b7ec7c261ea5 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -7,38 +7,36 @@
#
PORTNAME= swftools
-PORTVERSION= 0.6.0
+PORTVERSION= 0.6.1
CATEGORIES= graphics
MASTER_SITES= http://www.quiss.org/swftools/
MAINTAINER= ports@FreeBSD.org
COMMENT= SWF manipulation and generation utilities
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PIL/_imaging.so:${PORTSDIR}/graphics/py-imaging
-LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
+LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
+ t1.5:${PORTSDIR}/devel/t1lib \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- freetype.9:${PORTSDIR}/print/freetype2 \
- aviplay.0:${PORTSDIR}/multimedia/avifile
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PIL/_imaging.so:${PORTSDIR}/graphics/py-imaging
+ freetype.9:${PORTSDIR}/print/freetype2
+
+FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
USE_REINPLACE= yes
USE_BISON= yes
USE_GMAKE= yes
-USE_PYTHON= 2.2+
-FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGSS="-L${LOCALBASE}/lib" \
- FREETYPE_CONFIG=${FREETYPE_CONFIG}
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ FREETYPE_CONFIG="${FREETYPE_CONFIG}"
-MAN1= avi2swf.1 font2swf.1 jpeg2swf.1 pdf2swf.1 png2swf.1 swfbbox.1 swfc.1 \
+MAN1= font2swf.1 jpeg2swf.1 pdf2swf.1 png2swf.1 swfbbox.1 swfc.1 \
swfcombine.1 swfdump.1 swfextract.1 swfstrings.1 wav2swf.1
post-patch:
- @${REINPLACE_CMD} -e 's| -O | |g' \
- -e 's@/usr/lib/python@${LOCALBASE}/lib/python@' \
- -e 's@/usr/include/python@${LOCALBASE}/include/python@' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's| -O | |g ; \
+ s|/usr/local/include|${LOCALBASE}/include|g ; \
+ s|/usr/local/lib|${LOCALBASE}/lib|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|;make|;\$$\(MAKE\)|g' ${WRKSRC}/lib/Makefile.in
.include <bsd.port.mk>
diff --git a/graphics/swftools/distinfo b/graphics/swftools/distinfo
index 4407ae1d1c61..bd3151666265 100644
--- a/graphics/swftools/distinfo
+++ b/graphics/swftools/distinfo
@@ -1,2 +1,2 @@
-MD5 (swftools-0.6.0.tar.gz) = 39bf9fd9bc90571f296638ccca177fe3
-SIZE (swftools-0.6.0.tar.gz) = 1405412
+MD5 (swftools-0.6.1.tar.gz) = ed12cdf72deed5b67fc2dc64b9f5330a
+SIZE (swftools-0.6.1.tar.gz) = 1410115
diff --git a/graphics/swftools/files/patch-Makefile.in b/graphics/swftools/files/patch-Makefile.in
new file mode 100644
index 000000000000..565b6085aecc
--- /dev/null
+++ b/graphics/swftools/files/patch-Makefile.in
@@ -0,0 +1,17 @@
+--- Makefile.in.orig Tue Jul 13 21:32:41 2004
++++ Makefile.in Sun Aug 22 00:26:59 2004
+@@ -8,14 +8,10 @@
+ cd m4;$(MAKE) $@
+ @echo making $@ in lib...
+ cd lib;$(MAKE) $@
+- @echo making $@ in lib/python...
+- cd lib/python;$(MAKE) $@
+ @echo making $@ in src...
+ cd src;$(MAKE) $@
+ @echo making $@ in pdf2swf...
+ cd pdf2swf;$(MAKE) $@
+- @echo making $@ in avi2swf...
+- cd avi2swf;$(MAKE) $@
+ @echo making $@ in swfs...
+ cd swfs;$(MAKE) $@
+ @$(MAKE) $@-local
diff --git a/graphics/swftools/files/patch-configure b/graphics/swftools/files/patch-configure
index ab8a07327246..7efa27f1f142 100644
--- a/graphics/swftools/files/patch-configure
+++ b/graphics/swftools/files/patch-configure
@@ -1,31 +1,76 @@
---- configure.orig Mon Aug 16 11:29:43 2004
-+++ configure Mon Aug 16 11:30:57 2004
-@@ -10269,7 +10269,8 @@
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
- $ac_includes_default
--#include <$ac_header>
-+#include <ft2build.h>
-+#include FT_FREETYPE_H
- _ACEOF
- rm -f conftest.$ac_objext
- if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
-@@ -10313,7 +10314,8 @@
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
--#include <$ac_header>
-+#include <ft2build.h>
-+#include FT_FREETYPE_H
- _ACEOF
- if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
- (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
-@@ -10413,6 +10415,8 @@
+--- configure.orig Sat Aug 21 03:34:59 2004
++++ configure Sat Aug 21 12:46:50 2004
+@@ -10247,7 +10247,7 @@
+ fi
+
+
+-for ac_header in freetype/freetype.h
++for ac_header in ft2build.h
+ do
+ as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ if eval "test \"\${$as_ac_Header+set}\" = set"; then
+@@ -10413,45 +10413,26 @@
echo $ECHO_N "checking whether we can compile the freetype test program... $ECHO_C" >&6
cat > conftest.c << EOF
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftsnames.h>
+-#include <freetype/ttnameid.h>
+-#include <freetype/ftoutln.h>
+-
+-int main()
+-{
+- FT_Library ftlibrary;
+- FT_Face face;
+- FT_Error error;
+- FT_ULong charcode;
+- FT_UInt gindex;
+- FT_Glyph glyph;
+- FT_BBox bbox;
+- FT_Matrix matrix;
+- FT_UInt i;
+- char* name = 0;
+- char italic, bold;
+-
+- FT_Init_FreeType(&ftlibrary);
+- FT_New_Face(ftlibrary, "filename", 0, &face);
+- i = face->num_glyphs - 1;
+- italic = face->style_flags&FT_STYLE_FLAG_ITALIC;
+- bold = face->style_flags&FT_STYLE_FLAG_BOLD;
+- FT_Get_Postscript_Name(face);
+- FT_Get_Char_Index(face, 33);
+- FT_Get_First_Char(face, &i);
+- FT_Get_Next_Char(face, 33, &i);
+- if(FT_HAS_GLYPH_NAMES(face)) {
+- FT_Get_Glyph_Name(face, 33, name, 127);
+- }
+- FT_Load_Glyph(face, 33, FT_LOAD_NO_BITMAP|FT_LOAD_NO_SCALE);
+- FT_Get_Glyph(face->glyph, &glyph);
+- FT_Glyph_Get_CBox(glyph, ft_glyph_bbox_unscaled, &bbox);
+- FT_Done_Glyph(glyph);
+- FT_Done_Face(face);
+- FT_Done_FreeType(ftlibrary);
+#include <ft2build.h>
+#include FT_FREETYPE_H
- #include <freetype/freetype.h>
- #include <freetype/ftglyph.h>
- #include <freetype/ftsnames.h>
++#include <stdio.h>
++#include <stdlib.h>
++
++int
++main()
++{
++ FT_Library library;
++ FT_Error error;
++
++ error = FT_Init_FreeType(&library);
++
++ if (error)
++ return 1;
++ else
++ {
++ FT_Done_FreeType(library);
+ return 0;
++ }
+ }
+ EOF
+
diff --git a/graphics/swftools/files/patch-lib::modules::swffont.c b/graphics/swftools/files/patch-lib::modules::swffont.c
new file mode 100644
index 000000000000..52c486195be9
--- /dev/null
+++ b/graphics/swftools/files/patch-lib::modules::swffont.c
@@ -0,0 +1,12 @@
+--- lib/modules/swffont.c.orig Sat Aug 14 16:19:02 2004
++++ lib/modules/swffont.c Sun Aug 15 02:16:02 2004
+@@ -32,7 +32,8 @@
+
+ #ifdef HAVE_FREETYPE
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include <freetype/ftglyph.h>
+ #include <freetype/ftsizes.h>
+ #include <freetype/ftsnames.h>
diff --git a/graphics/swftools/files/patch-lib:modules:swffont.c b/graphics/swftools/files/patch-lib:modules:swffont.c
deleted file mode 100644
index 3d511a15c77a..000000000000
--- a/graphics/swftools/files/patch-lib:modules:swffont.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/modules/swffont.c.orig Mon Aug 16 11:32:50 2004
-+++ lib/modules/swffont.c Mon Aug 16 11:33:05 2004
-@@ -32,6 +32,8 @@
-
- #ifdef HAVE_FREETYPE
-
-+#include <ft2build.h>
-+#include FT_FREETYPE_H
- #include <freetype/freetype.h>
- #include <freetype/ftglyph.h>
- #include <freetype/ftsizes.h>
diff --git a/graphics/swftools/pkg-plist b/graphics/swftools/pkg-plist
index 53a4a3fc6fe1..dfe91941a795 100644
--- a/graphics/swftools/pkg-plist
+++ b/graphics/swftools/pkg-plist
@@ -1,4 +1,3 @@
-bin/avi2swf
bin/font2swf
bin/jpeg2swf
bin/pdf2swf