aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MOVED4
-rw-r--r--lang/Makefile2
-rw-r--r--lang/dragonegg46-33/Makefile77
-rw-r--r--lang/dragonegg46-33/distinfo2
-rw-r--r--lang/dragonegg46-33/files/hello.c9
-rw-r--r--lang/dragonegg46-33/files/patch-README82
-rw-r--r--lang/dragonegg46-33/pkg-descr8
-rw-r--r--lang/dragonegg47-33/Makefile6
-rw-r--r--mail/Makefile1
-rw-r--r--mail/getlive/Makefile37
-rw-r--r--mail/getlive/distinfo2
-rw-r--r--mail/getlive/files/getlive.conf.sample98
-rw-r--r--mail/getlive/pkg-descr5
-rw-r--r--print/Makefile1
-rw-r--r--print/ifxetex/Makefile46
-rw-r--r--print/ifxetex/distinfo2
-rw-r--r--print/ifxetex/pkg-descr8
17 files changed, 4 insertions, 386 deletions
diff --git a/MOVED b/MOVED
index 88bcde384806..cc950c4e612f 100644
--- a/MOVED
+++ b/MOVED
@@ -6362,3 +6362,7 @@ misc/freecode-submit||2014-07-31|Has expired: This software is obsolete. Freecod
mail/exim-doc-info||2014-07-31|Has expired: yes
misc/gman||2014-07-31|Has expired: Depends on expiring ghostview
print/ghostview|print/gv|2014-07-31|Has expired: project dead nearly a decade ago; use print/gv instead
+mail/getlive||2014-08-01|Has expired: GetLive project has been declared dead due to MS account conversion
+print/ifxetex||2014-08-01|Has expired: Very outdated and fully contained in texlive-texmf
+lang/dragonegg46-33||2014-08-01|Has expired: Dead upstream, impractical to build on 10 and later
+lang/dragonegg47-33||2014-08-01|Has expired: Dead upstream, impractical to build on 10 and later
diff --git a/lang/Makefile b/lang/Makefile
index f358a48a91b7..8041c5a93e65 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -49,8 +49,6 @@
SUBDIR += dlv
SUBDIR += dmd1
SUBDIR += dmd2
- SUBDIR += dragonegg46-33
- SUBDIR += dragonegg47-33
SUBDIR += ecl
SUBDIR += elan
SUBDIR += elixir
diff --git a/lang/dragonegg46-33/Makefile b/lang/dragonegg46-33/Makefile
deleted file mode 100644
index dc1324c42b28..000000000000
--- a/lang/dragonegg46-33/Makefile
+++ /dev/null
@@ -1,77 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= dragonegg
-PORTVERSION= 3.3
-PORTREVISION= 4
-CATEGORIES= lang devel
-MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
-PKGNAMESUFFIX= ${USE_GCC:S/.//g}-${LLVM_SUFFIX}
-DISTNAME= dragonegg-${PORTVERSION}.src
-
-MAINTAINER= brooks@FreeBSD.org
-COMMENT= GCC plugin to use the LLVM backend
-
-CONFLICTS= dragonegg46-devel-3.3*
-
-DEPRECATED= Dead upstream, impractical to build on 10 and later
-EXPIRATION_DATE= 2014-08-01
-
-BUILD_DEPENDS+= llvm-config${LLVM_SUFFIX}:${PORTSDIR}/devel/llvm${LLVM_SUFFIX}
-RUN_DEPENDS+= llvm-config${LLVM_SUFFIX}:${PORTSDIR}/devel/llvm${LLVM_SUFFIX}
-
-LLVM_SUFFIX= ${PORTVERSION:S/.//g}
-
-OPTIONS_DEFINE= DOCS
-
-USES= compiler:features gmake
-USE_GCC?= 4.6
-USE_LDCONFIG= yes
-DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
-UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
-
-DRAGONEGG_RELEASE= ${PORTVERSION:C/\.r[0-9]*//}
-DRAGONEGG_SO= dragonegg-${DRAGONEGG_RELEASE}.so
-DRAGONEGG_PATH= ${GCC_LIBDIR}/${DRAGONEGG_SO}
-GCC_LIBDIR= lib/${CC}
-
-ALL_TARGET=
-MAKE_ARGS= GCC=${LOCALBASE}/bin/${CC} LLVM_CONFIG=llvm-config${LLVM_SUFFIX}
-
-PLIST_FILES= ${GCC_LIBDIR}/${DRAGONEGG_SO}
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= README
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${COMPILER_FEATURES:Mlibc++}
-IGNORE= "Dragonegg can't work if LLVM was built with libc++"
-.endif
-
-post-patch:
- ${REINPLACE_CMD} -e 's/%%CC%%/${CC}/' \
- -e 's#%%PLUGINPATH%%#${LOCALBASE}/${DRAGONEGG_PATH}#' \
- -e 's/arg-dragonegg/arg-dragonegg-${DRAGONEGG_RELEASE}/' \
- ${WRKSRC}/README
-
-do-install:
- ${MKDIR} ${STAGEDIR}${LOCALBASE}/${GCC_LIBDIR}
- ${INSTALL_LIB} ${WRKSRC}/dragonegg.so \
- ${STAGEDIR}${LOCALBASE}/${GCC_LIBDIR}/${DRAGONEGG_SO}
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-.endif
-
-test:
- ${CC} -fplugin=${PREFIX}/${DRAGONEGG_PATH} ${FILESDIR}/hello.c \
- -o ${WRKDIR}/hello
- if [ "`${WRKDIR}/hello`" != "hello" ]; then \
- ${ECHO_CMD} wrong answer from ${WRKDIR}/test/hello ;\
- ${FALSE} ;\
- fi
-
-.include <bsd.port.post.mk>
diff --git a/lang/dragonegg46-33/distinfo b/lang/dragonegg46-33/distinfo
deleted file mode 100644
index 89392c67d0d7..000000000000
--- a/lang/dragonegg46-33/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (dragonegg-3.3.src.tar.gz) = 3153a827e9a3cef4212d0240ffc5ab7a2ce92dcf1283520d1eb0c3f295f4d9cd
-SIZE (dragonegg-3.3.src.tar.gz) = 457196
diff --git a/lang/dragonegg46-33/files/hello.c b/lang/dragonegg46-33/files/hello.c
deleted file mode 100644
index ed9e8e960a10..000000000000
--- a/lang/dragonegg46-33/files/hello.c
+++ /dev/null
@@ -1,9 +0,0 @@
-/* $FreeBSD$ */
-#include <stdio.h>
-
-int
-main(void)
-{
- printf("hello\n");
- return 0;
-}
diff --git a/lang/dragonegg46-33/files/patch-README b/lang/dragonegg46-33/files/patch-README
deleted file mode 100644
index dcffeeb1d7a4..000000000000
--- a/lang/dragonegg46-33/files/patch-README
+++ /dev/null
@@ -1,82 +0,0 @@
-
-$FreeBSD$
-
---- README.orig
-+++ README
-@@ -1,74 +1,9 @@
- ----------------------
--- BUILD INSTRUCTIONS -
------------------------
--
--Prerequisites
---------------
--
--The dragonegg plugin works with gcc 4.5, 4.6, 4.7 or 4.8, so you will need to
--have one of these installed. Many linux distributions ship one or both of them,
--perhaps as an addon package; binaries can be downloaded for most platforms.
--Otherwise you can always build gcc yourself. Plugin support (--enable-plugin)
--needs to be enabled in gcc, but since it is enabled by default on most platforms
--you usually won't need to do this explicitly.
--
--Step 0: Build and install llvm
--------------------------------
--
--I'm assuming anyone reading this knows how to build and install llvm. The
--version of llvm must match the version of the plugin, so if you are building
--dragonegg-3.0 then you should use llvm-3.0, while if you are building the
--development version of dragonegg then use the development version of llvm.
--
--
--Step 1: Build the plugin
--------------------------
--
--Build the plugin like this:
-- GCC=PATH_TO_INSTALLED_GCC make
--This command should be executed in the directory containing this README.
--
--The plugin needs to know about the version of gcc it will be loaded into, which
--is why you need to specify your version of gcc 4.5/4.6 via the GCC variable like
--this. For example, if the version of gcc you want to load the plugin into is
--/usr/local/gcc-4.6/bin/gcc, then you should do
-- GCC=/usr/local/gcc-4.6/bin/gcc make
--If you don't set the GCC variable then by default "gcc" is used, so you
--can just do
-- make
--if you plan to use the plugin with whatever version of gcc is in your path.
--
--The plugin makes use of various gcc headers that are usually shipped with gcc.
--However some linux distributions, for example debian and ubuntu, have split the
--headers out of gcc into a separate package. So if you get errors along the
--lines of "config.h not found", check whether gcc headers like "config.h" and
--"tree.h" are installed. On debian the package containing headers is called
--gcc-4.5-plugin-dev or gcc-4.6-plugin-dev.
--
--The plugin is compiled using the system compiler, and not with the gcc specified
--in the GCC variable (which wouldn't work if it is a cross compiler). If you
--want to also compile the plugin with your copy of gcc 4.5/4.6, you can do:
-- CXX=PATH_TO_INSTALLED_GCC GCC=PATH_TO_INSTALLED_GCC make
--
--The build system runs the "llvm-config" program (which should be in your path if
--you installed llvm properly in step 0) to find out about the copy of LLVM you
--installed, so there is no need to tell the build system explicitly about LLVM.
--If llvm-config is not in your path then you can specify where to find it using
--the LLVM_CONFIG variable.
--
--The end result of the build is a shared library, dragonegg.so.
--
--If you want the dragonegg plugin to be able to load LLVM plugins then pass
--ENABLE_LLVM_PLUGINS=1 to make.
--
--
------------------------
- - USAGE INSTRUCTIONS -
- ----------------------
-
--Run gcc as usual, but pass -fplugin=./dragonegg.so as an extra command line
--argument. Make sure you use the gcc you built dragonegg against (see step 1)!
--
-+Run %CC% as usual, but pass -fplugin=%%PLUGINPATH%%
-+as an extra command line argument.
-
- ------------------
- - USEFUL OPTIONS -
diff --git a/lang/dragonegg46-33/pkg-descr b/lang/dragonegg46-33/pkg-descr
deleted file mode 100644
index 9cf50ed96d40..000000000000
--- a/lang/dragonegg46-33/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-DragonEgg is a gcc plugin that replaces GCC's optimizers and code
-generators with those from the LLVM project. It works with gcc-4.6
-or gcc-4.7, can target the x86-32/x86-64 and ARM processor families,
-and has been successfully used on the Darwin, FreeBSD, KFreeBSD,
-Linux and OpenBSD platforms. It fully supports Ada, C, C++ and
-Fortran. It has partial support for Go, Java, Obj-C and Obj-C++.
-
-WWW: http://dragonegg.llvm.org/
diff --git a/lang/dragonegg47-33/Makefile b/lang/dragonegg47-33/Makefile
deleted file mode 100644
index 05f6db9f3238..000000000000
--- a/lang/dragonegg47-33/Makefile
+++ /dev/null
@@ -1,6 +0,0 @@
-# $FreeBSD$
-
-USE_GCC= 4.7
-MASTERDIR= ${.CURDIR}/../dragonegg46-33
-
-.include "${MASTERDIR}/Makefile"
diff --git a/mail/Makefile b/mail/Makefile
index 38f1a5ea3146..0cbfa16ee4b9 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -149,7 +149,6 @@
SUBDIR += ftrack
SUBDIR += gbuffy
SUBDIR += gensig
- SUBDIR += getlive
SUBDIR += getmail
SUBDIR += gkrellmmailwatch2
SUBDIR += gld
diff --git a/mail/getlive/Makefile b/mail/getlive/Makefile
deleted file mode 100644
index d3cf3961270c..000000000000
--- a/mail/getlive/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# Created by: ayunyan <ayunyan@gmail.com>
-# $FreeBSD$
-
-PORTNAME= getlive
-DISTVERSION= 3_0_3
-PORTREVISION= 1
-CATEGORIES= mail
-MASTER_SITES= http://tardisi.com/distfiles/ \
- http://lawrencechen.net/distfiles/
-DISTNAME= GetLive_${DISTVERSION}
-
-MAINTAINER= ayu@commun.jp
-COMMENT= Get mail from Hotmail (Live) mailboxes
-
-DEPRECATED= GetLive project has been declared dead due to MS account conversion
-EXPIRATION_DATE=2014-08-01
-
-RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- procmail:${PORTSDIR}/mail/procmail \
- p5-URI>=0:${PORTSDIR}/net/p5-URI \
- p5-WWW-Mechanize-GZip>=0:${PORTSDIR}/www/p5-WWW-Mechanize-GZip
-
-NO_BUILD= yes
-USES= perl5 shebangfix tar:tgz
-SHEBANG_FILES= GetLive.pl
-USE_PERL5= run
-
-PLIST_FILES= bin/getlive etc/getlive.conf.sample
-PORTDOCS= ChangeLog License Manual
-
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/GetLive.pl ${STAGEDIR}${PREFIX}/bin/getlive
- ${INSTALL_DATA} ${FILESDIR}/getlive.conf.sample ${STAGEDIR}${PREFIX}/etc
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>
diff --git a/mail/getlive/distinfo b/mail/getlive/distinfo
deleted file mode 100644
index 485db23961ad..000000000000
--- a/mail/getlive/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (GetLive_3_0_3.tgz) = bf2ae8c464b4c36ca65751be1b9698b1b4471348ae894cf46b57b255fa62f9c0
-SIZE (GetLive_3_0_3.tgz) = 27078
diff --git a/mail/getlive/files/getlive.conf.sample b/mail/getlive/files/getlive.conf.sample
deleted file mode 100644
index 470609b2703e..000000000000
--- a/mail/getlive/files/getlive.conf.sample
+++ /dev/null
@@ -1,98 +0,0 @@
-# UserName - YourHotmailUserName (without @something)
-#
-UserName=
-
-# Password - YourHotmailPassword (so restrict the access rights to this
-# configuration file.)
-#
-Password=
-
-# Domain - YourHotmailDomain (default 'hotmail.com', basically what's after
-# the @ in your address)
-#
-#Domain=hotmail.com
-
-# Proxy - ProxyServer if you're behind one.
-#
-#Proxy=
-
-# ProxyAuth - ProxyPassword if you're behind one with password.
-#
-#ProxyAuth=
-
-# Downloaded - SomeFileName (it keeps track of all id's of messages
-# that were fetched already)
-#
-Downloaded=
-
-# FetchOnlyUnread - Yes or No (default)
-#
-# If Yes only messages that are marked unread are fetched.
-# Downloaded and FetchOnlyUnread are mutual exclusive.
-#
-#FetchOnlyUnread=No
-
-# Processor - FilterCommand ('/usr/bin/procmail' by default).
-#
-# Any filtercommand taking the message in mbox format on its stdin
-# and doing something with it.
-#
-# *) '/bin/cat - >> FetchedMail' might be another interesting one to drop
-# directly in a mbox file.
-#
-# *) The distribution contains also SmtpForward.pl and SmtpAuthForward.pl.
-# Those can be used as 'Processor' to forward the mails to an SMTP server.
-#
-Processor=/usr/local/bin/procmail
-
-# Folder - FolderName : Folders that need to be fetched.
-#
-# This option must be repeated for each folder you want to fetch.
-# If this option is not present then all folders will be fetched.
-#
-#Folder=
-
-# MarkRead - Yes or No (default) : whether the message will be marked read
-# after being downloaded. By the way, it never
-# gets marked in any way when not downloaded
-# due to it being already in the
-# Downloaded = SomeFileName (see higher) file.
-#
-#MarkRead=No
-
-# Delete - Yes or No (default) : whether the message will be deleted after
-# being downloaded. By the way, it never gets
-# deleted in any way when not downloaded due to
-# it being already in the
-# Downloaded = SomeFileName (see higher) file.
-#
-#Delete=No
-
-# MoveToFolder - FolderName or @FileName
-#
-# FolderName is the folder to which the message must be moved after being
-# downloaded. By the way, it never gets moved in any way when not downloaded
-# due to it being already in the Downloaded = SomeFileName (see higher) file.
-#
-# If this argument takes the form @FileName then the FolderName is taken from
-# the contents of the file FileName.
-#
-# The idea is that f.i. a spamfilter can decide to what folder it must be moved.
-# That spamfilter would be part of Processor = FilterCommand (see higher) and
-# write a FolderName (for instance Junk if considered junk) to the file
-# FileName.
-#
-#MoveToFolder=
-
-# SkipTrash - Yes or No (default) : whether the message Trash folder will be
-# handled (default) or not.
-#
-#SkipTrash=No
-
-# BreakOnAlreadyDownloaded = Number
-#
-# Stop scanning a folder when detecting a seqeunce of Number messages that
-# is already downloaded. 0 means disabling this feature and is default.
-# Meant to reduce folder scanning.
-#
-#BreakOnAlreadyDownloaded=0
diff --git a/mail/getlive/pkg-descr b/mail/getlive/pkg-descr
deleted file mode 100644
index f178b79eb013..000000000000
--- a/mail/getlive/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-GetLive is a perl script that fetches mail from your Hotmail Live account.
-The mail is then presented to any filter (typically procmail) for further
-processing or dropping in a local mailbox.
-
-WWW: http://sourceforge.net/projects/getlive/
diff --git a/print/Makefile b/print/Makefile
index 412f6d7c31b4..0c31f2438196 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -111,7 +111,6 @@
SUBDIR += html2latex
SUBDIR += html2ps
SUBDIR += hyperlatex
- SUBDIR += ifxetex
SUBDIR += indexinfo
SUBDIR += it-acroread8
SUBDIR += jabref
diff --git a/print/ifxetex/Makefile b/print/ifxetex/Makefile
deleted file mode 100644
index 753ded969822..000000000000
--- a/print/ifxetex/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-# Created by: Martin Dieringer <martin.dieringer@gmx.de>
-# $FreeBSD$
-
-PORTNAME= ifxetex
-PORTVERSION= 20090124
-PORTREVISION= 4
-CATEGORIES= print
-MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
-MASTER_SITE_SUBDIR= macros/generic/
-DISTNAME= ${PORTNAME}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= The file ifxetex.sty tests whether XeTeX is being used
-
-DEPRECATED= Very outdated and fully contained in texlive-texmf
-EXPIRATION_DATE=2014-08-01
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= zip
-USE_TEX= latex
-
-PLIST= ${WRKDIR}/pkg-plist
-
-TEXMFDIR= share/texmf-local
-MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
-CLASSDIR= ${TEXMFDIR}/tex/latex/${PORTNAME}
-CLASS_FILES= ${PORTNAME}.sty
-
-NO_STAGE= yes
-do-build:
- cd ${WRKSRC} && latex ${PORTNAME}.ins
-
-pre-install:
- ${ECHO_CMD} "${CLASSDIR}/${CLASS_FILES}" > ${PLIST}
- ${ECHO_CMD} "@dirrm ${CLASSDIR}" >> ${PLIST}
- ${ECHO_CMD} "@exec ${MKTEXLSR}" >> ${PLIST}
- ${ECHO_CMD} "@unexec ${MKTEXLSR}" >> ${PLIST}
-
-do-install:
- @${MKDIR} ${PREFIX}/${CLASSDIR}
- ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
-
-post-install:
- ${MKTEXLSR}
-
-.include <bsd.port.mk>
diff --git a/print/ifxetex/distinfo b/print/ifxetex/distinfo
deleted file mode 100644
index 1cfe8a110ee3..000000000000
--- a/print/ifxetex/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ifxetex.zip) = f3461e33b522359de26b8b6396088922f26a89dc93e618f297179732e1886999
-SIZE (ifxetex.zip) = 60532
diff --git a/print/ifxetex/pkg-descr b/print/ifxetex/pkg-descr
deleted file mode 100644
index c8f2d06ae5cf..000000000000
--- a/print/ifxetex/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-This very simple package, for both Plain and LaTeX, defines
-the \ifxetex boolean for testing whether the TeX-variant
-XeTeX is being used for typesetting.
-
-Also provides the \RequireXeTeX command which throws
-an error if XeTeX is not the engine in use.
-
-WWW: http://www.ctan.org/tex-archive/macros/generic/ifxetex/