aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.ruby.mk8
-rw-r--r--archivers/ruby-zip/Makefile1
-rw-r--r--devel/rubygem-activesupport/Makefile1
-rw-r--r--devel/rubygem-activesupport4/Makefile1
-rw-r--r--devel/rubygem-enumerize/Makefile1
-rw-r--r--devel/rubygem-rdoc/Makefile1
-rw-r--r--devel/rubygem-ruby-ole/Makefile1
-rw-r--r--mail/rubygem-tmail/Makefile1
-rw-r--r--net/ruby-tcpsocketpipe/Makefile1
-rw-r--r--net/rubygem-rightaws/Makefile2
-rw-r--r--sysutils/rubygem-chef/Makefile1
-rw-r--r--textproc/ruby-rss.alt/Makefile1
-rw-r--r--textproc/ruby-xmlconfigfile/Makefile1
-rw-r--r--textproc/rubygem-nokogiri/Makefile1
-rw-r--r--textproc/rubygem-nokogiri14/Makefile1
-rw-r--r--textproc/rubygem-spreadsheet/Makefile1
-rw-r--r--www/ruby-google/Makefile1
-rw-r--r--www/ruby-wgettsv/Makefile1
-rw-r--r--www/rubygem-maruku/Makefile1
19 files changed, 0 insertions, 27 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 4a79e040b95e..8007cab44cdb 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -46,9 +46,6 @@ Ruby_Include_MAINTAINER= ruby@FreeBSD.org
# (default: setup.rb).
# USE_RUBY_RDTOOL - Says that the port uses rdtool to generate documents.
# USE_RUBY_RDOC - Says that the port uses rdoc to generate documents.
-# USE_RUBY_FEATURES - Says that the port requires some of the following
-# features for building and/or running (default: none):
-# iconv
# RUBY_REQUIRE - Set to a Ruby expression to evaluate before building
# the port. The constant "Ruby" is set to the integer
# version number of ruby, and the result of the
@@ -110,13 +107,11 @@ Ruby_Include_MAINTAINER= ruby@FreeBSD.org
# RUBY_PORT - Port path of ruby without PORTSDIR.
# RUBY_RDTOOL_PORT - Port path of rdtool without PORTSDIR.
# RUBY_RDOC_PORT - Port path of rdoc without PORTSDIR.
-# RUBY_ICONV_PORT - Port path of ruby-iconv without PORTSDIR.
#
# DEPEND_LIBRUBY - LIB_DEPENDS entry for libruby.
# DEPEND_RUBY - BUILD_DEPENDS/RUN_DEPENDS entry for ruby.
# DEPEND_RUBY_RDTOOL - BUILD_DEPENDS entry for rdtool.
# DEPEND_RUBY_RDOC - BUILD_DEPENDS entry for rdoc.
-# DEPEND_RUBY_ICONV - BUILD_DEPENDS/RUN_DEPENDS entry for ruby-iconv.
#
# RUBY_LIBDIR - Installation path for architecture independent
# libraries.
@@ -294,14 +289,11 @@ RUBY_RDOC?= ${LOCALBASE}/bin/rdoc${RUBY_VER:S/.//}
RUBY_BASE_PORT?= lang/ruby${RUBY_VER:S/.//}
RUBY_PORT?= ${RUBY_BASE_PORT}
RUBY_RDTOOL_PORT?= textproc/ruby-rdtool
-RUBY_RDOC_PORT?= textproc/ruby-rdoc
-RUBY_ICONV_PORT?= converters/ruby-iconv
# Depends
DEPEND_LIBRUBY?= lib${RUBY_NAME}.so.${RUBY_SHLIBVER}:${PORTSDIR}/${RUBY_PORT}
DEPEND_RUBY?= ${RUBY}:${PORTSDIR}/${RUBY_PORT}
DEPEND_RUBY_RDTOOL?= ${RUBY_RD2}:${PORTSDIR}/${RUBY_RDTOOL_PORT}
-DEPEND_RUBY_ICONV= ${RUBY_ARCHLIBDIR}/iconv.so:${PORTSDIR}/${RUBY_ICONV_PORT}
# Directories
RUBY_LIBDIR?= ${_RUBY_SYSLIBDIR}/ruby/${RUBY_VER}
diff --git a/archivers/ruby-zip/Makefile b/archivers/ruby-zip/Makefile
index 63bb1d02d58f..6260b3caf5f9 100644
--- a/archivers/ruby-zip/Makefile
+++ b/archivers/ruby-zip/Makefile
@@ -14,7 +14,6 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby module for reading and writing ZIP files
USE_RUBY= yes
-USE_RUBY_FEATURES= zlib
WRKSRC= ${WRKDIR}/rubyzip-${PORTVERSION}
NO_BUILD= yes
diff --git a/devel/rubygem-activesupport/Makefile b/devel/rubygem-activesupport/Makefile
index 699e785e8d8c..26cbf99e220d 100644
--- a/devel/rubygem-activesupport/Makefile
+++ b/devel/rubygem-activesupport/Makefile
@@ -15,7 +15,6 @@ RUN_DEPENDS= rubygem-i18n>=0.6.4:${PORTSDIR}/devel/rubygem-i18n \
rubygem-multi_json>=1.0:${PORTSDIR}/devel/rubygem-multi_json
USE_RUBY= yes
-USE_RUBY_FEATURES= iconv
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
diff --git a/devel/rubygem-activesupport4/Makefile b/devel/rubygem-activesupport4/Makefile
index 7ab8b62b2372..7303c9a78c10 100644
--- a/devel/rubygem-activesupport4/Makefile
+++ b/devel/rubygem-activesupport4/Makefile
@@ -20,7 +20,6 @@ RUN_DEPENDS= rubygem-i18n>=0.6.9:${PORTSDIR}/devel/rubygem-i18n \
USE_RUBY= yes
USE_RUBYGEMS= yes
-USE_RUBY_FEATURES= iconv
RUBYGEM_AUTOPLIST= yes
.include <bsd.port.mk>
diff --git a/devel/rubygem-enumerize/Makefile b/devel/rubygem-enumerize/Makefile
index 7b23c107a0e4..ed53f9ea09ec 100644
--- a/devel/rubygem-enumerize/Makefile
+++ b/devel/rubygem-enumerize/Makefile
@@ -15,6 +15,5 @@ RUN_DEPENDS= rubygem-activesupport>=3.2:${PORTSDIR}/devel/rubygem-activesupport
USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-USE_RUBY_FEATURES= iconv
.include <bsd.port.mk>
diff --git a/devel/rubygem-rdoc/Makefile b/devel/rubygem-rdoc/Makefile
index c1123cbf2822..581c09783948 100644
--- a/devel/rubygem-rdoc/Makefile
+++ b/devel/rubygem-rdoc/Makefile
@@ -16,7 +16,6 @@ RUN_DEPENDS= rubygem-json>=1.4:${PORTSDIR}/devel/rubygem-json
USE_RUBY= yes
USE_RUBYGEMS= yes
-USE_RUBY_FEATURES= iconv
RUBYGEM_AUTOPLIST= yes
GEM_ENV+= RUBYLIB=${PREFIX}/${GEM_LIB_DIR}/lib
diff --git a/devel/rubygem-ruby-ole/Makefile b/devel/rubygem-ruby-ole/Makefile
index 5f92444fb802..21285340c3f0 100644
--- a/devel/rubygem-ruby-ole/Makefile
+++ b/devel/rubygem-ruby-ole/Makefile
@@ -10,7 +10,6 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= Library for easy read/write access to OLE compound documents
USE_RUBY= yes
-USE_RUBY_FEATURES= iconv
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
diff --git a/mail/rubygem-tmail/Makefile b/mail/rubygem-tmail/Makefile
index ff03920c0633..0059f0e9f042 100644
--- a/mail/rubygem-tmail/Makefile
+++ b/mail/rubygem-tmail/Makefile
@@ -11,7 +11,6 @@ COMMENT= RFC2822/MIME compliant mail manipulating library for Ruby
USE_RUBY= yes
USE_RUBYGEMS= yes
-USE_RUBY_FEATURES= racc-runtime
RUBYGEM_AUTOPLIST= yes
.include <bsd.port.mk>
diff --git a/net/ruby-tcpsocketpipe/Makefile b/net/ruby-tcpsocketpipe/Makefile
index 451c2f6c29d5..7baf16ed1dc0 100644
--- a/net/ruby-tcpsocketpipe/Makefile
+++ b/net/ruby-tcpsocketpipe/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby library to create I/O pipes for TCP socket tunneling
USE_RUBY= yes
-USE_RUBY_FEATURES= devel-logger
NO_BUILD= yes
PLIST_FILES= %%RUBY_SITELIBDIR%%/socketproxy.rb
diff --git a/net/rubygem-rightaws/Makefile b/net/rubygem-rightaws/Makefile
index e51ae6f66682..0f183343c706 100644
--- a/net/rubygem-rightaws/Makefile
+++ b/net/rubygem-rightaws/Makefile
@@ -27,8 +27,6 @@ LIBXML_DESC= Use libxml instead of REXML
.if ${PORT_OPTIONS:MLIBXML}
RUN_DEPENDS+= rubygem-libxml-ruby>=0.5.2:${PORTSDIR}/textproc/rubygem-libxml-ruby
-.else
-USE_RUBY_FEATURES= rexml
.endif
.include <bsd.port.mk>
diff --git a/sysutils/rubygem-chef/Makefile b/sysutils/rubygem-chef/Makefile
index 5bbb41cf8d6d..d25949799b44 100644
--- a/sysutils/rubygem-chef/Makefile
+++ b/sysutils/rubygem-chef/Makefile
@@ -31,7 +31,6 @@ RUN_DEPENDS= rubygem-chef-zero>=2.1.0:${PORTSDIR}/sysutils/rubygem-chef-zero \
USE_RUBY= yes
USE_RUBYGEMS= yes
-USE_RUBY_FEATURES= iconv
RUBYGEM_AUTOPLIST= yes
SUB_LIST= RUBY=${RUBY}
diff --git a/textproc/ruby-rss.alt/Makefile b/textproc/ruby-rss.alt/Makefile
index 513afd2d92d0..645dcbc07984 100644
--- a/textproc/ruby-rss.alt/Makefile
+++ b/textproc/ruby-rss.alt/Makefile
@@ -20,7 +20,6 @@ CONFLICTS= ruby-rss-*
USE_RUBY= yes
USE_RUBY_SETUP= yes
-USE_RUBY_FEATURES= rexml
SADIR= lib/ruby/site_ruby/${RUBY_VER}/${RUBY_ARCH}
DOCS_EN= README.en Tutorial.en
diff --git a/textproc/ruby-xmlconfigfile/Makefile b/textproc/ruby-xmlconfigfile/Makefile
index d780c07767ef..8b41d3ab7cb6 100644
--- a/textproc/ruby-xmlconfigfile/Makefile
+++ b/textproc/ruby-xmlconfigfile/Makefile
@@ -15,7 +15,6 @@ COMMENT= Ruby module for easy handling of XML configuration files
OPTIONS_DEFINE= DOCS
USE_RUBY= yes
-USE_RUBY_FEATURES= rexml
USE_RUBY_SETUP= yes
RUBY_SETUP= install.rb
diff --git a/textproc/rubygem-nokogiri/Makefile b/textproc/rubygem-nokogiri/Makefile
index a8b1168bf3ff..70ce00ba83aa 100644
--- a/textproc/rubygem-nokogiri/Makefile
+++ b/textproc/rubygem-nokogiri/Makefile
@@ -12,7 +12,6 @@ COMMENT= HTML, XML, SAX, and Reader parser
LICENSE= MIT
USE_RUBY= yes
-USE_RUBY_FEATURES= iconv
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
USE_GNOME= libxml2 libxslt
diff --git a/textproc/rubygem-nokogiri14/Makefile b/textproc/rubygem-nokogiri14/Makefile
index 812b018ba2fd..82f06c82ce98 100644
--- a/textproc/rubygem-nokogiri14/Makefile
+++ b/textproc/rubygem-nokogiri14/Makefile
@@ -12,7 +12,6 @@ COMMENT= HTML, XML, SAX, and Reader parser
LICENSE= MIT
USE_RUBY= yes
-USE_RUBY_FEATURES= iconv
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
USE_GNOME= libxml2 libxslt
diff --git a/textproc/rubygem-spreadsheet/Makefile b/textproc/rubygem-spreadsheet/Makefile
index 2c35467fc938..185e31bfe7f8 100644
--- a/textproc/rubygem-spreadsheet/Makefile
+++ b/textproc/rubygem-spreadsheet/Makefile
@@ -14,7 +14,6 @@ LICENSE= GPLv3
RUN_DEPENDS= rubygem-ruby-ole>=1.0:${PORTSDIR}/devel/rubygem-ruby-ole
USE_RUBY= yes
-USE_RUBY_FEATURES= iconv
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
diff --git a/www/ruby-google/Makefile b/www/ruby-google/Makefile
index 9848e2a7455c..37444bba9f64 100644
--- a/www/ruby-google/Makefile
+++ b/www/ruby-google/Makefile
@@ -13,7 +13,6 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby interface to Google's SOAP-driven Web API
USE_RUBY= yes
-USE_RUBY_FEATURES= soap
USE_RUBY_SETUP= yes
RUBY_SETUP= install.rb
diff --git a/www/ruby-wgettsv/Makefile b/www/ruby-wgettsv/Makefile
index 32cae3f7e3b4..08c20f9cc82b 100644
--- a/www/ruby-wgettsv/Makefile
+++ b/www/ruby-wgettsv/Makefile
@@ -15,7 +15,6 @@ COMMENT= Collect WWW resources and generate TSV data
USES= shebangfix
SHEBANG_FILES= wgettsv
USE_RUBY= yes
-USE_RUBY_FEATURES= iconv
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/www/rubygem-maruku/Makefile b/www/rubygem-maruku/Makefile
index 27d47baa3b47..bddd0c3a7af8 100644
--- a/www/rubygem-maruku/Makefile
+++ b/www/rubygem-maruku/Makefile
@@ -11,7 +11,6 @@ COMMENT= Markdown and PHP Markdown extra interpreter for Ruby
USE_RUBY= yes
USE_RUBYGEMS= yes
-USE_RUBY_FEATURES= iconv
RUBYGEM_AUTOPLIST= yes
PLIST_FILES= bin/maruku bin/marutex