aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--textproc/saxon-devel/Makefile6
-rw-r--r--textproc/saxon-devel/files/saxon.sh10
-rw-r--r--textproc/saxon-he/Makefile6
-rw-r--r--textproc/saxon-he/files/saxon.sh10
4 files changed, 22 insertions, 10 deletions
diff --git a/textproc/saxon-devel/Makefile b/textproc/saxon-devel/Makefile
index 215907972a6b..3804c8c4bb46 100644
--- a/textproc/saxon-devel/Makefile
+++ b/textproc/saxon-devel/Makefile
@@ -16,8 +16,7 @@ DISTNAME= ${PORTNAME}b${PORTVERSION:S,.,-,g}
MAINTAINER= hq@FreeBSD.org
COMMENT= An XSLT 2.0 / XPath 2.0 / XQuery 1.0 processor for Java
-RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
- ${JAVALIBDIR}/xml-apis.jar:${PORTSDIR}/textproc/xerces-j
+RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
USE_ZIP= yes
USE_JAVA= yes
@@ -34,7 +33,8 @@ PORTDOCS= background documentation img javadoc
.endif
do-configure:
- @${SED} 's|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%JAVAVM%%|${JAVA}|g' \
+ @${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%JAVAVM%%|${JAVA}|g ; \
+ s|%%SAXON_JARS%%|${JARFILES:S,^,${JAVAJARDIR}/,}|' \
${FILESDIR}/saxon.sh >${WRKSRC}/saxon
do-install:
diff --git a/textproc/saxon-devel/files/saxon.sh b/textproc/saxon-devel/files/saxon.sh
index bfbf5eb61bc3..1865dbc5a793 100644
--- a/textproc/saxon-devel/files/saxon.sh
+++ b/textproc/saxon-devel/files/saxon.sh
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/textproc/saxon-devel/files/Attic/saxon.sh,v 1.3 2004-10-27 16:50:43 hq Exp $
+# $FreeBSD: /tmp/pcvs/ports/textproc/saxon-devel/files/Attic/saxon.sh,v 1.4 2004-11-09 16:03:39 hq Exp $
IAM=`basename "$0"`
@@ -11,4 +11,10 @@ else
LAUNCHER_CLASS="net.sf.saxon.Transform"
fi
-JAVAVM=%%JAVAVM%% %%LOCALBASE%%/bin/javavm -classpath "`%%LOCALBASE%%/bin/classpath`" ${LAUNCHER_CLASS} $@
+SAXON_CLASSPATH=""
+for jarfile in %%SAXON_JARS%%
+do
+ SAXON_CLASSPATH="${SAXON_CLASSPATH}:${jarfile}"
+done
+
+JAVAVM="%%JAVAVM%%" "%%LOCALBASE%%/bin/javavm" -classpath "${SAXON_CLASSPATH}" "${LAUNCHER_CLASS}" "$@"
diff --git a/textproc/saxon-he/Makefile b/textproc/saxon-he/Makefile
index 215907972a6b..3804c8c4bb46 100644
--- a/textproc/saxon-he/Makefile
+++ b/textproc/saxon-he/Makefile
@@ -16,8 +16,7 @@ DISTNAME= ${PORTNAME}b${PORTVERSION:S,.,-,g}
MAINTAINER= hq@FreeBSD.org
COMMENT= An XSLT 2.0 / XPath 2.0 / XQuery 1.0 processor for Java
-RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
- ${JAVALIBDIR}/xml-apis.jar:${PORTSDIR}/textproc/xerces-j
+RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
USE_ZIP= yes
USE_JAVA= yes
@@ -34,7 +33,8 @@ PORTDOCS= background documentation img javadoc
.endif
do-configure:
- @${SED} 's|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%JAVAVM%%|${JAVA}|g' \
+ @${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%JAVAVM%%|${JAVA}|g ; \
+ s|%%SAXON_JARS%%|${JARFILES:S,^,${JAVAJARDIR}/,}|' \
${FILESDIR}/saxon.sh >${WRKSRC}/saxon
do-install:
diff --git a/textproc/saxon-he/files/saxon.sh b/textproc/saxon-he/files/saxon.sh
index 7b7e03dbdb28..2f8fa270f061 100644
--- a/textproc/saxon-he/files/saxon.sh
+++ b/textproc/saxon-he/files/saxon.sh
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/textproc/saxon-he/files/Attic/saxon.sh,v 1.3 2004-10-27 16:50:43 hq Exp $
+# $FreeBSD: /tmp/pcvs/ports/textproc/saxon-he/files/Attic/saxon.sh,v 1.4 2004-11-09 16:03:39 hq Exp $
IAM=`basename "$0"`
@@ -11,4 +11,10 @@ else
LAUNCHER_CLASS="net.sf.saxon.Transform"
fi
-JAVAVM=%%JAVAVM%% %%LOCALBASE%%/bin/javavm -classpath "`%%LOCALBASE%%/bin/classpath`" ${LAUNCHER_CLASS} $@
+SAXON_CLASSPATH=""
+for jarfile in %%SAXON_JARS%%
+do
+ SAXON_CLASSPATH="${SAXON_CLASSPATH}:${jarfile}"
+done
+
+JAVAVM="%%JAVAVM%%" "%%LOCALBASE%%/bin/javavm" -classpath "${SAXON_CLASSPATH}" "${LAUNCHER_CLASS}" "$@"