aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/grpcurl/Makefile38
-rw-r--r--net/grpcurl/distinfo15
-rw-r--r--net/grpcurl/pkg-descr10
4 files changed, 64 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ac27f1bb2365..7d8b30477a21 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -214,6 +214,7 @@
SUBDIR += grilo-plugins2
SUBDIR += grilo2
SUBDIR += grive2
+ SUBDIR += grpcurl
SUBDIR += grsync
SUBDIR += gsk
SUBDIR += gspoof
diff --git a/net/grpcurl/Makefile b/net/grpcurl/Makefile
new file mode 100644
index 000000000000..73dbbc4f38ac
--- /dev/null
+++ b/net/grpcurl/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= grpcurl
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.0
+CATEGORIES= net
+
+MAINTAINER= seanc@FreeBSD.org
+COMMENT= Command-line tool that lets you interact with gRPC servers
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= go:lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= fullstorydev
+GH_SUBDIR= src/github.com/fullstorydev/grpcurl
+GH_TAGNAME= ca5693f
+GH_TUPLE= golang:protobuf:c65a041:jsonpb/src/github.com/golang/protobuf \
+ jhump:protoreflect:5cc2142:protoreflect/src/github.com/jhump/protoreflect \
+ golang:net:5f9ae10:net/src/golang.org/x/net \
+ grpc:grpc-go:4172bfc:grpcgo/src/google.golang.org/grpc \
+ golang:text:7922cc4:text/src/golang.org/x/text \
+ google:go-genproto:7fd901a:gogenproto/src/google.golang.org/genproto
+
+PLIST_FILES= bin/grpcurl
+
+do-build:
+ cd ${WRKSRC}/cmd/${PORTNAME} && ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOPATH=${WRKSRC} \
+ ${LOCALBASE}/bin/go build -ldflags "-X main.version=${DISTVERSIONPREFIX}${PORTVERSION} -s -w" \
+ -o ${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/fullstorydev/grpcurl/cmd/${PORTNAME}/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/grpcurl/distinfo b/net/grpcurl/distinfo
new file mode 100644
index 000000000000..870e1748797e
--- /dev/null
+++ b/net/grpcurl/distinfo
@@ -0,0 +1,15 @@
+TIMESTAMP = 1524426278
+SHA256 (fullstorydev-grpcurl-v0.1.0-ca5693f_GH0.tar.gz) = 452153e7d8614e2dd4b88ca8f1b15f08e56f4bf1671e886d4d8a00d7c6766dc5
+SIZE (fullstorydev-grpcurl-v0.1.0-ca5693f_GH0.tar.gz) = 52038
+SHA256 (golang-protobuf-c65a041_GH0.tar.gz) = 223d442662bf7e9bac76bd6daa029e3b6505d600cfebc30d8a780ce721f7fbda
+SIZE (golang-protobuf-c65a041_GH0.tar.gz) = 268297
+SHA256 (jhump-protoreflect-5cc2142_GH0.tar.gz) = a995d9af8c6d1e455a2191f2096b9a32ced282f00eaa5b8764881df68c19a3f6
+SIZE (jhump-protoreflect-5cc2142_GH0.tar.gz) = 374611
+SHA256 (golang-net-5f9ae10_GH0.tar.gz) = a591471891765ad5955b9650e0ce19a48317d88f950201e3c20168a2627efb8a
+SIZE (golang-net-5f9ae10_GH0.tar.gz) = 946787
+SHA256 (grpc-grpc-go-4172bfc_GH0.tar.gz) = fde1509495269a02f631b5d970375474e946288a50ebe55da4187d79065a52b5
+SIZE (grpc-grpc-go-4172bfc_GH0.tar.gz) = 430680
+SHA256 (golang-text-7922cc4_GH0.tar.gz) = 43e0ad74934bd8b295cf3fbd182fd2295114075be1ef598cedb3789ce284826f
+SIZE (golang-text-7922cc4_GH0.tar.gz) = 6566268
+SHA256 (google-go-genproto-7fd901a_GH0.tar.gz) = b5d5d485dfb4b7ba49900f63cb10d9f815791298bccf3395ccc8bfe99f96560b
+SIZE (google-go-genproto-7fd901a_GH0.tar.gz) = 1753095
diff --git a/net/grpcurl/pkg-descr b/net/grpcurl/pkg-descr
new file mode 100644
index 000000000000..624566f70e33
--- /dev/null
+++ b/net/grpcurl/pkg-descr
@@ -0,0 +1,10 @@
+grpcurl is a command-line tool that lets you interact with gRPC servers. It's
+basically curl for gRPC servers.
+
+The main purpose for this tool is to invoke RPC methods on a gRPC server from
+the command-line. gRPC servers use a binary encoding on the wire (protobufs)
+and is effectively impossible to interact with using regular HTTP tools such as
+curl. grpcurl accepts messages using JSON encoding, which is usable by both
+humans and scripts.
+
+WWW: https://github.com/fullstorydev/grpcurl