aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/mail-notification/Makefile96
-rw-r--r--mail/mail-notification/distinfo6
-rw-r--r--mail/mail-notification/files/patch-src_mn-gmail-mailbox-properties.c11
-rw-r--r--mail/mail-notification/files/patch-src_mn-imap-mailbox.c16
-rw-r--r--mail/mail-notification/pkg-plist15
5 files changed, 55 insertions, 89 deletions
diff --git a/mail/mail-notification/Makefile b/mail/mail-notification/Makefile
index 2fd7992fe5d6..bee0e36a00fc 100644
--- a/mail/mail-notification/Makefile
+++ b/mail/mail-notification/Makefile
@@ -5,78 +5,74 @@
# $FreeBSD$
#
-PORTNAME= mail-notification
-PORTVERSION= 2.0
-PORTREVISION= 5
-CATEGORIES= mail ipv6
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+PORTNAME= mail-notification
+DISTVERSION= 3.0-rc1
+CATEGORIES= mail ipv6
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= mailnotify
-MAINTAINER= jylefort@FreeBSD.org
-COMMENT= A mail notification for freedesktop.org-compliant system trays
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= A mail notification for freedesktop.org-compliant system trays
-USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack eel2
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix gnomehack eel2
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib -Wl,-export-dynamic
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-GCONF_SCHEMAS= mail-notification.schemas
-INSTALLS_OMF= yes
+USE_GMAKE= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+GCONF_SCHEMAS= mail-notification.schemas
+INSTALLS_OMF= yes
-OPTIONS= MBOX "mbox support" on \
- MH "MH support" on \
- MAILDIR "Maildir support" on \
- POP3 "POP3 support" on \
- IMAP "IMAP support" on \
- SSL "SSL/TLS support" on \
- SASL "SASL authentication support" on \
- GMAIL "Gmail support" on \
- EVOLUTION "Evolution support" off \
- SYLPHEED "Sylpheed support" on
+OPTIONS= MBOX "mbox support" on \
+ MH "MH support" on \
+ MAILDIR "Maildir support" on \
+ POP3 "POP3 support" on \
+ IMAP "IMAP support" on \
+ SSL "SSL/TLS support" on \
+ SASL "SASL authentication support" on \
+ GMAIL "Gmail support" on \
+ EVOLUTION "Evolution support" off \
+ SYLPHEED "Sylpheed support" on
.include <bsd.port.pre.mk>
.if defined(WITHOUT_MBOX)
-CONFIGURE_ARGS+= --disable-mbox
+CONFIGURE_ARGS+=--disable-mbox
.endif
.if defined(WITHOUT_MH)
-CONFIGURE_ARGS+= --disable-mh
+CONFIGURE_ARGS+=--disable-mh
.endif
.if defined(WITHOUT_MAILDIR)
-CONFIGURE_ARGS+= --disable-maildir
+CONFIGURE_ARGS+=--disable-maildir
.endif
.if defined(WITHOUT_POP3)
-CONFIGURE_ARGS+= --disable-pop3
+CONFIGURE_ARGS+=--disable-pop3
.endif
.if defined(WITHOUT_IMAP)
-CONFIGURE_ARGS+= --disable-imap
+CONFIGURE_ARGS+=--disable-imap
.endif
.if defined(WITHOUT_POP3) && defined(WITHOUT_IMAP)
# only POP3 and IMAP use SSL and SASL
-WITHOUT_SSL= yes
-WITHOUT_SASL= yes
+WITHOUT_SSL= yes
+WITHOUT_SASL= yes
.endif
.if defined(WITHOUT_GMAIL)
-CONFIGURE_ARGS+= --disable-gmail
-PLIST_SUB+= GMAIL="@comment "
+CONFIGURE_ARGS+=--disable-gmail
+PLIST_SUB+= GMAIL="@comment "
.else
-PLIST_SUB+= GMAIL=""
+PLIST_SUB+= GMAIL=""
.endif
.if defined(WITHOUT_EVOLUTION)
-CONFIGURE_ARGS+= --disable-evolution
-PLIST_SUB+= EVOLUTION="@comment "
+CONFIGURE_ARGS+=--disable-evolution
+PLIST_SUB+= EVOLUTION="@comment "
.else
-BUILD_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/mail/evolution:patch \
- ${X11BASE}/libdata/pkgconfig/evolution-plugin-2.6.pc:${PORTSDIR}/mail/evolution
-RUN_DEPENDS+= ${X11BASE}/libdata/pkgconfig/evolution-plugin-2.6.pc:${PORTSDIR}/mail/evolution
-EVOLUTION_WRKSRC!= cd ${PORTSDIR}/mail/evolution && ${MAKE} -V WRKSRC
-CONFIGURE_ARGS+= --with-evolution-source-dir="${EVOLUTION_WRKSRC}"
-PLIST_SUB+= EVOLUTION="" LITERAL_PREFIX="${PREFIX}"
+BUILD_DEPENDS+= ${X11BASE}/libdata/pkgconfig/evolution-plugin-2.6.pc:${PORTSDIR}/mail/evolution
+RUN_DEPENDS+= ${X11BASE}/libdata/pkgconfig/evolution-plugin-2.6.pc:${PORTSDIR}/mail/evolution
+PLIST_SUB+= EVOLUTION="" LITERAL_PREFIX="${PREFIX}"
.endif
.if defined(WITHOUT_SYLPHEED)
-CONFIGURE_ARGS+= --disable-sylpheed
+CONFIGURE_ARGS+=--disable-sylpheed
.endif
.if defined(WITH_MBOX) \
|| defined(WITH_MH) \
@@ -84,22 +80,18 @@ CONFIGURE_ARGS+= --disable-sylpheed
|| defined(WITH_POP3) \
|| defined(WITH_IMAP) \
|| defined(WITH_SYLPHEED)
-LIB_DEPENDS+= gmime-2.0.4:${PORTSDIR}/mail/gmime2
+LIB_DEPENDS+= gmime-2.0.4:${PORTSDIR}/mail/gmime2
.endif
.if defined(WITHOUT_SSL)
-CONFIGURE_ARGS+= --disable-ssl
+CONFIGURE_ARGS+=--disable-ssl
.else
# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
.endif
.if defined(WITHOUT_SASL)
-CONFIGURE_ARGS+= --disable-sasl
+CONFIGURE_ARGS+=--disable-sasl
.else
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|evolution-plugin-2.2|evolution-plugin-2.6|' \
- ${WRKSRC}/configure
-
.include <bsd.port.post.mk>
diff --git a/mail/mail-notification/distinfo b/mail/mail-notification/distinfo
index b37e84f9b98a..d7e33e5ac638 100644
--- a/mail/mail-notification/distinfo
+++ b/mail/mail-notification/distinfo
@@ -1,3 +1,3 @@
-MD5 (mail-notification-2.0.tar.gz) = 56ef7401aba1cb27d881fb0f33a3248d
-SHA256 (mail-notification-2.0.tar.gz) = e4ec2fe27b3d399a6289857ef5a33e564bfe641a829f597e9dac753ae643339b
-SIZE (mail-notification-2.0.tar.gz) = 869151
+MD5 (mail-notification-3.0-rc1.tar.gz) = 74e2e61744e5a66da16faa1b61530ea8
+SHA256 (mail-notification-3.0-rc1.tar.gz) = 0c77a6721d91c1604144275f921661d4f38d81f59390b803dea6c045a8b4da07
+SIZE (mail-notification-3.0-rc1.tar.gz) = 908606
diff --git a/mail/mail-notification/files/patch-src_mn-gmail-mailbox-properties.c b/mail/mail-notification/files/patch-src_mn-gmail-mailbox-properties.c
deleted file mode 100644
index 1ae37750b18c..000000000000
--- a/mail/mail-notification/files/patch-src_mn-gmail-mailbox-properties.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/mn-gmail-mailbox-properties.c.orig Tue Aug 9 22:01:56 2005
-+++ src/mn-gmail-mailbox-properties.c Wed Aug 10 14:29:05 2005
-@@ -180,7 +180,7 @@
- GTK_ENTRY(auth->password_entry),
- NULL);
-
-- g_signal_connect(auth->username_entry, "changed", G_CALLBACK(mn_mailbox_properties_notify_default_name), self);
-+ g_signal_connect_swapped(auth->username_entry, "changed", G_CALLBACK(mn_mailbox_properties_notify_default_name), self);
-
- #line 186 "mn-gmail-mailbox-properties.c"
- }
diff --git a/mail/mail-notification/files/patch-src_mn-imap-mailbox.c b/mail/mail-notification/files/patch-src_mn-imap-mailbox.c
deleted file mode 100644
index 7856dd51e208..000000000000
--- a/mail/mail-notification/files/patch-src_mn-imap-mailbox.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/mn-imap-mailbox.c.orig Tue Aug 9 22:01:56 2005
-+++ src/mn-imap-mailbox.c Wed Jan 25 19:22:48 2006
-@@ -1646,7 +1646,12 @@
- */
- if (mn_ascii_validate(input))
- {
-- if (g_str_has_prefix(input, "+ "))
-+ if (! strcmp(input, "+"))
-+ {
-+ response = g_new0(MNClientSessionResponse, 1);
-+ response->continuation = g_strdup("");
-+ }
-+ else if (g_str_has_prefix(input, "+ "))
- {
- response = g_new0(MNClientSessionResponse, 1);
- response->continuation = g_strdup(input + 2);
diff --git a/mail/mail-notification/pkg-plist b/mail/mail-notification/pkg-plist
index deb9150dbf08..c8f7a4445b63 100644
--- a/mail/mail-notification/pkg-plist
+++ b/mail/mail-notification/pkg-plist
@@ -1,9 +1,8 @@
bin/mail-notification
-etc/sound/events/mail-notification.soundlist
+etc/xdg/autostart/mail-notification.desktop
libdata/bonobo/servers/GNOME_MailNotification.server
%%EVOLUTION%%libdata/bonobo/servers/GNOME_MailNotification_Evolution.server
share/gnome/applications/mail-notification-properties.desktop
-share/gnome/applications/mail-notification.desktop
share/gnome/help/mail-notification/C/documentation-license.xml
share/gnome/help/mail-notification/C/figures/mail.png
share/gnome/help/mail-notification/C/figures/mailbox-emblem-error.png
@@ -11,27 +10,28 @@ share/gnome/help/mail-notification/C/figures/mailbox-emblem-polled.png
share/gnome/help/mail-notification/C/figures/mailbox-emblem-unknown.png
share/gnome/help/mail-notification/C/mail-notification.xml
share/gnome/help/mail-notification/C/software-license.xml
-share/gnome/mail-notification/ui/edit-toolbars-dialog.glade
%%GMAIL%%share/gnome/mail-notification/ui/gmail.png
-share/gnome/mail-notification/ui/hand-open.png
share/gnome/mail-notification/ui/logo.png
share/gnome/mail-notification/ui/mail-summary-popup.glade
share/gnome/mail-notification/ui/mailbox-properties-dialog.glade
-share/gnome/mail-notification/ui/main-window.png
-share/gnome/mail-notification/ui/menus.xml
share/gnome/mail-notification/ui/properties-dialog.glade
-share/gnome/mail-notification/ui/toolbars.xml
share/gnome/omf/mail-notification/mail-notification-C.omf
share/gnome/pixmaps/mail-notification.png
share/locale/bg/LC_MESSAGES/mail-notification.mo
+share/locale/cs/LC_MESSAGES/mail-notification.mo
share/locale/de/LC_MESSAGES/mail-notification.mo
share/locale/fr/LC_MESSAGES/mail-notification.mo
+share/locale/ja/LC_MESSAGES/mail-notification.mo
+share/locale/nl/LC_MESSAGES/mail-notification.mo
share/locale/pl/LC_MESSAGES/mail-notification.mo
share/locale/pt/LC_MESSAGES/mail-notification.mo
+share/locale/pt_BR/LC_MESSAGES/mail-notification.mo
share/locale/ru/LC_MESSAGES/mail-notification.mo
share/locale/sr/LC_MESSAGES/mail-notification.mo
share/locale/sr@Latn/LC_MESSAGES/mail-notification.mo
%%EVOLUTION%%@cwd %%X11BASE%%
+%%EVOLUTION%%lib/evolution/2.6/plugins/liborg-gnome-mail-notification.a
+%%EVOLUTION%%lib/evolution/2.6/plugins/liborg-gnome-mail-notification.la
%%EVOLUTION%%lib/evolution/2.6/plugins/liborg-gnome-mail-notification.so
%%EVOLUTION%%lib/evolution/2.6/plugins/org-gnome-mail-notification.eplug
%%EVOLUTION%%@cwd %%LITERAL_PREFIX%%
@@ -41,3 +41,4 @@ share/locale/sr@Latn/LC_MESSAGES/mail-notification.mo
@dirrm share/gnome/help/mail-notification/C/figures
@dirrm share/gnome/help/mail-notification/C
@dirrm share/gnome/help/mail-notification
+@dirrmtry etc/xdg/autostart