aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/hawk/Makefile4
-rw-r--r--net-mgmt/klg/Makefile4
-rw-r--r--net-mgmt/nagiosql/Makefile3
-rw-r--r--net-mgmt/nedi/Makefile3
-rw-r--r--net-mgmt/ocsinventory-ng/Makefile3
-rw-r--r--net-mgmt/pandorafms_console/Makefile3
-rw-r--r--net-mgmt/phpip/Makefile3
-rw-r--r--net-mgmt/zabbix2-frontend/Makefile23
8 files changed, 13 insertions, 33 deletions
diff --git a/net-mgmt/hawk/Makefile b/net-mgmt/hawk/Makefile
index d87911bf3832..02305afbd030 100644
--- a/net-mgmt/hawk/Makefile
+++ b/net-mgmt/hawk/Makefile
@@ -16,10 +16,8 @@ RUN_DEPENDS= p5-Net-Netmask>=0:net-mgmt/p5-Net-Netmask \
p5-DBI>=0:databases/p5-DBI \
p5-DBD-mysql>=0:databases/p5-DBD-mysql
-USES= perl5
-USE_MYSQL= server
+USES= mysql:server php:mod perl5
USE_PHP= mysql
-WANT_PHP_MOD= yes
IGNORE_WITH_PHP= 70 71
NO_BUILD= yes
diff --git a/net-mgmt/klg/Makefile b/net-mgmt/klg/Makefile
index fc29b0796e8e..2ec4324edf5c 100644
--- a/net-mgmt/klg/Makefile
+++ b/net-mgmt/klg/Makefile
@@ -11,10 +11,8 @@ COMMENT= PHP-based looking glass for Cisco, Juniper and Quagga/Zebra routers
LICENSE= BSD3CLAUSE
-USES= tar:txz php
-USE_MYSQL= yes
+USES= mysql tar:txz php:web
USE_PHP= mysql pcre sockets xml
-WANT_PHP_WEB= yes
NO_ARCH= yes
NO_BUILD= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/net-mgmt/nagiosql/Makefile b/net-mgmt/nagiosql/Makefile
index cc8a7c0e5f40..5104b9c2ccd3 100644
--- a/net-mgmt/nagiosql/Makefile
+++ b/net-mgmt/nagiosql/Makefile
@@ -18,9 +18,8 @@ RUN_DEPENDS= nagios:net-mgmt/nagios \
${PEARDIR}/HTML/Template/IT.php:devel/pear-HTML_Template_IT@${PHP_FLAVOR}
USE_MYSQL= yes
-USES= cpe gettext tar:bzip2
+USES= cpe gettext php:web tar:bzip2
USE_PHP= mysql filter gettext session simplexml
-WANT_PHP_WEB= yes
USERS?= nagios
GROUPS?= nagios
diff --git a/net-mgmt/nedi/Makefile b/net-mgmt/nedi/Makefile
index 79fdb24f2d7e..10c91ae7f805 100644
--- a/net-mgmt/nedi/Makefile
+++ b/net-mgmt/nedi/Makefile
@@ -17,14 +17,13 @@ RUN_DEPENDS= p5-Net-SNMP>=0:net-mgmt/p5-Net-SNMP \
p5-Algorithm-Diff>=0:devel/p5-Algorithm-Diff \
p5-DBI>=0:databases/p5-DBI
-USES= perl5 shebangfix tar:tgz
+USES= php:web perl5 shebangfix tar:tgz
SHEBANG_FILES= *.pl html/inc/Devsend.pl
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
NO_ARCH= yes
USE_PHP= session snmp mysql
-WANT_PHP_WEB= yes
SUB_FILES= pkg-message
PLIST_SUB+= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
diff --git a/net-mgmt/ocsinventory-ng/Makefile b/net-mgmt/ocsinventory-ng/Makefile
index 3dc430779b5a..80c64051c73b 100644
--- a/net-mgmt/ocsinventory-ng/Makefile
+++ b/net-mgmt/ocsinventory-ng/Makefile
@@ -21,8 +21,7 @@ RUN_DEPENDS= p5-XML-Simple>=0:textproc/p5-XML-Simple \
p5-SOAP-Lite>=0:net/p5-SOAP-Lite \
p5-XML-Entities>=0:textproc/p5-XML-Entities
-USES= apache:run,2.2+ mysql perl5
-WANT_PHP_WEB= yes
+USES= apache:run,2.2+ mysql perl5 php:web
USE_PHP= mysql pcre zlib session xml gd zip openssl mbstring
NO_ARCH= yes
NO_BUILD= yes
diff --git a/net-mgmt/pandorafms_console/Makefile b/net-mgmt/pandorafms_console/Makefile
index db52e97c1609..9380c3a18db9 100644
--- a/net-mgmt/pandorafms_console/Makefile
+++ b/net-mgmt/pandorafms_console/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${PANDORA_LICENSE_FILE}
RUN_DEPENDS= ${LOCALBASE}/bin/twopi:graphics/graphviz
-USES= apache:run,2.2+ shebangfix
+USES= apache:run,2.2+ php:web shebangfix
SHEBANG_FILES= include/languages/extract_newlines.sh \
include/languages/util-all \
include/languages/util-bzr-update \
@@ -29,7 +29,6 @@ PGSQL_DESC= Use PostgreSQL backend (experimental)
USE_PHP= curl filter gd gettext hash json ldap mbstring mysql \
snmp session xml zip zlib
-WANT_PHP_WEB= yes
SUB_FILES+= pandora_console.conf pkg-message newsyslog.conf
SUB_LIST+= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
diff --git a/net-mgmt/phpip/Makefile b/net-mgmt/phpip/Makefile
index fa28839d03d7..6a5082084ebf 100644
--- a/net-mgmt/phpip/Makefile
+++ b/net-mgmt/phpip/Makefile
@@ -17,8 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
SNAPSHOT= 200611081420
NO_BUILD= yes
USE_PHP= mysql
-USES= dos2unix
-WANT_PHP_WEB= yes
+USES= dos2unix php:web
IGNORE_WITH_PHP= 70 71
diff --git a/net-mgmt/zabbix2-frontend/Makefile b/net-mgmt/zabbix2-frontend/Makefile
index 65b806873dc2..bb7305c3ce8c 100644
--- a/net-mgmt/zabbix2-frontend/Makefile
+++ b/net-mgmt/zabbix2-frontend/Makefile
@@ -14,7 +14,7 @@ PLIST= ${PKGDIR}/pkg-plist.frontend
USE_PHP= bcmath ctype gd pcre snmp sockets mbstring session dom xml \
xmlreader xmlwriter simplexml gettext ldap
-WANT_PHP_WEB= yes
+USES= php:web
OPTIONS_DEFINE= MYSQL MYSQLI PGSQL SQLITE ORACLE
OPTIONS_DEFAULT= MYSQL MYSQLI
@@ -22,23 +22,12 @@ MYSQLI_DESC= MySQLI backend
MYSQL_VARS= IGNORE_WITH_PHP+=70
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_PHP+= mysql
-.endif
-
-.if ${PORT_OPTIONS:MMYSQLI}
-USE_PHP+= mysqli
-.endif
+MYSQL_USE= PHP=mysql
+MYSQLI_USE= PHP=mysqli
+PGSQL_USE= PHP=pgsql
+SQLITE_USE= PHP=sqlite3
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PHP+= pgsql
-.endif
-
-.if ${PORT_OPTIONS:MSQLITE}
-USE_PHP+= sqlite3
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MORACLE}
ZABBIX_REQUIRE=