aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/par2cmdline-tbb/Makefile4
-rw-r--r--devel/tbb/Makefile16
-rw-r--r--devel/tbb/distinfo4
-rw-r--r--devel/tbb/pkg-plist25
-rw-r--r--graphics/opencv/Makefile4
5 files changed, 33 insertions, 20 deletions
diff --git a/archivers/par2cmdline-tbb/Makefile b/archivers/par2cmdline-tbb/Makefile
index 50abc2eb4fa4..8a117929bbeb 100644
--- a/archivers/par2cmdline-tbb/Makefile
+++ b/archivers/par2cmdline-tbb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= par2cmdline-tbb
PORTVERSION= 20100203
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= archivers
MASTER_SITES= http://chuchusoft.com/par2_tbb/
DISTNAME= par2cmdline-0.4-tbb-${PORTVERSION}
@@ -15,7 +15,7 @@ DISTNAME= par2cmdline-0.4-tbb-${PORTVERSION}
MAINTAINER= martymac@FreeBSD.org
COMMENT= Tools for using Parity v2 Archive files (tbb version)
-LIB_DEPENDS= tbb.3:${PORTSDIR}/devel/tbb
+LIB_DEPENDS= tbb.4:${PORTSDIR}/devel/tbb
LICENSE= GPLv2
diff --git a/devel/tbb/Makefile b/devel/tbb/Makefile
index adcff131c74c..05b2c9588a4f 100644
--- a/devel/tbb/Makefile
+++ b/devel/tbb/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= tbb
-PORTVERSION= 3.0.5
+PORTVERSION= 4.0.0
CATEGORIES= devel
-MASTER_SITES= http://threadingbuildingblocks.org/uploads/77/164/3.0%20Update%205/ \
+MASTER_SITES= http://threadingbuildingblocks.org/uploads/78/174/4.0/ \
LOCAL/martymac
-DISTNAME= tbb30_20101215oss_src
+DISTNAME= tbb40_233oss_src
EXTRACT_SUFX= .tgz
MAINTAINER= martymac@FreeBSD.org
@@ -25,7 +25,7 @@ USE_GMAKE= yes
ALL_TARGET= default
MAKE_ENV= CPLUS=${CXX}
-WRKSRC= ${WRKDIR}/tbb30_20101215oss
+WRKSRC= ${WRKDIR}/tbb40_233oss
post-extract:
@${CP} ${FILESDIR}/version_info_FreeBSD.sh ${WRKSRC}/build/
@@ -37,11 +37,11 @@ post-patch:
do-install:
cd ${WRKSRC}; \
${INSTALL_DATA} build/FreeBSD*release/libtbb.so \
- ${PREFIX}/lib/libtbb.so.3; \
- ${LN} -fs ${PREFIX}/lib/libtbb.so.3 ${PREFIX}/lib/libtbb.so; \
+ ${PREFIX}/lib/libtbb.so.4; \
+ ${LN} -fs ${PREFIX}/lib/libtbb.so.4 ${PREFIX}/lib/libtbb.so; \
${INSTALL_DATA} build/FreeBSD*release/libtbbmalloc.so \
- ${PREFIX}/lib/libtbbmalloc.so.3; \
- ${LN} -fs ${PREFIX}/lib/libtbbmalloc.so.3 ${PREFIX}/lib/libtbbmalloc.so; \
+ ${PREFIX}/lib/libtbbmalloc.so.4; \
+ ${LN} -fs ${PREFIX}/lib/libtbbmalloc.so.4 ${PREFIX}/lib/libtbbmalloc.so; \
${MKDIR} ${PREFIX}/include/tbb/; \
cd include/tbb/ && ${COPYTREE_SHARE} \* ${PREFIX}/include/tbb/
diff --git a/devel/tbb/distinfo b/devel/tbb/distinfo
index 8c480d60e861..8bb317a347c2 100644
--- a/devel/tbb/distinfo
+++ b/devel/tbb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tbb30_20101215oss_src.tgz) = e86026ac88314fb6429c0511d51b661db9bf17229e85702e119e7a684f6d9d69
-SIZE (tbb30_20101215oss_src.tgz) = 1743537
+SHA256 (tbb40_233oss_src.tgz) = e6761eccde5a483f82ceb959522ffa95a71e01d31c3c2e341b7baa1fc198d21b
+SIZE (tbb40_233oss_src.tgz) = 2057845
diff --git a/devel/tbb/pkg-plist b/devel/tbb/pkg-plist
index f7a9f09faeeb..335d4c7b1e8f 100644
--- a/devel/tbb/pkg-plist
+++ b/devel/tbb/pkg-plist
@@ -1,5 +1,4 @@
include/tbb/concurrent_priority_queue.h
-include/tbb/graph.h
include/tbb/task.h
include/tbb/parallel_while.h
include/tbb/task_scheduler_init.h
@@ -20,6 +19,11 @@ include/tbb/queuing_rw_mutex.h
include/tbb/tick_count.h
include/tbb/parallel_for.h
include/tbb/recursive_mutex.h
+include/tbb/concurrent_unordered_set.h
+include/tbb/memory_pool.h
+include/tbb/flow_graph.h
+include/tbb/runtime_loader.h
+include/tbb/machine/gcc_generic.h
include/tbb/machine/windows_api.h
include/tbb/machine/macos_common.h
include/tbb/machine/sunos_sparc.h
@@ -32,11 +36,21 @@ include/tbb/machine/linux_common.h
include/tbb/machine/windows_intel64.h
include/tbb/machine/linux_intel64.h
include/tbb/machine/windows_ia32.h
+include/tbb/internal/_aggregator_impl.h
+include/tbb/internal/_flow_graph_tagged_buffer_impl.h
+include/tbb/internal/_flow_graph_impl.h
+include/tbb/internal/_flow_graph_join_impl.h
+include/tbb/internal/_flow_graph_or_impl.h
+include/tbb/internal/_flow_graph_node_impl.h
+include/tbb/internal/_flow_graph_types_impl.h
+include/tbb/internal/_tbb_windef.h
+include/tbb/internal/_concurrent_queue_impl.h
+include/tbb/internal/_concurrent_unordered_impl.h
+include/tbb/internal/_flow_graph_item_buffer_impl.h
include/tbb/concurrent_vector.h
include/tbb/parallel_for_each.h
include/tbb/tbb_allocator.h
include/tbb/queuing_mutex.h
-include/tbb/_concurrent_unordered_internal.h
include/tbb/blocked_range2d.h
include/tbb/parallel_sort.h
include/tbb/task_scheduler_observer.h
@@ -45,7 +59,6 @@ include/tbb/parallel_scan.h
include/tbb/null_rw_mutex.h
include/tbb/spin_rw_mutex.h
include/tbb/blocked_range3d.h
-include/tbb/_concurrent_queue_internal.h
include/tbb/pipeline.h
include/tbb/compat/ppl.h
include/tbb/compat/thread
@@ -55,7 +68,6 @@ include/tbb/spin_mutex.h
include/tbb/tbbmalloc_proxy.h
include/tbb/concurrent_unordered_map.h
include/tbb/cache_aligned_allocator.h
-include/tbb/_tbb_windef.h
include/tbb/tbb.h
include/tbb/tbb_machine.h
include/tbb/scalable_allocator.h
@@ -67,10 +79,11 @@ include/tbb/concurrent_hash_map.h
include/tbb/null_mutex.h
include/tbb/reader_writer_lock.h
include/tbb/task_group.h
+@dirrm include/tbb/internal
@dirrm include/tbb/machine
@dirrm include/tbb/compat
@dirrm include/tbb
lib/libtbb.so
-lib/libtbb.so.3
+lib/libtbb.so.4
lib/libtbbmalloc.so
-lib/libtbbmalloc.so.3
+lib/libtbbmalloc.so.4
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 2d300b978817..97de00c90c83 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= opencv
PORTVERSION= 2.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}library/${PORTNAME}-unix/${PORTVERSION}
DISTNAME= OpenCV-${DISTVERSION}a
@@ -126,7 +126,7 @@ CMAKE_ARGS+= -DWITH_QT:BOOL=Off
.endif
.if defined(WITH_TBB)
-LIB_DEPENDS+= tbb.3:${PORTSDIR}/devel/tbb
+LIB_DEPENDS+= tbb.4:${PORTSDIR}/devel/tbb
CMAKE_ARGS+= -DWITH_TBB:BOOL=On \
-DTBBLIB_FOUND:BOOL=1 -DTBB_FOUND:BOOL=On \
-DTBB_INCLUDE_DIRS:STRING="${LOCALBASE}/include" \