aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/sidplayer/Makefile14
-rw-r--r--audio/sidplayer/files/pkg-message.in4
-rw-r--r--lang/visualworks/Makefile18
-rw-r--r--lang/visualworks/files/pkg-message.in11
-rw-r--r--mail/imap-uw/Makefile26
-rw-r--r--mail/imap-uw/files/pkg-message.in15
-rw-r--r--mail/panda-imap/Makefile26
-rw-r--r--mail/panda-imap/files/pkg-message.in15
-rw-r--r--mail/qpopper/Makefile13
-rw-r--r--mail/qpopper/files/pkg-message.in7
-rw-r--r--news/noffle/Makefile4
-rw-r--r--news/noffle/files/pkg-message.in (renamed from news/noffle/pkg-message)2
-rw-r--r--sysutils/clockspeed/Makefile5
-rw-r--r--sysutils/clockspeed/files/pkg-message.in (renamed from sysutils/clockspeed/pkg-message)10
-rw-r--r--sysutils/env4801/Makefile12
-rw-r--r--sysutils/env4801/files/env4801.sh.in (renamed from sysutils/env4801/files/env4801.sh)0
-rw-r--r--sysutils/env4801/files/pkg-message.in (renamed from sysutils/env4801/pkg-message)0
-rw-r--r--www/b2evolution/Makefile8
-rw-r--r--www/b2evolution/files/pkg-message.in (renamed from www/b2evolution/pkg-message)0
-rw-r--r--www/lilurl/Makefile5
-rw-r--r--www/lilurl/files/pkg-message.in8
21 files changed, 85 insertions, 118 deletions
diff --git a/audio/sidplayer/Makefile b/audio/sidplayer/Makefile
index 9b79fc86d55b..d2b228d20b3e 100644
--- a/audio/sidplayer/Makefile
+++ b/audio/sidplayer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sidplayer
PORTVERSION= 4.4
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= audio
MASTER_SITES= http://sidplayer.cebix.net/downloads/ \
LOCAL/ehaupt
@@ -20,8 +20,8 @@ GNU_CONFIGURE= yes
SDLINCLUDEDIR= SDL
OPTIONS_DEFINE= DOCS
-
-.include <bsd.port.options.mk>
+OPTIONS_SUB= yes
+SUB_FILES= pkg-message
post-patch:
@${REINPLACE_CMD} -e 's|SDL/SDL_endian\.h|${SDLINCLUDEDIR}/SDL_endian\.h|' \
@@ -32,12 +32,4 @@ do-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/PSID\ Demo/* ${STAGEDIR}${DOCSDIR}
-post-install:
- @${ECHO_MSG} "=============================================================="
- @${ECHO_MSG} "A huge SID tune archive can be found at http://hvsc.c64.org/"
-.if ${PORT_OPTIONS:MDOCS}
- @${ECHO_MSG} "You can find a few examples in ${DOCSDIR}"
-.endif
- @${ECHO_MSG} "=============================================================="
-
.include <bsd.port.mk>
diff --git a/audio/sidplayer/files/pkg-message.in b/audio/sidplayer/files/pkg-message.in
new file mode 100644
index 000000000000..f8454ae7ef26
--- /dev/null
+++ b/audio/sidplayer/files/pkg-message.in
@@ -0,0 +1,4 @@
+==============================================================
+A huge SID tune archive can be found at http://hvsc.c64.org/
+%%DOCS%%You can find a few examples in %%DOCSDIR%%
+==============================================================
diff --git a/lang/visualworks/Makefile b/lang/visualworks/Makefile
index 32ccbf4fcbd9..9a5e6ed3a0ed 100644
--- a/lang/visualworks/Makefile
+++ b/lang/visualworks/Makefile
@@ -3,6 +3,7 @@
PORTNAME= visualworks
PORTVERSION= 7.6
+PORTREVISION= 1
CATEGORIES= lang linux
MASTER_SITES= http://www.cincomsmalltalk.com/bsdports/${SUBDIR}.old/
DISTFILES= BaseVisualWorks.tar.gz \
@@ -28,6 +29,8 @@ OPTIONS_DEFINE= ATOOLS COM DLLC DST DATABASE DOTNET CONTRIBUTED ARAGON COAST DOM
WEBAPP WEBSERVICES VMLINUX VMWINDOWS VMMAC VMSOLARIS VMAIX VMHPUX VMSGI
OPTIONS_DEFAULT= DLLC DATABASE SEASIDE STORE
+SUB_FILES= pkg-message
+
ATOOLS_DESC= Advanced Tools
COM_DESC= COM
DLLC_DESC= DLLC Connect
@@ -163,19 +166,4 @@ do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/${MY_STARTUP_SCRIPT} ${STAGEDIR}${DATADIR}
@${LN} -s ${DATADIR}/${MY_STARTUP_SCRIPT} ${STAGEDIR}${PREFIX}/bin/visual
-post-install:
- @${ECHO_MSG} " "
- @${ECHO_MSG} " --------------------------- Please note: ---------------------------"
- @${ECHO_MSG} " "
- @${ECHO_MSG} " To start using VisualWorks, copy the default image to your"
- @${ECHO_MSG} " home directory:"
- @${ECHO_MSG} " # ${CP} ${DATADIR}/image/visualnc.im ~"
- @${ECHO_MSG} " Make it writeable:"
- @${ECHO_MSG} " # ${CHMOD} u+w ~/visualnc.im"
- @${ECHO_MSG} " Then run it using:"
- @${ECHO_MSG} " # visual ~/visualnc.im"
- @${ECHO_MSG} " "
- @${ECHO_MSG} " -------------------- Thanks for your attention! --------------------"
- @${ECHO_MSG} " "
-
.include <bsd.port.post.mk>
diff --git a/lang/visualworks/files/pkg-message.in b/lang/visualworks/files/pkg-message.in
new file mode 100644
index 000000000000..fe0989969644
--- /dev/null
+++ b/lang/visualworks/files/pkg-message.in
@@ -0,0 +1,11 @@
+ --------------------------- Please note: ---------------------------
+
+ To start using VisualWorks, copy the default image to your
+ home directory:
+ # cp %%DATADIR%%/image/visualnc.im ~
+ Make it writeable:
+ # chmod u+w ~/visualnc.im
+ Then run it using:
+ # visual ~/visualnc.im
+
+ -------------------- Thanks for your attention! --------------------
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index b40c83b7eaee..51e2e22d1e07 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -3,6 +3,7 @@
PORTNAME= imap
PORTVERSION= 2007f
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
@@ -34,6 +35,7 @@ ALL_TARGET= bsf
OPTIONS_DEFINE= SSL SSL_AND_PLAINTEXT DRAC NETSCAPE_BRAIN_DAMAGE DOCS
OPTIONS_DEFAULT= SSL
+OPTIONS_SUB= yes
SSL_DESC= Compile with SSL support
SSL_AND_PLAINTEXT_DESC= Allow plain text passwords and SSL
DRAC_DESC= Dynamically open MTA for relaying
@@ -94,32 +96,10 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/src/mailutil/mailutil.1 ${STAGEDIR}${PREFIX}/man/man1/
${INSTALL_MAN} ${WRKSRC}/src/tmail/tmail.1 ${STAGEDIR}${PREFIX}/man/man1/
-post-install:
- @${CAT} ${PKGMESSAGE}
-.if ${PORT_OPTIONS:MDRAC}
- @${ECHO} "================================================================================"
- @${ECHO} "To have DRAC working, you must create ${PREFIX}/etc/dracd.host, containing"
- @${ECHO} "the hostname of the DRAC server:"
- @${ECHO}
- @${ECHO} "localhost"
- @${ECHO} "================================================================================"
-.endif
-.if ${PORT_OPTIONS:MSSL}
- @${ECHO}
- @${ECHO} "To create and install a new SSL certificate for imapd and ipop3d, type \"make"
- @${ECHO} "cert\". Or install manually in ${PREFIX}/certs."
- @${ECHO}
- @${ECHO} "Example inetd config for SSL only services:"
- @${ECHO}
- @${ECHO} "pop3s stream tcp nowait root ${PREFIX}/libexec/ipop3d ipop3d"
- @${ECHO} "imaps stream tcp nowait root ${PREFIX}/libexec/imapd imapd"
- @${ECHO} "================================================================================"
-.endif
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} -m 0755 -p ${STAGEDIR}${DOCSDIR}
@${TAR} -C ${WRKSRC}/docs -cf - . | \
(umask 022; ${TAR} -C ${STAGEDIR}${DOCSDIR} -xf -)
-.endif
cert:
@${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/certs
diff --git a/mail/imap-uw/files/pkg-message.in b/mail/imap-uw/files/pkg-message.in
index 21f0badd3448..62b3f7d2c277 100644
--- a/mail/imap-uw/files/pkg-message.in
+++ b/mail/imap-uw/files/pkg-message.in
@@ -31,3 +31,18 @@ dir accessed.
WITHOUT_SSL - build without SSL/encryption support.
WITH_SSL_AND_PLAINTEXT - build with SSL/encryption support, but allow
non-encrypted logins.
+%%DRAC%%================================================================================
+%%DRAC%%To have DRAC working, you must create ${PREFIX}/etc/dracd.host, containing
+%%DRAC%%the hostname of the DRAC server:
+%%DRAC%%
+%%DRAC%%localhost
+%%DRAC%%================================================================================
+%%SSL%%
+%%SSL%%To create and install a new SSL certificate for imapd and ipop3d, type \"make
+%%SSL%%cert\". Or install manually in ${PREFIX}/certs.
+%%SSL%%
+%%SSL%%Example inetd config for SSL only services:
+%%SSL%%
+%%SSL%%pop3s stream tcp nowait root ${PREFIX}/libexec/ipop3d ipop3d
+%%SSL%%imaps stream tcp nowait root ${PREFIX}/libexec/imapd imapd
+%%SSL%%================================================================================
diff --git a/mail/panda-imap/Makefile b/mail/panda-imap/Makefile
index 747656c9b56d..586050db9448 100644
--- a/mail/panda-imap/Makefile
+++ b/mail/panda-imap/Makefile
@@ -3,6 +3,7 @@
PORTNAME= panda-imap
PORTVERSION= 20130621
+PORTREVISION= 1
CATEGORIES= mail ipv6
MAINTAINER= thierry@FreeBSD.org
@@ -31,6 +32,7 @@ ALL_TARGET= bsf
OPTIONS_DEFINE= SSL SSL_AND_PLAINTEXT DRAC NETSCAPE_BRAIN_DAMAGE DOCS
OPTIONS_DEFAULT= SSL
+OPTIONS_SUB= yes
SSL_DESC= Compile with SSL support
SSL_AND_PLAINTEXT_DESC= Allow plain text passwords and SSL
DRAC_DESC= Dynamically open MTA for relaying
@@ -92,32 +94,10 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/src/mailutil/mailutil.1 ${STAGEDIR}${PREFIX}/man/man1/
${INSTALL_MAN} ${WRKSRC}/src/tmail/tmail.1 ${STAGEDIR}${PREFIX}/man/man1/
-post-install:
- @${CAT} ${PKGMESSAGE}
-.if ${PORT_OPTIONS:MDRAC}
- @${ECHO} "================================================================================"
- @${ECHO} "To have DRAC working, you must create ${PREFIX}/etc/dracd.host, containing"
- @${ECHO} "the hostname of the DRAC server:"
- @${ECHO}
- @${ECHO} "localhost"
- @${ECHO} "================================================================================"
-.endif
-.if ${PORT_OPTIONS:MSSL}
- @${ECHO}
- @${ECHO} "To create and install a new SSL certificate for imapd and ipop3d, type \"make"
- @${ECHO} "cert\". Or install manually in ${PREFIX}/certs."
- @${ECHO}
- @${ECHO} "Example inetd config for SSL only services:"
- @${ECHO}
- @${ECHO} "pop3s stream tcp nowait root ${PREFIX}/libexec/ipop3d ipop3d"
- @${ECHO} "imaps stream tcp nowait root ${PREFIX}/libexec/imapd imapd"
- @${ECHO} "================================================================================"
-.endif
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} -m 0755 -p ${STAGEDIR}${DOCSDIR}
${TAR} -C ${WRKSRC}/docs -cf - . | \
(umask 022; ${TAR} -C ${STAGEDIR}${DOCSDIR} -xf -)
-.endif
cert:
${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/certs
diff --git a/mail/panda-imap/files/pkg-message.in b/mail/panda-imap/files/pkg-message.in
index 21f0badd3448..62b3f7d2c277 100644
--- a/mail/panda-imap/files/pkg-message.in
+++ b/mail/panda-imap/files/pkg-message.in
@@ -31,3 +31,18 @@ dir accessed.
WITHOUT_SSL - build without SSL/encryption support.
WITH_SSL_AND_PLAINTEXT - build with SSL/encryption support, but allow
non-encrypted logins.
+%%DRAC%%================================================================================
+%%DRAC%%To have DRAC working, you must create ${PREFIX}/etc/dracd.host, containing
+%%DRAC%%the hostname of the DRAC server:
+%%DRAC%%
+%%DRAC%%localhost
+%%DRAC%%================================================================================
+%%SSL%%
+%%SSL%%To create and install a new SSL certificate for imapd and ipop3d, type \"make
+%%SSL%%cert\". Or install manually in ${PREFIX}/certs.
+%%SSL%%
+%%SSL%%Example inetd config for SSL only services:
+%%SSL%%
+%%SSL%%pop3s stream tcp nowait root ${PREFIX}/libexec/ipop3d ipop3d
+%%SSL%%imaps stream tcp nowait root ${PREFIX}/libexec/imapd imapd
+%%SSL%%================================================================================
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index f213340965a2..9b1d2d9dad0a 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qpopper
PORTVERSION= 4.1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.qualcomm.com/eudora/servers/unix/popper/ \
http://core.ring.gr.jp/archives/net/mail/qpopper/
@@ -57,6 +57,7 @@ STANDALONE_MODE_DESC= build qpopper to be run without inetd
U_OPTION_DESC= include support for user .qpopper-options
OPTIONS_DEFAULT= APOP SSL U_OPTION
+OPTION_SUB= yes
.include <bsd.port.pre.mk>
@@ -176,14 +177,4 @@ post-install:
fi ; \
fi
-.if ${PORT_OPTIONS:MPOPPASSD}
- @${ECHO_MSG} ""
- @${ECHO_MSG} "==============================================================================="
- @${ECHO_MSG} "It adds for myself"
- @${ECHO_MSG} "/etc/devfs.conf:"
- @${ECHO_MSG} "link /dev/pts/0 pty0"
- @${ECHO_MSG} "==============================================================================="
- @${ECHO_MSG} ""
-.endif
-
.include <bsd.port.post.mk>
diff --git a/mail/qpopper/files/pkg-message.in b/mail/qpopper/files/pkg-message.in
index dcfd3ed808d3..0a9aa5207b54 100644
--- a/mail/qpopper/files/pkg-message.in
+++ b/mail/qpopper/files/pkg-message.in
@@ -4,3 +4,10 @@ To enable the qpopper-daemon, add the following line to your /etc/inetd.conf:
pop3 stream tcp nowait root %%PREFIX%%/libexec/qpopper qpopper -s
****************************************************************************
+%%POPPASSD%%
+%%POPPASSD%%===============================================================================
+%%POPPASSD%%It adds for myself
+%%POPPASSD%%/etc/devfs.conf:
+%%POPPASSD%%link /dev/pts/0 pty0
+%%POPPASSD%%===============================================================================
+%%POPPASSD%%
diff --git a/news/noffle/Makefile b/news/noffle/Makefile
index d0180dc95ff4..6564d53fee7a 100644
--- a/news/noffle/Makefile
+++ b/news/noffle/Makefile
@@ -21,6 +21,7 @@ LIBS+= -L${LOCALBASE}/lib
SPOOL_DIR= /var/spool/noffle
PLIST_SUB+= SPOOL_DIR=${SPOOL_DIR}
+SUB_FILES= pkg-message
DOCS= ChangeLog docs/FAQ INSTALL docs/INTERNALS README \
docs/testing.txt docs/noffle.lsm
@@ -51,7 +52,4 @@ do-install:
${STAGEDIR}${SPOOL_DIR}/requested
-post-install:
- ${SED} -e "s:/usr/local:${PREFIX}:g" ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/news/noffle/pkg-message b/news/noffle/files/pkg-message.in
index da487e076731..38a3ab92bbb1 100644
--- a/news/noffle/pkg-message
+++ b/news/noffle/files/pkg-message.in
@@ -2,6 +2,6 @@
****************************************************************************
To enable the noffle-daemon, add the following line to your /etc/inetd.conf:
-nntp stream tcp nowait news /usr/local/bin/noffle -r
+nntp stream tcp nowait news %%PREFIX%%/bin/noffle -r
****************************************************************************
diff --git a/sysutils/clockspeed/Makefile b/sysutils/clockspeed/Makefile
index 8438bcf2dfa7..63df995f1048 100644
--- a/sysutils/clockspeed/Makefile
+++ b/sysutils/clockspeed/Makefile
@@ -26,6 +26,8 @@ RC_SCRIPT_STARTUP_DIR= ${PREFIX}/etc/rc.d
OPTIONS_DEFINE= DOCS
+SUB_FILES= pkg-message
+
post-extract:
# get this port working under FreeBSD non-i386
@${INSTALL} ${FILESDIR}/tryclock_gettime.c ${WRKSRC}
@@ -62,9 +64,6 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${CLOCKSPEED_RC_SCRIPT_SAMPLE:T} \
${STAGEDIR}/${RC_SCRIPT_STARTUP_DIR}/${CLOCKSPEED_RC_SCRIPT_SAMPLE:T}
-post-install:
- @${SED} s!/usr/local/!${PREFIX}/! ${PKGMESSAGE}
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/INSTALL ${STAGEDIR}${DOCSDIR}
diff --git a/sysutils/clockspeed/pkg-message b/sysutils/clockspeed/files/pkg-message.in
index d7412ef02908..bb371d57c28d 100644
--- a/sysutils/clockspeed/pkg-message
+++ b/sysutils/clockspeed/files/pkg-message.in
@@ -1,6 +1,6 @@
ATTENTIONATTENTION:
-Please make sure that you read /usr/local/share/doc/clockspeed/INSTALL.
+Please make sure that you read %%PREFIX%%/share/doc/clockspeed/INSTALL.
It contains important information about testing and configuring
clockspeed, and finally installing it in your system.
@@ -15,13 +15,13 @@ PR ports/27617.
1) killall clockspeed (you can't have it running)
2) sntpclock IP.OF.NTP.SERVER | clockadd
3) enable/start clockspeed :
- % cp /usr/local/etc/rc.d/clockspeed.sh.sample \
- /usr/local/etc/rc.d/clockspeed.sh
+ % cp %%PREFIX%%/etc/rc.d/clockspeed.sh.sample \
+ %%PREFIX%%/etc/rc.d/clockspeed.sh
# enable clockspeed to automagically start next
# time you reboot. do this after testing everything
- % /usr/local/etc/rc.d/clockspeed.sh start
+ % %%PREFIX%%/etc/rc.d/clockspeed.sh start
# start clockspeed now
-4) sntpclock IP.OF.NTP.SERVER > /usr/local/etc/clockspeed/adjust
+4) sntpclock IP.OF.NTP.SERVER > %%PREFIX%%/etc/clockspeed/adjust
5) cd /usr/src/share/zoneinfo
6) make -DLEAPSECONDS clean all install ; make clean
diff --git a/sysutils/env4801/Makefile b/sysutils/env4801/Makefile
index 86e3148c3532..9881a5b08905 100644
--- a/sysutils/env4801/Makefile
+++ b/sysutils/env4801/Makefile
@@ -17,11 +17,12 @@ NO_WRKSUBDIR= yes
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= ${WRKSRC}
-RC_SCRIPTS_SUB= PREFIX=${PREFIX}
MAKE_ARGS= -DNOMAN
PLIST_FILES= sbin/env4801 etc/rc.d/env4801.sh
+SUB_FILES= env4801.sh pkg-message
+
OPTIONS_DEFINE= STATIC
OPTIONS_DEFAULT= STATIC
STATIC_DESC= Build a statically linked executable
@@ -33,15 +34,8 @@ post-patch:
@${REINPLACE_CMD} -e '/-static/d' ${WRKSRC}/Makefile
.endif
-post-extract:
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/env4801.sh > ${WRKSRC}/env4801.sh
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/env4801 ${STAGEDIR}${PREFIX}/sbin
- ${INSTALL_SCRIPT} ${WRKSRC}/env4801.sh ${STAGEDIR}${PREFIX}/etc/rc.d
-
-post-install:
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${PKGMESSAGE}
+ ${INSTALL_SCRIPT} ${WRKDIR}/env4801.sh ${STAGEDIR}${PREFIX}/etc/rc.d
.include <bsd.port.mk>
diff --git a/sysutils/env4801/files/env4801.sh b/sysutils/env4801/files/env4801.sh.in
index f49b07233f12..f49b07233f12 100644
--- a/sysutils/env4801/files/env4801.sh
+++ b/sysutils/env4801/files/env4801.sh.in
diff --git a/sysutils/env4801/pkg-message b/sysutils/env4801/files/pkg-message.in
index 0df42d546ea4..0df42d546ea4 100644
--- a/sysutils/env4801/pkg-message
+++ b/sysutils/env4801/files/pkg-message.in
diff --git a/www/b2evolution/Makefile b/www/b2evolution/Makefile
index 344ccd5b0275..84c0c3f5aa83 100644
--- a/www/b2evolution/Makefile
+++ b/www/b2evolution/Makefile
@@ -30,6 +30,9 @@ WARNING= ${PKGDIR}/pkg-warning
OPTIONS_DEFINE= MYSQL
OPTIONS_DEFAULT= MYSQL
+SUB_FILES= pkg-message
+SUB_LIST+= B2EVO_DIR=${B2EVO_DIR} B2EVO_URL=${B2EVO_URL}
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL}
@@ -54,9 +57,4 @@ do-install:
@${CP} -R ${WRKSRC}/ ${STAGEDIR}${PREFIX}/${B2EVO_DIR}
@${CHMOD} 665 ${STAGEDIR}${PREFIX}/${B2EVO_DIR}/blogs/conf/_config.php
-post-install:
- @${SED} -e 's|%%PREFIX%%|${PREFIX}|' \
- -e 's|%%B2EVO_DIR%%|${B2EVO_DIR}|; s|%%B2EVO_URL%%|${B2EVO_URL}|' \
- ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/www/b2evolution/pkg-message b/www/b2evolution/files/pkg-message.in
index 5d60ce340c84..5d60ce340c84 100644
--- a/www/b2evolution/pkg-message
+++ b/www/b2evolution/files/pkg-message.in
diff --git a/www/lilurl/Makefile b/www/lilurl/Makefile
index 7950c17c8c29..839707bfc8d2 100644
--- a/www/lilurl/Makefile
+++ b/www/lilurl/Makefile
@@ -19,7 +19,6 @@ WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
LILURL_DIR?= www/lilurl
-PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
PLIST= ${WRKDIR}/pkg-plist
@@ -39,8 +38,4 @@ do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${LILURL_DIR}
@${CP} -R ${WRKSRC}/ ${STAGEDIR}${PREFIX}/${LILURL_DIR}
-post-install:
- @${SED} -e 's,%%PREFIX%%,${PREFIX},; s,%%LILURL_DIR%%,${LILURL_DIR},g' \
- ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/www/lilurl/files/pkg-message.in b/www/lilurl/files/pkg-message.in
index 9da019a2de48..628a8d5b6639 100644
--- a/www/lilurl/files/pkg-message.in
+++ b/www/lilurl/files/pkg-message.in
@@ -10,12 +10,12 @@ you may have to follow this steps to make it work correctly:
# echo "GRANT ALL ON lilurl.* TO lilurluser@localhost IDENTIFIED BY 'lilurluser'; FLUSH PRIVILEGES;" | mysql
3. Import the default lilurl database:
-# mysql lilurl < %%PREFIX%%/%%LILURL_DIR%%/lilurl.sql
+# mysql lilurl < %%WWWDIR%%/lilurl.sql
-4. Copy %%PREFIX%%/%%LILURL_DIR%%/includes/conf.php.sample to %%PREFIX%%/%%LILURL_DIR%%/includes/conf.php
- Edit %%PREFIX%%/%%LILURL_DIR%%/includes/conf.php
+4. Copy %%WWWDIR%%/includes/conf.php.sample to %%WWWDIR%%/includes/conf.php
+ Edit %%WWWDIR%%/includes/conf.php
5. Add alias in apache config for the lilurl dir:
-Alias /lilurl "%%PREFIX%%/%%LILURL_DIR%%/"
+Alias /lilurl "%%WWWDIR%%/"
=======================================================================