aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--japanese/dserver/Makefile8
-rw-r--r--sysutils/bubblemon/Makefile8
-rw-r--r--sysutils/di/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/japanese/dserver/Makefile b/japanese/dserver/Makefile
index feebad907fab..4046d72bdd7a 100644
--- a/japanese/dserver/Makefile
+++ b/japanese/dserver/Makefile
@@ -24,6 +24,12 @@ COMMENT= CDROM dictionary server & clients
RUN_DEPENDS= jless:${PORTSDIR}/japanese/less
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
@@ -39,4 +45,4 @@ post-install:
@${INSTALL_DATA} ${FILESDIR}/README.FreeBSD-setup.euc ${PREFIX}/lib/dserver/doc/
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGREQ} ${PKGNAME} INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/bubblemon/Makefile b/sysutils/bubblemon/Makefile
index 1d71e74e2d89..76fdf0397237 100644
--- a/sysutils/bubblemon/Makefile
+++ b/sysutils/bubblemon/Makefile
@@ -17,6 +17,12 @@ COMMENT= Bubblemon is a system CPU and memory load monitor for the GNOME panel
LIB_DEPENDS= gtop.1:${PORTSDIR}/devel/libgtop
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomeprefix gnomehack libpanel
@@ -39,4 +45,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/di/Makefile b/sysutils/di/Makefile
index bd590661ff4b..61a5b282ca69 100644
--- a/sysutils/di/Makefile
+++ b/sysutils/di/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= http://www.gentoo.com/di/
MAINTAINER= bll@gentoo.com
COMMENT= A disk information utility
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
HAS_CONFIGURE= yes
MAN1= di.1
@@ -21,4 +27,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mi ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/di.1 ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>