aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/py-cassandra-driver/Makefile1
-rw-r--r--databases/py-cassandra-driver/files/patch-setup.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/databases/py-cassandra-driver/Makefile b/databases/py-cassandra-driver/Makefile
index 113bdd1dc3e8..4dc2b6b4f0a1 100644
--- a/databases/py-cassandra-driver/Makefile
+++ b/databases/py-cassandra-driver/Makefile
@@ -2,6 +2,7 @@
PORTNAME= cassandra-driver
DISTVERSION= 3.15.1
+PORTREVISION= 1
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/databases/py-cassandra-driver/files/patch-setup.py b/databases/py-cassandra-driver/files/patch-setup.py
new file mode 100644
index 000000000000..bd2f26010fd5
--- /dev/null
+++ b/databases/py-cassandra-driver/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2018-10-31 06:47:06 UTC
++++ setup.py
+@@ -395,7 +395,7 @@ def run_setup(extensions):
+ # 1.) build_ext eats errors at compile time, letting the install complete while producing useful feedback
+ # 2.) there could be a case where the python environment has cython installed but the system doesn't have build tools
+ if pre_build_check():
+- cython_dep = 'Cython>=0.20,!=0.25,<0.29'
++ cython_dep = 'Cython>=0.20,!=0.25,<0.30'
+ user_specified_cython_version = os.environ.get('CASS_DRIVER_ALLOWED_CYTHON_VERSION')
+ if user_specified_cython_version is not None:
+ cython_dep = 'Cython==%s' % (user_specified_cython_version,)