aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/ilbc/Makefile2
-rw-r--r--net/libilbc/Makefile26
-rw-r--r--net/libilbc/distinfo2
-rw-r--r--net/libilbc/pkg-descr8
-rw-r--r--net/libilbc/pkg-plist6
6 files changed, 45 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b69c2dc9ca01..b79dfebb05ba 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -322,6 +322,7 @@
SUBDIR += libfixbuf
SUBDIR += libgnetwork
SUBDIR += libgweather
+ SUBDIR += libilbc
SUBDIR += libkvkontakte
SUBDIR += libmediawiki
SUBDIR += libmms
diff --git a/net/ilbc/Makefile b/net/ilbc/Makefile
index 154e7d53581e..132c22410cf5 100644
--- a/net/ilbc/Makefile
+++ b/net/ilbc/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= http://simon.morlat.free.fr/download/1.2.x/source/
MAINTAINER= asm@asm.kiev.ua
COMMENT= Internet Low Bit Rate codec (RFC3951)
+CONFLICTS= libilbc-[0-9]*
+
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/net/libilbc/Makefile b/net/libilbc/Makefile
new file mode 100644
index 000000000000..65199af4b6ee
--- /dev/null
+++ b/net/libilbc/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= libilbc
+DISTVERSION= 1.1.1
+CATEGORIES= net
+
+MAINTAINER= mva@FreeBSD.org
+COMMENT= Internet Low Bit Rate codec (RFC3951)
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+CONFLICTS= ilbc-r[0-9]*
+
+USE_GITHUB= yes
+GH_ACCOUNT= dekkers
+GH_COMMIT= b5f9b10
+GH_TAGNAME= ${GH_COMMIT}
+
+USES= cmake
+USE_LDCONFIG= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|lib/$${CMAKE_LIBRARY_ARCHITECTURE}/pkgconfig|libdata/pkgconfig|' ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/net/libilbc/distinfo b/net/libilbc/distinfo
new file mode 100644
index 000000000000..4cea04ca1d53
--- /dev/null
+++ b/net/libilbc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libilbc-1.1.1.tar.gz) = 1f0cf2fa0ebaef300dbbe201a4cd4dc4661d6744fea37aa946080471de4161bd
+SIZE (libilbc-1.1.1.tar.gz) = 152937
diff --git a/net/libilbc/pkg-descr b/net/libilbc/pkg-descr
new file mode 100644
index 000000000000..0ff7634175b8
--- /dev/null
+++ b/net/libilbc/pkg-descr
@@ -0,0 +1,8 @@
+iLBC (internet Low Bitrate Codec) is a FREE speech codec suitable for robust
+voice communication over IP. The codec is designed for narrow band speech and
+results in a payload bit rate of 13.33 kbit/s with an encoding frame length
+of 30 ms and 15.20 kbps with an encoding length of 20 ms. The iLBC codec
+enables graceful speech quality degradation in the case of lost frames,
+which occurs in connection with lost or delayed IP packets.
+
+WWW: http://github.com/dekkers/libilbc
diff --git a/net/libilbc/pkg-plist b/net/libilbc/pkg-plist
new file mode 100644
index 000000000000..8a8757d7ce42
--- /dev/null
+++ b/net/libilbc/pkg-plist
@@ -0,0 +1,6 @@
+include/ilbc.h
+lib/libilbc.a
+lib/libilbc.so
+lib/libilbc.so.1
+lib/libilbc.so.1.1.1
+libdata/pkgconfig/libilbc.pc