aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/bsdstats/Makefile27
-rw-r--r--sysutils/bsdstats/files/300.statistics29
-rw-r--r--sysutils/bsdstats/files/300.statistics.in29
-rw-r--r--sysutils/bsdstats/files/pkg-message.in9
-rw-r--r--sysutils/bsdstats/pkg-descr8
-rw-r--r--sysutils/bsdstats/pkg-message9
7 files changed, 112 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index b3e1db856211..fbb094c4fca4 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -55,6 +55,7 @@
SUBDIR += bsd-splash-changer
SUBDIR += bsdadminscripts
SUBDIR += bsdsar
+ SUBDIR += bsdstats
SUBDIR += bubblemon-dockapp
SUBDIR += bubblemon2
SUBDIR += ccd2iso
diff --git a/sysutils/bsdstats/Makefile b/sysutils/bsdstats/Makefile
new file mode 100644
index 000000000000..13a661fa41ae
--- /dev/null
+++ b/sysutils/bsdstats/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: bsdstats
+# Date created: 5 August 2006
+# Whom: Marc G. Fournier <scrappy@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsdstats
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+DISTFILES=
+
+MAINTAINER= scrappy@freebsd.org
+COMMENT= Monthly script for reporting anonymous statistics about your machine
+
+NO_BUILD= yes
+PLIST_FILES= etc/periodic/monthly/300.statistics
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${MKDIR} ${LOCALBASE}/etc/periodic/monthly
+ ${CP} ${FILESDIR}/300.statistics ${LOCALBASE}/etc/periodic/monthly
+post-install:
+ ${CAT} pkg-message
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/bsdstats/files/300.statistics b/sysutils/bsdstats/files/300.statistics
new file mode 100644
index 000000000000..329a094e457f
--- /dev/null
+++ b/sysutils/bsdstats/files/300.statistics
@@ -0,0 +1,29 @@
+#!/bin/sh -
+#
+# $FreeBSD: /tmp/pcvs/ports/sysutils/bsdstats/files/Attic/300.statistics,v 1.1 2006-08-06 03:34:08 scrappy Exp $
+#
+
+# If there is a global system configuration file, suck it in.
+#
+monthly_statistics_mailto="scrappy@hub.org,root"
+if [ -r /etc/defaults/periodic.conf ]
+then
+ . /etc/defaults/periodic.conf
+ source_periodic_confs
+fi
+
+oldmask=$(umask)
+umask 066
+
+case "$monthly_statistics_enable" in
+ [Yy][Ee][Ss])
+ HN=`/bin/hostname`
+ SYS=`/usr/bin/uname -r`
+ ARCH=`/usr/bin/uname -m`
+ /usr/bin/fetch -qo /tmp/getid http://bsdstats.hub.org/scripts/getid.php?hn=$HN\&sys=$SYS\&arch=$ARCH
+ ;;
+ *) rc=0;;
+esac
+
+umask $oldmask
+exit $rc
diff --git a/sysutils/bsdstats/files/300.statistics.in b/sysutils/bsdstats/files/300.statistics.in
new file mode 100644
index 000000000000..8ba6cd4f8ceb
--- /dev/null
+++ b/sysutils/bsdstats/files/300.statistics.in
@@ -0,0 +1,29 @@
+#!/bin/sh -
+#
+# $FreeBSD: /tmp/pcvs/ports/sysutils/bsdstats/files/300.statistics.in,v 1.1 2006-08-06 03:34:08 scrappy Exp $
+#
+
+# If there is a global system configuration file, suck it in.
+#
+monthly_statistics_mailto="scrappy@hub.org,root"
+if [ -r /etc/defaults/periodic.conf ]
+then
+ . /etc/defaults/periodic.conf
+ source_periodic_confs
+fi
+
+oldmask=$(umask)
+umask 066
+
+case "$monthly_statistics_enable" in
+ [Yy][Ee][Ss])
+ HN=`/bin/hostname`
+ SYS=`/usr/bin/uname -r`
+ ARCH=`/usr/bin/uname -m`
+ /usr/bin/fetch -qo /tmp/getid http://bsdstats.hub.org/scripts/getid.php?hn=$HN\&sys=$SYS\&arch=$ARCH
+ ;;
+ *) rc=0;;
+esac
+
+umask $oldmask
+exit $rc
diff --git a/sysutils/bsdstats/files/pkg-message.in b/sysutils/bsdstats/files/pkg-message.in
new file mode 100644
index 000000000000..639b8b405814
--- /dev/null
+++ b/sysutils/bsdstats/files/pkg-message.in
@@ -0,0 +1,9 @@
+
+********************
+To enable the port, edit or create /etc/periodic.conf and add this line:
+ monthly_statistics_enable=yes
+
+To run it manually the first time, just run it as:
+ /usr/local/etc/periodic/monthly/300.statistics
+********************
+
diff --git a/sysutils/bsdstats/pkg-descr b/sysutils/bsdstats/pkg-descr
new file mode 100644
index 000000000000..089e68f7fa12
--- /dev/null
+++ b/sysutils/bsdstats/pkg-descr
@@ -0,0 +1,8 @@
+The purpose of this port is to attempt to produce reasonably accurate
+statistics on FreeBSD deployment, to be used for both marketing, and
+advocacy purposes by the project.
+
+The major problem that we are trying to address is vendors who do not
+feel that FreeBSD presents enough of a market to bother supporting.
+
+WWW: http://bsdstats.hub.org
diff --git a/sysutils/bsdstats/pkg-message b/sysutils/bsdstats/pkg-message
new file mode 100644
index 000000000000..639b8b405814
--- /dev/null
+++ b/sysutils/bsdstats/pkg-message
@@ -0,0 +1,9 @@
+
+********************
+To enable the port, edit or create /etc/periodic.conf and add this line:
+ monthly_statistics_enable=yes
+
+To run it manually the first time, just run it as:
+ /usr/local/etc/periodic/monthly/300.statistics
+********************
+