aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/pioneer/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/pioneer/Makefile b/games/pioneer/Makefile
index 2855898e3ead..803dec5011bb 100644
--- a/games/pioneer/Makefile
+++ b/games/pioneer/Makefile
@@ -4,7 +4,7 @@
PORTNAME= pioneer
PORTVERSION= 0.0.${GH_TAGNAME}
CATEGORIES= games
-MASTER_SITES= http://github.com/${GH_ACCOUNT}/${GH_PROJECT}/archive/${GH_TAGNAME}.tar.gz?dummy=/
+MASTER_SITES= http://github.com/${GH_ACCOUNT}/${GH_PROJECT}/archive/${GH_TAGNAME}${EXTRACT_SUFX}?dummy=/
MAINTAINER= lightside@gmx.com
COMMENT= Space adventure game set in the Milky Way galaxy
@@ -92,6 +92,9 @@ post-patch: .SILENT
${WRKSRC}/configure.ac
${REINPLACE_CMD} -e 's/modelviewer/${PORTNAME} -modelviewer/' \
${WRKSRC}/Modelviewer.txt
+# Use "unsigned int" type for std::max matching function
+ ${REINPLACE_CMD} -e 's/int m_atlasVIncrement/unsigned &/' \
+ ${WRKSRC}/src/text/TextureFont.h
.if !${PORT_OPTIONS:MMODELCOMPILER}
${REINPLACE_CMD} -e 's/pioneer modelcompiler/pioneer/' \
${WRKSRC}/src/Makefile.am