aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/simgear/Makefile7
-rw-r--r--games/flightgear/Makefile7
2 files changed, 12 insertions, 2 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index f1e710ffe67a..a4b5991f6fe0 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -19,9 +19,14 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
jpeg.9:${PORTSDIR}/graphics/jpeg \
alut.1:${PORTSDIR}/audio/freealut \
- osg.48:${PORTSDIR}/graphics/osg \
boost_thread.4:${PORTSDIR}/devel/boost
+.if defined(WITH_OSG_DEVEL)
+LIB_DEPENDS+= osg.54:${PORTSDIR}/graphics/osg-devel
+.else
+LIB_DEPENDS+= osg.48:${PORTSDIR}/graphics/osg
+.endif
+
USE_XORG= ice sm x11 xext xi xt xmu
USE_GL= gl glu glut
GNU_CONFIGURE= yes
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index c2feaaaf213a..52ad92713ae8 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -22,7 +22,6 @@ MAINTAINER= ganael.laplanche@martymac.com
COMMENT= The FlightGear flight simulator
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
- osg.48:${PORTSDIR}/graphics/osg \
boost_thread.4:${PORTSDIR}/devel/boost
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear
@@ -30,6 +29,12 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear \
${LOCALBASE}/share/FlightGear/version:${PORTSDIR}/games/flightgear-data
+.if defined(WITH_OSG_DEVEL)
+LIB_DEPENDS+= osg.54:${PORTSDIR}/graphics/osg-devel
+.else
+LIB_DEPENDS+= osg.48:${PORTSDIR}/graphics/osg
+.endif
+
USE_XORG= ice sm x11 xext xi xt xmu
USE_GL= gl glu glut
USE_GMAKE= yes