aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/xvkbd/Makefile42
-rw-r--r--x11/xvkbd/distinfo4
-rw-r--r--x11/xvkbd/files/patch-xvkbd.man69
3 files changed, 59 insertions, 56 deletions
diff --git a/x11/xvkbd/Makefile b/x11/xvkbd/Makefile
index a6b6968278f8..ce4f2f033420 100644
--- a/x11/xvkbd/Makefile
+++ b/x11/xvkbd/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xvkbd
-PORTVERSION= 3.6
+PORTVERSION= 3.7
CATEGORIES= x11
MASTER_SITES= http://homepage3.nifty.com/tsato/xvkbd/
@@ -11,37 +11,35 @@ COMMENT= Virtual keyboard for X applications
LICENSE= GPLv2 # (or later)
-OPTIONS_DEFINE= XAW3D XTEST NLS DOCS
-OPTIONS_DEFAULT= XTEST
-XAW3D_DESC= Xaw3d widget library support
-XTEST_DESC= XTEST extensions support
-
USES= imake
USE_XORG= ice sm x11 xaw xext xmu xpm xt
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MXAW3D}
-LIB_DEPENDS+= libXaw3d.so:${PORTSDIR}/x11-toolkits/Xaw3d
-XK_DEFSUBST+= -e 's/XCOMM define XAW3d/\#define XAW3d/;'
-.endif
+DESKTOP_ENTRIES="Xvkbd" "" "" "xvkbd" "Utility;" false
-.if ${PORT_OPTIONS:MXTEST}
-USE_XORG+= xtst
-XK_DEFSUBST+= -e 's/XCOMM define XTEST/\#define XTEST/;'
-.endif
+OPTIONS_DEFINE= DOCS NLS XAW3D XTEST
+OPTIONS_DEFAULT= XTEST
-.if ${PORT_OPTIONS:MNLS}
-XK_DEFSUBST+= -e 's/XCOMM define I18N/\#define I18N/;'
-.endif
+XAW3D_DESC= Xaw3d widget library support
+XAW3D_LIB_DEPENDS= libXaw3d.so:${PORTSDIR}/x11-toolkits/Xaw3d
+XTEST_DESC= XTEST extensions support
+XTEST_USE= xorg=xtst
post-patch:
-.if defined(XK_DEFSUBST)
- @${REINPLACE_CMD} ${XK_DEFSUBST} ${WRKSRC}/Imakefile
-.endif
@${REINPLACE_CMD} -e \
's|/usr/include/|${LOCALBASE}/include/|' ${WRKSRC}/XVkbd-small.ad
+post-patch-NLS-on:
+ @${REINPLACE_CMD} -e \
+ '/define I18N/s|^XCOMM |#|' ${WRKSRC}/Imakefile
+
+post-patch-XAW3D-on:
+ @${REINPLACE_CMD} -e \
+ '/define XAW3D/s|^XCOMM |#|' ${WRKSRC}/Imakefile
+
+post-patch-XTEST-on:
+ @${REINPLACE_CMD} -e \
+ '/define XTEST/s|^XCOMM |#|' ${WRKSRC}/Imakefile
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} README ${STAGEDIR}${DOCSDIR})
diff --git a/x11/xvkbd/distinfo b/x11/xvkbd/distinfo
index 2bc516930375..17903b13a99d 100644
--- a/x11/xvkbd/distinfo
+++ b/x11/xvkbd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xvkbd-3.6.tar.gz) = 2678541c23336a0795bf5684c9f38d382a6566e6509794a39952d6da47da5bae
-SIZE (xvkbd-3.6.tar.gz) = 81613
+SHA256 (xvkbd-3.7.tar.gz) = 895f768269820e7c0379b0daac3687bda0c670d192ebb7e61e5613a5939ec90b
+SIZE (xvkbd-3.7.tar.gz) = 81645
diff --git a/x11/xvkbd/files/patch-xvkbd.man b/x11/xvkbd/files/patch-xvkbd.man
index 857f4053083f..c15c03a286b0 100644
--- a/x11/xvkbd/files/patch-xvkbd.man
+++ b/x11/xvkbd/files/patch-xvkbd.man
@@ -3,7 +3,7 @@ Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2015-05-07
---- xvkbd.man.orig 2015-02-14 12:28:00 UTC
+--- xvkbd.man.orig 2015-09-12 07:21:58 UTC
+++ xvkbd.man
@@ -29,7 +29,7 @@ which may make it easier to enter long w
.PP
@@ -173,15 +173,15 @@ Last-Update: 2015-05-07
and terminate soon after sending the string.
.TP 4
-.B "-utf16"
+- When used with \fB-file\fP option,
+.B "\-utf16"
- When used with \fB-file\fP option,
++ When used with \fB\-file\fP option,
make \fIxvkbd\fP to accept UTF16 characters in the file.
.TP 4
-.BI "-delay " value
--Put \fIvalue\fP ms of delay for evey characters
--when sending characters with \fB-text\fP or \fB-file\fP.
+.BI "\-delay " value
-+Put \fIvalue\fP ms of delay for evey character
+ Put \fIvalue\fP ms of delay for evey characters
+-when sending characters with \fB-text\fP or \fB-file\fP.
+when sending characters with \fB\-text\fP or \fB\-file\fP.
Maybe this is useful when problem arises when characters are entered too fast.
.sp 0.5
@@ -283,7 +283,7 @@ Last-Update: 2015-05-07
to apply this for those four modifiers.
Maybe this can be useful when attempting to decorate
the mouse operations with the modifiers.
-@@ -524,97 +524,97 @@ and which can prevent the correct operat
+@@ -524,101 +524,101 @@ and which can prevent the correct operat
.sp 0.5
Resource `\fBxvkbd.positiveModifiers: \fP\fImodifiers...\fP' has the same function.
.TP 4
@@ -398,18 +398,23 @@ Last-Update: 2015-05-07
.SH "Download"
.TP 4
\fILatest Official Release\fP
--\fIhttp://homepage3.nifty.com/tsato/xvkbd/xvkbd-3.6.tar.gz\fP
-+\fIhttp://homepage3.nifty.com/tsato/xvkbd/xvkbd\-3.6.tar.gz\fP
+-\fIhttp://homepage3.nifty.com/tsato/xvkbd/xvkbd-3.7.tar.gz\fP
++\fIhttp://homepage3.nifty.com/tsato/xvkbd/xvkbd\-3.7.tar.gz\fP
.br
- - source of version 3.6 (2015-02-15)
+ - source of version 3.7 (2015-09-12)
.TP 4
previous release
+-http://homepage3.nifty.com/tsato/xvkbd/xvkbd-3.6.tar.gz
++http://homepage3.nifty.com/tsato/xvkbd/xvkbd\-3.6.tar.gz
+ .br
+ - source of version 3.6 (2015-02-15)
+ .sp 0.5
-http://homepage3.nifty.com/tsato/xvkbd/xvkbd-3.5.tar.gz
+http://homepage3.nifty.com/tsato/xvkbd/xvkbd\-3.5.tar.gz
.br
- source of version 3.5 (2013-07-15)
.PP
-@@ -651,8 +651,8 @@ load them via \fIxrdb\fP(1), or
+@@ -655,8 +655,8 @@ load them via \fIxrdb\fP(1), or
.IP " o " 4
set the filename to the \fB$XENVIRONMENT\fP environment variable, or
.IP " o " 4
@@ -420,7 +425,7 @@ Last-Update: 2015-05-07
.IP " o " 4
put them in application default directory as \fBXVkbd\fP.
.PP
-@@ -664,11 +664,11 @@ directories specified with \fB$XUSERFILE
+@@ -668,11 +668,11 @@ directories specified with \fB$XUSERFILE
system's application default directory specified with
\fB$XFILESEACHPATH\fP environment variable,
or else the directory specified when compiling the X
@@ -434,7 +439,7 @@ Last-Update: 2015-05-07
near top of the file.
.PP
\fIxvkbd\fP is distributed with some application default files,
-@@ -699,7 +699,7 @@ You may also want to set:
+@@ -703,7 +703,7 @@ You may also want to set:
to display only the labels for the current shift state,
instead of trying to always display all of them in the small keytop.
.PP
@@ -443,7 +448,7 @@ Last-Update: 2015-05-07
.SH " Removing Unwanted Keys"
Keys on \fIxvkbd\fP window can be removed by setting their width to 1.
-@@ -773,12 +773,12 @@ when \fBxvkbd.modalKeytop\fP resoruce is
+@@ -777,12 +777,12 @@ when \fBxvkbd.modalKeytop\fP resoruce is
In all of those resources, each keys are separated by spaces,
and rows of keys are terminated with `\fB \\n\\\fP'
(note that `\fB\\n\fP' must have space before it).
@@ -459,7 +464,7 @@ Last-Update: 2015-05-07
will make \fIxvkbd\fP to use the German layout.
For another method to activate those settings, please refer
"How to Customize \fIxvkbd\fP" above.
-@@ -840,7 +840,7 @@ You can use \fBxev\fP command to check w
+@@ -844,7 +844,7 @@ You can use \fBxev\fP command to check w
.IP " o " 4
If \fIAlt\fP or \fIMeta\fP is not defined as modifier,
the key can't be used as modifier.
@@ -468,7 +473,7 @@ Last-Update: 2015-05-07
.IP " o " 4
\fINum Lock\fP (and maybe other modifiers) on the physical keyboard
may not work correctly when \fIxvkbd\fP is in use.
-@@ -851,10 +851,10 @@ FAQ - Possible Problems and Solutions
+@@ -855,10 +855,10 @@ FAQ - Possible Problems and Solutions
http://homepage3.nifty.com/tsato/xvkbd/faq.html
.TP 4
Making your own completion dictionary
@@ -482,7 +487,7 @@ Last-Update: 2015-05-07
.TP 4
Note about how to send key events
http://homepage3.nifty.com/tsato/xvkbd/events.html
-@@ -875,26 +875,26 @@ which can't be entered directly from key
+@@ -879,26 +879,26 @@ which can't be entered directly from key
can be entered using dedicated key combinations.
.IP " - " 6
Make keyboard layout not to be disturbed when
@@ -514,7 +519,7 @@ Last-Update: 2015-05-07
.IP " - " 6
\fIxvkbd\fP can now send keys
with \fIMode_switch\fP (\fIAltGr\fP) modifier,
-@@ -902,9 +902,9 @@ which enables those characters in the po
+@@ -906,9 +906,9 @@ which enables those characters in the po
.IP " - " 6
\fIxvkbd\fP now support \fIAltGr\fP key
so that German (and some other) keyboard layout can be used.
@@ -526,7 +531,7 @@ Last-Update: 2015-05-07
in the distribution, which modifies keyboard layout
and put some non-ASCII keys on the \fIxvkbd\fP window.
.IP " - " 6
-@@ -920,7 +920,7 @@ Labels on keys can now be set independen
+@@ -924,7 +924,7 @@ Labels on keys can now be set independen
not shifted, \fIShift\fP, \fIAltGr\fP and \fIShift\fP-\fIAltGr\fP.
(thanks, Jim)
.IP " - " 6
@@ -535,7 +540,7 @@ Last-Update: 2015-05-07
.TP 4
Version 1.2 (2001-02-18)
.IP " - " 6
-@@ -948,7 +948,7 @@ so that it will not terminated accidentl
+@@ -952,7 +952,7 @@ so that it will not terminated accidentl
.TP 4
Version 1.3 (2001-03-19)
.IP " - " 6
@@ -544,7 +549,7 @@ Last-Update: 2015-05-07
(contributed from Marcel Portner)
.IP " - " 6
\fIxvkbd\fP now catches MappingNotify event and reload the new mapping.
-@@ -998,7 +998,7 @@ and older \fIxvkbd\fP may not work corre
+@@ -1002,7 +1002,7 @@ and older \fIxvkbd\fP may not work corre
.TP 4
Version 1.6 (2001-11-10)
.IP " - " 6
@@ -553,7 +558,7 @@ Last-Update: 2015-05-07
(thanks, Gregory)
.IP " - " 6
New entry `\fIUse XTEST Extension?\fP' is added
-@@ -1017,7 +1017,7 @@ after \fIxvkbd\fP is invoked.
+@@ -1021,7 +1021,7 @@ after \fIxvkbd\fP is invoked.
Show/hide of the keypad and funcion keys on the main window
can now be toggled from the main menu.
.IP " - " 6
@@ -562,7 +567,7 @@ Last-Update: 2015-05-07
(contributed from Jean-Pierre Demailly)
.TP 4
Version 2.1 (2002-01-27)
-@@ -1025,9 +1025,9 @@ Version 2.1 (2002-01-27)
+@@ -1029,9 +1029,9 @@ Version 2.1 (2002-01-27)
When height of the \fIxvkbd\fP window is smaller than
\fBXVkbd.modalThreshold\fP,
\fIxvkbd\fP will now automatically switch the keytop
@@ -574,7 +579,7 @@ Last-Update: 2015-05-07
would send wrong keys - this problem is now fixed.
.IP " - " 6
Target \fBdistclean\fP in the \fBImakefile\fP is renamed
-@@ -1040,8 +1040,8 @@ Version 2.2 (2002-03-17)
+@@ -1044,8 +1044,8 @@ Version 2.2 (2002-03-17)
String assigned to function keys can now be edited on a panel popped up via
"\fIEdit Function Keys...\fP" in the main menu.
.IP " - " 6
@@ -585,7 +590,7 @@ Last-Update: 2015-05-07
its standard input (stdin) to get the string to be sent.
.IP " - " 6
In the previous release,
-@@ -1070,7 +1070,7 @@ Swiss/German,
+@@ -1074,7 +1074,7 @@ Swiss/German,
United Kingdom
and Latin-1.
.IP " - " 6
@@ -594,7 +599,7 @@ Last-Update: 2015-05-07
- this problem is now fixed.
.TP 4
Version 2.4 (2002-10-02)
-@@ -1131,24 +1131,24 @@ Yet another Japanese keyboard layout, JI
+@@ -1135,24 +1135,24 @@ Yet another Japanese keyboard layout, JI
.IP " - " 6
It is now possible to minimize (iconify) the main window
even if no window manager is in use.
@@ -626,7 +631,7 @@ Last-Update: 2015-05-07
and maybe useful when run \fIxvkbd\fP from a display manager.
.TP 4
Version 2.7a (2005-05-07)
-@@ -1164,17 +1164,17 @@ where we must use \fIISO_Level3_Shift\fP
+@@ -1168,17 +1168,17 @@ where we must use \fIISO_Level3_Shift\fP
Reference to the target bitmap is changed from
\fB/usr/X11R6/include/X11/bitmaps/target\fP to \fB/usr/include/X11/bitmaps/target\fP.
.IP " - " 6
@@ -648,7 +653,7 @@ Last-Update: 2015-05-07
via \fB\\x\fP, \fB\\y\fP and \fB\\m\fP special sequences.
.TP 4
Version 3.0 (2008-05-05)
-@@ -1189,7 +1189,7 @@ Version 3.1 (2010-01-17)
+@@ -1193,7 +1193,7 @@ Version 3.1 (2010-01-17)
.IP " - " 6
Changed the default setting for automatic click to OFF, which was set ON in the previous release in error and caused confusion.
.IP " - " 6
@@ -657,7 +662,7 @@ Last-Update: 2015-05-07
.IP " - " 6
Up to 25x25 keys can now be supported both for the main keyboard and the keypad.
.IP " - " 6
-@@ -1197,7 +1197,7 @@ Able to open the keypad panel when start
+@@ -1201,7 +1201,7 @@ Able to open the keypad panel when start
.IP " - " 6
Fixed errors in some keyboard layout files (Korean, Slovene, UK).
.IP " - " 6
@@ -666,7 +671,7 @@ Last-Update: 2015-05-07
.TP 4
Version 3.2 (2010-03-14)
.IP " - " 6
-@@ -1208,10 +1208,10 @@ New option `\fIBehave as Toolbar Window?
+@@ -1212,10 +1212,10 @@ New option `\fIBehave as Toolbar Window?
`\fIAlways on Top\fP' will work rather better with window managers
which support extended window manager hint \fB_NET_WM_STATE_ABOVE\fP.
.IP " - " 6
@@ -679,7 +684,7 @@ Last-Update: 2015-05-07
`\fB*\fP' and `\fB?\fP'.
.IP " - " 6
Word completion dictionary file to be used with `\fIWord Completion...\fP'
-@@ -1220,18 +1220,18 @@ Word completion dictionary file to be us
+@@ -1224,18 +1224,18 @@ Word completion dictionary file to be us
Only the words which have two or more characters will be appeared
in the word completion list.
.IP " - " 6
@@ -701,7 +706,7 @@ Last-Update: 2015-05-07
the specified display when startup.
.IP " - " 6
Bug fixed: \fBKP_0\fP now works.
-@@ -1247,7 +1247,7 @@ as it seems delay of 0 caused problems i
+@@ -1251,7 +1251,7 @@ as it seems delay of 0 caused problems i
ISO_Left_Tab is assigned to the shifted position of the Tab key on the \fIxvkbd\fP window,
so that Shift-Tab can be simulated.
.IP " - " 6
@@ -710,7 +715,7 @@ Last-Update: 2015-05-07
.TP 4
Version 3.5 (2013-07-15)
.IP " - " 6
-@@ -1258,8 +1258,8 @@ Fixed a problem that "Always on Top" not
+@@ -1262,8 +1262,8 @@ Fixed a problem that "Always on Top" not
.TP 4
Version 3.6 (2015-02-15)
.IP " - " 6