aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/libopennet/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/net/libopennet/Makefile b/net/libopennet/Makefile
index eef0afff3d6f..8c20ceb4db2c 100644
--- a/net/libopennet/Makefile
+++ b/net/libopennet/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libopennet
PORTVERSION= 0.9.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.rkeene.org/files/oss/libopennet/ \
http://www.cs.nctu.edu.tw/~gslin/files/
@@ -10,9 +11,16 @@ MASTER_SITES= http://www.rkeene.org/files/oss/libopennet/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for opening files over a network
+LICENSE= LGPL21 GPLv2 # net.c header mentions GPL
+LICENSE_COMB= multi
+LICENSE_FILE_LGPL21= ${WRKSRC}/LICENSE
+
GNU_CONFIGURE= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
USES= gmake
USE_LDCONFIG= yes
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libopennet.so
+
.include <bsd.port.mk>