aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-themes/Makefile1
-rw-r--r--x11-themes/linux-gtk-bluecurve-theme/Makefile40
-rw-r--r--x11-themes/linux-gtk-bluecurve-theme/distinfo2
-rw-r--r--x11-themes/linux-gtk-bluecurve-theme/pkg-descr9
-rw-r--r--x11-themes/linux-gtk-bluecurve-theme/pkg-plist7
5 files changed, 59 insertions, 0 deletions
diff --git a/x11-themes/Makefile b/x11-themes/Makefile
index f39e3a7f5258..f40f592f8114 100644
--- a/x11-themes/Makefile
+++ b/x11-themes/Makefile
@@ -91,6 +91,7 @@
SUBDIR += lila-xfce4-panel
SUBDIR += lila-xffm
SUBDIR += lila-xfwm4
+ SUBDIR += linux-gtk-bluecurve-theme
SUBDIR += metacity-aluminumalloy-cryogenic-theme
SUBDIR += metacity-aluminumalloy-smog-theme
SUBDIR += metacity-aluminumalloy-toxic-theme
diff --git a/x11-themes/linux-gtk-bluecurve-theme/Makefile b/x11-themes/linux-gtk-bluecurve-theme/Makefile
new file mode 100644
index 000000000000..0564675b311c
--- /dev/null
+++ b/x11-themes/linux-gtk-bluecurve-theme/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: linux-gtk-bluecurve-theme
+# Date created: 19 Jun 2004
+# Whom: Jean-Yves lefort
+#
+# $FreeBSD$
+#
+
+PORTNAME= linux-gtk-bluecurve-theme
+PORTVERSION= 0.73
+CATEGORIES= x11-themes
+MASTER_SITES= ftp://fr.rpmfind.net/linux/redhat/9/en/os/${MACHINE_ARCH}/RedHat/RPMS/
+DISTFILES= redhat-artwork-${PORTVERSION}-1.${MACHINE_ARCH}.rpm
+DIST_SUBDIR= rpm
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= Bluecurve theme for GTK1 and GTK2 from RedHat 8.0 (Linux version)
+
+EXTRACT_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
+
+NO_WRKSUBDIR= yes
+USE_LINUX_PREFIX= yes
+NO_BUILD= yes
+ONLY_FOR_ARCHS= i386
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @cd ${WRKDIR}; rpm2cpio ${_DISTDIR}/${DISTFILES} | ${CPIO} -id --quiet
+
+do-install:
+ @${MKDIR} ${PREFIX}/usr/share/themes/Bluecurve && ${CHMOD} a+rx ${PREFIX}/usr/share/themes/Bluecurve
+ @${MKDIR} ${PREFIX}/usr/lib/gtk-2.0/2.2.0/engines && ${CHMOD} a+rx ${PREFIX}/usr/lib/gtk-2.0/2.2.0/engines
+ @${MKDIR} ${PREFIX}/usr/share/themes/Bluecurve/gtk-2.0 && ${CHMOD} a+rx ${PREFIX}/usr/share/themes/Bluecurve/gtk-2.0
+ @${INSTALL_DATA} ${WRKSRC}/usr/lib/gtk-2.0/2.2.0/engines/libbluecurve.so ${PREFIX}/usr/lib/gtk-2.0/2.2.0/engines
+ @${INSTALL_DATA} ${WRKSRC}/usr/share/themes/Bluecurve/gtk-2.0/gtkrc ${PREFIX}/usr/share/themes/Bluecurve/gtk-2.0
+ @${MKDIR} ${PREFIX}/usr/lib/gtk/themes/engines && ${CHMOD} a+rx ${PREFIX}/usr/lib/gtk/themes/engines
+ @${INSTALL_DATA} ${WRKSRC}/usr/lib/gtk/themes/engines/libbluecurve.so ${PREFIX}/usr/lib/gtk/themes/engines
+ @${MKDIR} ${PREFIX}/usr/share/themes/Bluecurve/gtk && ${CHMOD} a+rx ${PREFIX}/usr/share/themes/Bluecurve/gtk
+ @${INSTALL_DATA} ${WRKSRC}/usr/share/themes/Bluecurve/gtk/gtkrc ${PREFIX}/usr/share/themes/Bluecurve/gtk
+
+.include <bsd.port.mk>
diff --git a/x11-themes/linux-gtk-bluecurve-theme/distinfo b/x11-themes/linux-gtk-bluecurve-theme/distinfo
new file mode 100644
index 000000000000..9be5ddd3d2cf
--- /dev/null
+++ b/x11-themes/linux-gtk-bluecurve-theme/distinfo
@@ -0,0 +1,2 @@
+MD5 (rpm/redhat-artwork-0.73-1.i386.rpm) = c2ad53b9aea12f2b70d995e5e330ce32
+SIZE (rpm/redhat-artwork-0.73-1.i386.rpm) = 7939141
diff --git a/x11-themes/linux-gtk-bluecurve-theme/pkg-descr b/x11-themes/linux-gtk-bluecurve-theme/pkg-descr
new file mode 100644
index 000000000000..13389eff5835
--- /dev/null
+++ b/x11-themes/linux-gtk-bluecurve-theme/pkg-descr
@@ -0,0 +1,9 @@
+This is a port of RedHat 8.0 "Bluecurve" theme for GTK/GNOME.
+It won't install RedHat logos and pixmaps, but only the required
+theme engines.
+
+This is the Linux version, for use with x11-toolkits/linux-gtk and
+x11-toolkits/linux-gtk2.
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/x11-themes/linux-gtk-bluecurve-theme/pkg-plist b/x11-themes/linux-gtk-bluecurve-theme/pkg-plist
new file mode 100644
index 000000000000..ba234ce46b4d
--- /dev/null
+++ b/x11-themes/linux-gtk-bluecurve-theme/pkg-plist
@@ -0,0 +1,7 @@
+usr/lib/gtk/themes/engines/libbluecurve.so
+usr/lib/gtk-2.0/2.2.0/engines/libbluecurve.so
+usr/share/themes/Bluecurve/gtk/gtkrc
+usr/share/themes/Bluecurve/gtk-2.0/gtkrc
+@dirrm usr/share/themes/Bluecurve/gtk
+@dirrm usr/share/themes/Bluecurve/gtk-2.0
+@dirrm usr/share/themes/Bluecurve