aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/atunes/Makefile4
-rw-r--r--audio/rubyripper/Makefile2
-rw-r--r--devel/antlrworks/Makefile4
-rw-r--r--devel/upp/Makefile2
-rw-r--r--editors/omegaT/Makefile4
-rw-r--r--games/gtklife/Makefile4
-rw-r--r--games/ioquake3/Makefile4
-rw-r--r--games/meandmyshadow/Makefile2
-rw-r--r--games/pouetchess/Makefile4
-rw-r--r--games/redeclipse/Makefile6
-rw-r--r--games/scummvm/Makefile2
-rw-r--r--games/vor/Makefile2
-rw-r--r--graphics/kudu/Makefile2
-rw-r--r--math/saga/Makefile2
-rw-r--r--misc/tvbrowser/Makefile6
-rw-r--r--multimedia/gmencoder/Makefile4
-rw-r--r--net-im/mercury/Makefile2
-rw-r--r--www/kompozer/Makefile2
-rw-r--r--www/links-hacked/Makefile4
-rw-r--r--www/rssowl/Makefile6
20 files changed, 34 insertions, 34 deletions
diff --git a/audio/atunes/Makefile b/audio/atunes/Makefile
index e77eb89aa6a6..5f5c41ec6718 100644
--- a/audio/atunes/Makefile
+++ b/audio/atunes/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/aTunes%20${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
MAINTAINER= lme@FreeBSD.org
-COMMENT= A full-featured audio player and manager developed in Java
+COMMENT= Full-featured audio player and manager developed in Java
NO_BUILD= yes
USE_JAVA= yes
@@ -65,7 +65,7 @@ RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
DESKTOP_ENTRIES="aTunes" \
"Audio player and manager" \
- "${DATADIR}/aTunes.ico" \
+ "${PREFIX}/share/pixmaps/atunes.png" \
"aTunes" \
"Audio;AudioVideo;Java;" \
true
diff --git a/audio/rubyripper/Makefile b/audio/rubyripper/Makefile
index 1863ac68b982..f51b62e20b32 100644
--- a/audio/rubyripper/Makefile
+++ b/audio/rubyripper/Makefile
@@ -31,7 +31,7 @@ USE_RUBY= yes
INSTALLS_ICONS= yes
DESKTOP_ENTRIES="Rubyripper" "Secure Audio Disc Ripper" \
- "${PORTNAME}.png" "rrip_gtk2" "Audio;AudioVideo;" false
+ "${PORTNAME}" "rrip_gtk2" "Audio;AudioVideo;" false
post-patch:
# fix an apparent typo
diff --git a/devel/antlrworks/Makefile b/devel/antlrworks/Makefile
index 4df3d6c35e5d..96767c5abf8c 100644
--- a/devel/antlrworks/Makefile
+++ b/devel/antlrworks/Makefile
@@ -18,9 +18,9 @@ JAVA_VERSION= 1.6+
DESKTOP_ENTRIES="ANTLRWorks" \
"ANTLR GUI Development Environment" \
- "antlrworks.png" \
+ "${PREFIX}/share/pixmaps/antlrworks.png" \
"antlrworks" \
- "Application;Development;" \
+ "Development;Java;" \
true
PLIST_FILES= bin/antlrworks \
diff --git a/devel/upp/Makefile b/devel/upp/Makefile
index 69930f97e379..c0b3ec61c772 100644
--- a/devel/upp/Makefile
+++ b/devel/upp/Makefile
@@ -39,7 +39,7 @@ PORTDATA= bazaar examples reference tutorial uppsrc GCC.bm
DESKTOP_ENTRIES="TheIDE" "IDE for cross-platform C++ development" \
"${DATADIR}/uppsrc/ide/theide-48.png" "theide" \
- "Application;Development;IDE;" ${FALSE}
+ "Development;IDE;GTK;" false
OPTIONS_DEFINE= SDL OPENGL MYSQL PGSQL USEMALLOC
USEMALLOC_DESC= Compile without U++ heap allocator
diff --git a/editors/omegaT/Makefile b/editors/omegaT/Makefile
index f321939bb741..2f2bc963f0fb 100644
--- a/editors/omegaT/Makefile
+++ b/editors/omegaT/Makefile
@@ -34,8 +34,8 @@ SUB_FILES= omegaT.sh omegat.prefs
DESKTOP_ENTRIES="OmegaT" "Translation memory application" \
"${DATADIR}/images/OmegaT.png" \
- "omegaT" "Application;Office;WordProcessor;" \
- ${FALSE}
+ "omegaT" "Office;WordProcessor;Java;" \
+ false
post-build:
@cd ${WRKDIR} && ${MV} 'dist' ${PORTNAME}
diff --git a/games/gtklife/Makefile b/games/gtklife/Makefile
index f613dd92310e..385a57aefcc0 100644
--- a/games/gtklife/Makefile
+++ b/games/gtklife/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games
MASTER_SITES= http://ironphoenix.org/tril/gtklife/
MAINTAINER= eadler@FreeBSD.org
-COMMENT= A GTK+ implementation of Conway's Game of Life
+COMMENT= GTK+ implementation of Conway's Game of Life
LICENSE= GPLv2
@@ -29,7 +29,7 @@ DESKTOP_ENTRIES="GtkLife" \
"Play Conway's Game of Life" \
"gtklife" \
"gtklife" \
- "Application;Game;Simulation;" \
+ "Game;Simulation;" \
${STARTUP_NOTIFY}
OPTIONS_DEFINE= GTK2
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 698d37643ac9..ec92008fac6d 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -108,12 +108,12 @@ RUN_DEPENDS+= ${Q3SERVER}${BINSUFFIX}:${PORTSDIR}/games/${PORTNAME}-server
. if !defined(WITHOUT_CLIENT)
DESKTOP_ENTRIES+= "${Q3CLIENT} ${Q3ENGINEVER}" "${COMMENT}" \
"${Q3ICON}" \
- "${Q3CLIENT}${BINSUFFIX}" "Application;Game;" false
+ "${Q3CLIENT}${BINSUFFIX}" "Game;" false
. endif
. if defined(WITH_SMP)
DESKTOP_ENTRIES+= "${Q3CLIENT} ${Q3ENGINEVER} SMP" "${COMMENT}" \
"${Q3ICON}" \
- "${Q3CLIENT}-smp${BINSUFFIX}" "Application;Game;" false
+ "${Q3CLIENT}-smp${BINSUFFIX}" "Game;" false
. endif
.endif
diff --git a/games/meandmyshadow/Makefile b/games/meandmyshadow/Makefile
index b6a39c21ac63..0c5cff99a4e6 100644
--- a/games/meandmyshadow/Makefile
+++ b/games/meandmyshadow/Makefile
@@ -26,7 +26,7 @@ PORTDOCS= *
DESKTOP_ENTRIES="Me and My Shadow" \
"Puzzle/platform game" \
- "meandmyshadow.png" \
+ "${PREFIX}/share/pixmaps/meandmyshadow.png" \
"meandmyshadow" \
"Game;LogicGame;" \
false
diff --git a/games/pouetchess/Makefile b/games/pouetchess/Makefile
index 59f9efa4f56c..0830a7f4cc2e 100644
--- a/games/pouetchess/Makefile
+++ b/games/pouetchess/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.11
DISTNAME= pouetChess_0.11_src
MAINTAINER= amdmi3@FreeBSD.org
-COMMENT= An open-source 3D chess game
+COMMENT= Open-source 3D chess game
USE_SDL= sdl image
USE_GL= gl
@@ -25,7 +25,7 @@ DESKTOP_ENTRIES="pouetChess" \
"Play chess" \
"${DATADIR}/textures/1.png" \
"pouetChess" \
- "Application;Game;" \
+ "Game;BoardGame;" \
false
post-patch:
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
index a8e5a7cda489..2e16e2047c6a 100644
--- a/games/redeclipse/Makefile
+++ b/games/redeclipse/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}_${PORTVERSION:C/^([0-9]+\.[0-9]+)\..*/\
DISTNAME= ${PORTNAME}_${PORTVERSION}_nix_bsd
MAINTAINER= amdmi3@FreeBSD.org
-COMMENT= A single-player and multi-player first-person ego-shooter
+COMMENT= Single-player and multi-player first-person ego-shooter
LICENSE_COMB= multi
LICENSE= MIT ZLIB
@@ -58,8 +58,8 @@ DESKTOP_ENTRIES="Red Eclipse" \
"${COMMENT}" \
"${PREFIX}/share/pixmaps/redeclipse.ico" \
"reclient" \
- "Application;Game;" \
- ${FALSE}
+ "Game;" \
+ false
.endif
.if !defined(WITHOUT_DEDICATED)
diff --git a/games/scummvm/Makefile b/games/scummvm/Makefile
index a1c87ff36f8d..75119cfbd301 100644
--- a/games/scummvm/Makefile
+++ b/games/scummvm/Makefile
@@ -51,7 +51,7 @@ DESKTOP_ENTRIES="ScummVM" \
"ScummVM - Run classic adventure games" \
"${DATADIR}/scummvm.svg" \
"scummvm" \
- "Application;Game;" \
+ "Game;AdventureGame;" \
false
PLIST_FILES= bin/scummvm \
diff --git a/games/vor/Makefile b/games/vor/Makefile
index a44f53af57fa..293b5d8ab192 100644
--- a/games/vor/Makefile
+++ b/games/vor/Makefile
@@ -27,7 +27,7 @@ DESKTOP_ENTRIES="Variations on Rockdodger" \
"Dodge the rocks until you die" \
"${DATADIR}/icon.png" \
"vor" \
- "Application;Game;ArcadeGame;" \
+ "Game;ArcadeGame;" \
false
.if !defined(NOPORTDOCS)
diff --git a/graphics/kudu/Makefile b/graphics/kudu/Makefile
index 78191b51ebe9..9d47f654bcce 100644
--- a/graphics/kudu/Makefile
+++ b/graphics/kudu/Makefile
@@ -31,7 +31,7 @@ DESKTOP_ENTRIES="Kudu" \
"Edit 3D models" \
"${DATADIR}/images/logo.png" \
"kudu" \
- "Application;Graphics;" \
+ "Graphics;3DGraphics;GTK;" \
true
post-patch:
diff --git a/math/saga/Makefile b/math/saga/Makefile
index c1a5feb9d699..283a66cba4e4 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -33,7 +33,7 @@ USE_DOS2UNIX= dlg_about.cpp
MAN1= saga_cmd.1 saga_gui.1
DESKTOP_ENTRIES= "SAGA GIS" "${COMMENT}" "${DATADIR}/saga_icon_32.xpm" \
- "saga_gui" "Application;Math;" true
+ "saga_gui" "Science;Geoscience;Math;" true
OPTIONS_DEFINE= UNICODE PYTHON HARU VIGRA
OPTIONS_DEFAULT= UNICODE PYTHON
diff --git a/misc/tvbrowser/Makefile b/misc/tvbrowser/Makefile
index c6607078d819..cd899f188a80 100644
--- a/misc/tvbrowser/Makefile
+++ b/misc/tvbrowser/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= SF/${PORTNAME}/TV-Browser%20Releases%20%28Java%206%20and%20higher%
DISTNAME= ${PORTNAME}_${PORTVERSION}_bin
MAINTAINER= lme@FreeBSD.org
-COMMENT= A digital TV guide
+COMMENT= Digital TV guide
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_LDCONFIG= yes
@@ -22,10 +22,10 @@ JAVA_VERSION= 1.6+
SUB_FILES= tvbrowser
DESKTOP_ENTRIES="TV-Browser" \
- "A digital TV guide" \
+ "${COMMENT}" \
"${DATADIR}/imgs/tvbrowser128.png" \
"tvbrowser" \
- "Application;Video;AudioVideo;TV;" \
+ "Video;AudioVideo;TV;Java;" \
true
do-install:
diff --git a/multimedia/gmencoder/Makefile b/multimedia/gmencoder/Makefile
index f20df3785533..d20b91e73869 100644
--- a/multimedia/gmencoder/Makefile
+++ b/multimedia/gmencoder/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/v${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= gahr@FreeBSD.org
-COMMENT= Gmencoder is Gnome2 front-end to mplayer/mencoder
+COMMENT= Gnome2 front-end to mplayer/mencoder
BUILD_DEPENDS= mencoder:${PORTSDIR}/multimedia/mencoder
RUN_DEPENDS= mencoder:${PORTSDIR}/multimedia/mencoder
@@ -27,7 +27,7 @@ USE_GNOME= gnomehack gnomeprefix libgnomeui
MAN1= gmencoder.1
DESKTOP_ENTRIES= "Gmencoder" "Gnome2 front-end to mplayer/mencoder" \
- "" "gmencoder" "GNOME;Application;AudioVideo;" false
+ "" "gmencoder" "GNOME;AudioVideo;" false
.include <bsd.port.pre.mk>
diff --git a/net-im/mercury/Makefile b/net-im/mercury/Makefile
index 5fa374221df8..30d7680e19fc 100644
--- a/net-im/mercury/Makefile
+++ b/net-im/mercury/Makefile
@@ -41,7 +41,7 @@ DIR2PRUNE= resources/AppData/Games \
DESKTOP_ENTRIES="Mercury Messenger" "${COMMENT}" \
"${INSTDIR}/resources/online.png" \
"${SUB_FILES}" \
- "Application;InstantMessaging;Java;Network;" true
+ "InstantMessaging;Java;Network;" true
.if defined(WITH_VIDEO) # Experimental
VIDJAR= VidConf-libs.jar
diff --git a/www/kompozer/Makefile b/www/kompozer/Makefile
index 9a1cc02ba665..d44c63988be0 100644
--- a/www/kompozer/Makefile
+++ b/www/kompozer/Makefile
@@ -37,7 +37,7 @@ MOZ_OPTIONS= ${CONFIGURE_TARGET} \
DESKTOP_ENTRIES="Kompozer" "${COMMENT}" \
"${PREFIX}/lib/kompozer/icons/mozicon50.xpm" "${PORTNAME}" \
- "Application;Network;" true
+ "Network;Development;WebDevelopment;" true
NOT_FOR_ARCHS= ia64
NOT_FOR_ARCHS_REASON_ia64= does not build
diff --git a/www/links-hacked/Makefile b/www/links-hacked/Makefile
index 8ad1bfd9c969..5cafae85eb0c 100644
--- a/www/links-hacked/Makefile
+++ b/www/links-hacked/Makefile
@@ -67,9 +67,9 @@ USE_XORG= x11 xproto
CONFIGURE_ARGS+= --with-x
DESKTOP_ENTRIES="Links" \
"Lynx-like hacked WWW browser" \
- "links" \
+ "${PREFIX}/share/pixmaps/links.xpm" \
"links -g" \
- "Application;Network;WebBrowser;" \
+ "Network;WebBrowser;" \
false
PLIST_FILES+= share/pixmaps/links.xpm
.else
diff --git a/www/rssowl/Makefile b/www/rssowl/Makefile
index 7a232fa4d922..74ea876de0ae 100644
--- a/www/rssowl/Makefile
+++ b/www/rssowl/Makefile
@@ -35,10 +35,10 @@ PLIST_FILES= bin/rssowl %%DATADIR%%/rssowl.jar share/pixmaps/rssowl.png
PLIST_DIRS= %%DATADIR%%
DESKTOP_ENTRIES="RSSOwl" \
- "Read newsfeeds" \
- "rssowl.png" \
+ "Newsfeeds reader" \
+ "${PREFIX}/share/pixmaps/rssowl.png" \
"rssowl" \
- "Application;Network;News;" \
+ "Network;News;Java;" \
true
post-patch: