aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/phalcon/Makefile27
-rw-r--r--www/phalcon/distinfo2
-rw-r--r--www/phalcon/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a716f9a1d7bd..4e6b50a9f996 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1374,6 +1374,7 @@
SUBDIR += pelican
SUBDIR += perlbal
SUBDIR += pglogd
+ SUBDIR += phalcon
SUBDIR += photo_gallery
SUBDIR += php-dyn
SUBDIR += php-plurk-api
diff --git a/www/phalcon/Makefile b/www/phalcon/Makefile
new file mode 100644
index 000000000000..5fee92a379b9
--- /dev/null
+++ b/www/phalcon/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: phalcon
+# Date created: 6 May 2012
+# Whom: Jin-Sih Lin <linpct@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phalcon
+PORTVERSION= 0.3.5
+CATEGORIES= www
+MASTER_SITES= https://github.com/${PORTNAME}/c${PORTNAME}/tarball/master/
+
+MAINTAINER= linpct@gmail.com
+COMMENT= Phalcon PHP Framework written in C-language
+
+GITVERSION= bb24857
+FETCH_ARGS= -pRr
+WRKSRC= ${WRKDIR}/${PORTNAME}-c${PORTNAME}-${GITVERSION}/release/
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS= --enable-phalcon --prefix=${PREFIX} --with-php-config=${LOCALBASE}/bin/php-config
+
+USE_PHP= yes
+USE_PHPEXT= yes
+USE_PHPIZE= yes
+
+.include <bsd.port.mk>
diff --git a/www/phalcon/distinfo b/www/phalcon/distinfo
new file mode 100644
index 000000000000..be2ebd9b3fd0
--- /dev/null
+++ b/www/phalcon/distinfo
@@ -0,0 +1,2 @@
+SHA256 (phalcon-0.3.5.tar.gz) = 8ef6be0730322ed1872d9bb3deca08c5ed81068f86378a11380739861810e843
+SIZE (phalcon-0.3.5.tar.gz) = 383634
diff --git a/www/phalcon/pkg-descr b/www/phalcon/pkg-descr
new file mode 100644
index 000000000000..dbc36e170718
--- /dev/null
+++ b/www/phalcon/pkg-descr
@@ -0,0 +1,4 @@
+PhalconPHP is a web framework delivered as a C extension providing high
+performance and lower resource consumption.
+
+WWW: http://phalconphp.com/