aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/Scripts/functions.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Scripts/functions.sh b/Mk/Scripts/functions.sh
index 24bfd5544de0..5122a8abaae9 100644
--- a/Mk/Scripts/functions.sh
+++ b/Mk/Scripts/functions.sh
@@ -202,7 +202,7 @@ export_ports_env() {
# Bring in all the vars, but not empty ones.
eval $(${MAKE} -f ${PORTSDIR}/Mk/bsd.port.mk ${make_cmd} \
- USES="${uses}" | grep -v '=$')
+ USES="${uses}" | grep -v '=$' | sed -e 's,\\ $,,')
for var in ${export_vars}; do
# Export and display non-empty ones. This is not redundant
# with above since we're looping on all vars here; do not