aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/galera/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/databases/galera/Makefile b/databases/galera/Makefile
index ec3a407da589..c6192b6f9450 100644
--- a/databases/galera/Makefile
+++ b/databases/galera/Makefile
@@ -15,6 +15,17 @@ BUILD_DEPENDS= checkmk:devel/check \
${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
+NOT_FOR_ARCHS= i386
+# On i386 older versions of clang produce:
+# cannot compile this atomic library call yet ... __atomic_add_fetch
+# whereas newer ones generate a call to __atomic_add_fetch which ends up with
+# undefined reference at link time:
+# undefined reference to `__atomic_fetch_add_8'
+# https://bugs.llvm.org//show_bug.cgi?id=23262
+# https://bugs.llvm.org//show_bug.cgi?id=24908
+# https://tracker.crystax.net/issues/1263
+NOT_FOR_ARCHS_REASON_i386=Uses 64 bit atomics that clang cannot generate on i386
+
USES= execinfo python:build scons ssl
USE_LDCONFIG= yes